Topic: Dependancy Problems when trying to update

Hi Remi,

Got this working on 1 machine great, now I am having trouble on another. I have a brand new Virtual CentOS machine from MediaTemple.net.

I installed yum.

yum -y update

yum --enablerepo remi --enablerepo remi-test update php-\*

The above gives me these errors:


--> Finished Dependency Resolution
php-5.3.1-1.el4.remi.i386 from remi has depsolving problems
  --> Missing Dependency: httpd-mmn = 20020903 is needed by package php-5.3.1-1.el4.remi.i386 (remi)
php-snmp-5.3.1-1.el4.remi.i386 from remi has depsolving problems
  --> Missing Dependency: libnetsnmp.so.5 is needed by package php-snmp-5.3.1-1.el4.remi.i386 (remi)
php-imap-5.3.1-1.el4.remi.i386 from remi has depsolving problems
  --> Missing Dependency: libc-client.so.0 is needed by package php-imap-5.3.1-1.el4.remi.i386 (remi)
Error: Missing Dependency: libc-client.so.0 is needed by package php-imap-5.3.1-1.el4.remi.i386 (remi)
Error: Missing Dependency: libnetsnmp.so.5 is needed by package php-snmp-5.3.1-1.el4.remi.i386 (remi)
Error: Missing Dependency: httpd-mmn = 20020903 is needed by package php-5.3.1-1.el4.remi.i386 (remi)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest







Any suggestions?

Re: Dependancy Problems when trying to update

Yes, check your other enabled repo.

httpd-mmn = 20020903 => httpd
libnetsnmp.so.5 => net-snmp-libs
libc-client.so.0 => libc-client

All available in "base" repo.

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Dependancy Problems when trying to update

I tryed

yum --enablerepo base


Did not help sad

Re: Dependancy Problems when trying to update

i mean i tryed

yum --enablerepo base --enablerepo remi --eablerepo remi-test update php-\*

and got the same result... should i uninstall and reinstall httpd and the others?

They were preinstalled with my Server Image.

Thanks for all your help and hard work!!

Re: Dependancy Problems when trying to update

What are the result of

cat /etc/redhat-release
yum repolist
rpm -qa httpd\* net-snmp\* libc-client\* php\*

Could also be usefull to do a simple

yum update

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Dependancy Problems when trying to update

[root@php53 ~]# cat /etc/redhat-release
CentOS release 5.4 (Final)

[root@php53 ~]# yum repolist
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: mirrors.netdna.com
 * atomic: [url=http://www.atomicorp.com]www.atomicorp.com[/url]
 * base: mirror.newnanutilities.org
 * extras: mirror.facebook.net
 * updates: mirrors.easynews.com
addons                                                                                                                                                                                                                      |  951 B     00:00     
atomic                                                                                                                                                                                                                      | 1.9 kB     00:00     
atomic/primary_db                                                                                                                                                                                                           | 298 kB     00:00     
base                                                                                                                                                                                                                        | 2.1 kB     00:00     
extras                                                                                                                                                                                                                      | 1.1 kB     00:00     
plesk                                                                                                                                                                                                                       |  951 B     00:00     
updates                                                                                                                                                                                                                     | 1.9 kB     00:00     
repo id                                                                                 repo name                                                                                                                                     status
addons                                                                                  CentOS-5 - Addons                                                                                                                             enabled:    0
atomic                                                                                  CentOS / Red Hat Enterprise Linux 5 - atomicrocketturtle.com                                                                                  enabled:  489
base                                                                                    CentOS-5 - Base                                                                                                                               enabled: 2535
extras                                                                                  CentOS-5 - Extras                                                                                                                             enabled:  325
plesk                                                                                   Plesk Server Administrator                                                                                                                    enabled:  190
updates                                                                                 CentOS-5 - Updates                                                                                                                            enabled:  390
repolist: 3929



[root@php53 ~]# rpm -qa httpd\* net-snmp\* libc-client\* php\*
php-common-5.2.12-1.el5.art
php-mbstring-5.2.12-1.el5.art
net-snmp-utils-5.3.2.2-7.el5_4.2
php-pdo-5.2.12-1.el5.art
php-devel-5.2.12-1.el5.art
php-pear-1.7.2-2.el5.art
php-ldap-5.2.12-1.el5.art
net-snmp-libs-5.3.2.2-7.el5_4.2
php-cli-5.2.12-1.el5.art
php-5.2.12-1.el5.art
php-imap-5.2.12-1.el5.art
php-xml-5.2.12-1.el5.art
libc-client-2004g-2.2.1
httpd-2.2.3-31.el5.centos.2
php-mysql-5.2.12-1.el5.art
php-mhash-5.2.12-1.el5.art
php-xmlrpc-5.2.12-1.el5.art
net-snmp-5.3.2.2-7.el5_4.2
php5-ioncube-loader-3.1-07051711
php-odbc-5.2.12-1.el5.art
php-ncurses-5.2.12-1.el5.art
net-snmp-devel-5.3.2.2-7.el5_4.2
php-gd-5.2.12-1.el5.art
httpd-devel-2.2.3-31.el5.centos.2
php-mcrypt-5.2.12-1.el5.art
php-snmp-5.2.12-1.el5.art

Re: Dependancy Problems when trying to update

Just did:

yum update

it updated some php to 5.2.x

then tryed:

[root@php53 ~]# yum --enablerepo base --enablerepo remi --enablerepo remi-test update php-\*
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: mirrors.netdna.com
 * atomic: [url=http://www.atomicorp.com]www.atomicorp.com[/url]
 * base: mirror.newnanutilities.org
 * extras: mirror.facebook.net
 * remi: iut-info.univ-reims.fr
 * updates: mirrors.versaweb.com
addons                                                                                                                                                                                                                      |  951 B     00:00     
atomic                                                                                                                                                                                                                      | 1.9 kB     00:00     
base                                                                                                                                                                                                                        | 2.1 kB     00:00     
extras                                                                                                                                                                                                                      | 1.1 kB     00:00     
plesk                                                                                                                                                                                                                       |  951 B     00:00     
remi                                                                                                                                                                                                                        | 2.3 kB     00:00     
remi-test                                                                                                                                                                                                                   | 2.3 kB     00:00     
updates                                                                                                                                                                                                                     | 1.9 kB     00:00     
Setting up Update Process
Package matching php-common-5.3.0-1.el4.remi.i386 already installed. Checking for update.
Resolving Dependencies
--> Running transaction check
---> Package php.i386 0:5.3.1-1.el4.remi set to be updated
--> Processing Dependency: httpd-mmn = 20020903 for package: php
--> Processing Dependency: libssl.so.4 for package: php
--> Processing Dependency: libcrypto.so.4 for package: php
---> Package php-cli.i386 0:5.3.1-1.el4.remi set to be updated
--> Processing Dependency: libedit.so.0 for package: php-cli
---> Package php-common.i386 0:5.3.1-1.el4.remi set to be updated
---> Package php-devel.i386 0:5.3.1-1.el4.remi set to be updated
---> Package php-gd.i386 0:5.3.1-1.el4.remi set to be updated
---> Package php-imap.i386 0:5.3.1-1.el4.remi set to be updated
--> Processing Dependency: libc-client.so.0 for package: php-imap
---> Package php-ldap.i386 0:5.3.1-1.el4.remi set to be updated
--> Processing Dependency: libldap-2.2.so.7 for package: php-ldap
--> Processing Dependency: liblber-2.2.so.7 for package: php-ldap
---> Package php-mbstring.i386 0:5.3.1-1.el4.remi set to be updated
---> Package php-mcrypt.i386 0:5.3.1-1.el4.remi set to be updated
--> Processing Dependency: libltdl.so.3 for package: php-mcrypt
---> Package php-mysql.i386 0:5.3.1-1.el4.remi set to be updated
--> Processing Dependency: libmysqlclient.so.16 for package: php-mysql
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16) for package: php-mysql
---> Package php-odbc.i386 0:5.3.1-1.el4.remi set to be updated
---> Package php-pdo.i386 0:5.3.1-1.el4.remi set to be updated
--> Processing Dependency: libsqlite.so.0 for package: php-pdo
---> Package php-pear.noarch 1:1.9.0-2.el4.remi set to be updated
---> Package php-pecl-ncurses.i386 0:1.0.1-1.el4.remi set to be updated
---> Package php-snmp.i386 0:5.3.1-1.el4.remi set to be updated
--> Processing Dependency: libnetsnmp.so.5 for package: php-snmp
---> Package php-xml.i386 0:5.3.1-1.el4.remi set to be updated
---> Package php-xmlrpc.i386 0:5.3.1-1.el4.remi set to be updated
--> Running transaction check
---> Package compat-openldap.i386 0:2.3.43_2.2.29-3.el5 set to be updated
---> Package libedit.i386 0:2.11-1.20080712cvs.el4.remi set to be updated
---> Package libtool-ltdl.i386 0:1.5.22-7.el5_4 set to be updated
--> Processing Dependency: libmysqlclient.so.15 for package: psa-fileserver
--> Processing Dependency: libmysqlclient.so.15 for package: psa-hotfix3
--> Processing Dependency: libmysqlclient.so.15 for package: mysql-devel
--> Processing Dependency: libmysqlclient.so.15 for package: psa
--> Processing Dependency: libmysqlclient.so.15 for package: psa-hotfix4-8.6.0
--> Processing Dependency: libmysqlclient.so.15 for package: mysql
--> Processing Dependency: libmysqlclient.so.15 for package: psa-qmail
--> Processing Dependency: libmysqlclient.so.15 for package: perl-DBD-MySQL
--> Processing Dependency: libmysqlclient.so.15 for package: psa-courier-imap-add
--> Processing Dependency: libmysqlclient.so.15 for package: mysql-server
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package: psa-fileserver
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package: mysql
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package: mysql-server
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package: perl-DBD-MySQL
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package: psa-courier-imap-add
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package: psa-qmail
--> Processing Dependency: libmysqlclient_r.so.15 for package: mysql-server
--> Processing Dependency: libmysqlclient_r.so.15 for package: mysql-devel
--> Processing Dependency: libmysqlclient_r.so.15(libmysqlclient_15) for package: mysql-server
--> Processing Dependency: libndbclient.so.2 for package: mysql-devel
--> Processing Dependency: mysql-libs = 5.0.89-1.el5.art for package: mysql
---> Package mysql-libs.i386 0:5.1.42-1.el4.remi set to be updated
---> Package openssl097a.i386 0:0.9.7a-9.el5_2.1 set to be updated
---> Package php.i386 0:5.3.1-1.el4.remi set to be updated
--> Processing Dependency: httpd-mmn = 20020903 for package: php
---> Package php-imap.i386 0:5.3.1-1.el4.remi set to be updated
--> Processing Dependency: libc-client.so.0 for package: php-imap
---> Package php-snmp.i386 0:5.3.1-1.el4.remi set to be updated
--> Processing Dependency: libnetsnmp.so.5 for package: php-snmp
---> Package sqlite2.i386 0:2.8.17-2.el4.remi set to be updated
--> Processing Dependency: libreadline.so.4 for package: sqlite2
--> Running transaction check
---> Package compat-readline43.i386 0:4.3-3 set to be updated
--> Processing Dependency: mysql = 5.0.89-1.el5.art for package: mysql-bench
---> Package mysql.i386 0:5.1.42-1.el4.remi set to be updated
---> Package mysql-devel.i386 0:5.1.42-1.el4.remi set to be updated
---> Package mysql-server.i386 0:5.1.42-1.el4.remi set to be updated
---> Package mysqlclient15.i386 0:5.0.67-1.el4.remi set to be updated
---> Package php.i386 0:5.3.1-1.el4.remi set to be updated
--> Processing Dependency: httpd-mmn = 20020903 for package: php
---> Package php-imap.i386 0:5.3.1-1.el4.remi set to be updated
--> Processing Dependency: libc-client.so.0 for package: php-imap
---> Package php-snmp.i386 0:5.3.1-1.el4.remi set to be updated
--> Processing Dependency: libnetsnmp.so.5 for package: php-snmp
--> Running transaction check
---> Package mysql-bench.i386 0:5.1.42-1.el4.remi set to be updated
---> Package php.i386 0:5.3.1-1.el4.remi set to be updated
--> Processing Dependency: httpd-mmn = 20020903 for package: php
---> Package php-imap.i386 0:5.3.1-1.el4.remi set to be updated
--> Processing Dependency: libc-client.so.0 for package: php-imap
---> Package php-snmp.i386 0:5.3.1-1.el4.remi set to be updated
--> Processing Dependency: libnetsnmp.so.5 for package: php-snmp
--> Finished Dependency Resolution
php-5.3.1-1.el4.remi.i386 from remi has depsolving problems
  --> Missing Dependency: httpd-mmn = 20020903 is needed by package php-5.3.1-1.el4.remi.i386 (remi)
php-snmp-5.3.1-1.el4.remi.i386 from remi has depsolving problems
  --> Missing Dependency: libnetsnmp.so.5 is needed by package php-snmp-5.3.1-1.el4.remi.i386 (remi)
php-imap-5.3.1-1.el4.remi.i386 from remi has depsolving problems
  --> Missing Dependency: libc-client.so.0 is needed by package php-imap-5.3.1-1.el4.remi.i386 (remi)
Error: Missing Dependency: libc-client.so.0 is needed by package php-imap-5.3.1-1.el4.remi.i386 (remi)
Error: Missing Dependency: libnetsnmp.so.5 is needed by package php-snmp-5.3.1-1.el4.remi.i386 (remi)
Error: Missing Dependency: httpd-mmn = 20020903 is needed by package php-5.3.1-1.el4.remi.i386 (remi)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Re: Dependancy Problems when trying to update

here is the rpm query after yum update

[root@php53 ~]# rpm -qa httpd\* net-snmp\* libc-client\* php\*
net-snmp-utils-5.3.2.2-7.el5_4.2
php-5.2.12-2.el5.art
php-pear-1.7.2-2.el5.art
php-common-5.2.12-2.el5.art
php-imap-5.2.12-2.el5.art
php-gd-5.2.12-2.el5.art
net-snmp-libs-5.3.2.2-7.el5_4.2
php-pdo-5.2.12-2.el5.art
php-mysql-5.2.12-2.el5.art
php-odbc-5.2.12-2.el5.art
php-ldap-5.2.12-2.el5.art
php-mbstring-5.2.12-2.el5.art
libc-client-2004g-2.2.1
httpd-2.2.3-31.el5.centos.2
php-cli-5.2.12-2.el5.art
php-xml-5.2.12-2.el5.art
php-devel-5.2.12-2.el5.art
php-xmlrpc-5.2.12-2.el5.art
net-snmp-5.3.2.2-7.el5_4.2
php5-ioncube-loader-3.1-07051711
net-snmp-devel-5.3.2.2-7.el5_4.2
php-ncurses-5.2.12-2.el5.art
php-mhash-5.2.12-2.el5.art
httpd-devel-2.2.3-31.el5.centos.2
php-snmp-5.2.12-2.el5.art
php-mcrypt-5.2.12-2.el5.art

Re: Dependancy Problems when trying to update

It seems you are running EL5, so you must use remi for EL5 (not for EL4, according to your first post)

Missing : EPEL repository

And I don't know if plesk will run with latest PHP 5.3 (you will probably have issue with ioncube)

Please read : http://blog.famillecollet.com/pages/Config-en

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Dependancy Problems when trying to update

sad

I got EPEL on there, tryed

yum update then yum --enablerepo remi update php-\*

and still the same thing.

I'm starting to think I'm not going to get this to work easily, since my whole point was to make this a repeatable process to deply on my production server.

I read the link you sent, but it only made me more confused.

Re: Dependancy Problems when trying to update

As I said : "so you must use remi for EL5"

So :

wget http://rpms.famillecollet.com/enterprise/remi-release-5.rpm
rpm -Uvh remi-release-5.rpm

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Dependancy Problems when trying to update

THANK YOU REMI!!!!!!


I'm an idiot! I copied the repo files from my other server (which must be el4) and never thought to check the version.

Even after what you said, I had a dependency problem with php-hash. Since I don't have anything that I know I need it for, I removed it.

I tried to reinstall so you can see the error. Not sure if its a known issue.

[root@php53 ~]# yum install php-mhash
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: mirrors.netdna.com
* atomic: www.atomicorp.com
* base: mirror.newnanutilities.org
* epel: mirrors.solfo.com
* extras: mirror.facebook.net
* updates: mirrors.versaweb.com
addons                                                                                                                                                                                                                      |  951 B     00:00     
atomic                                                                                                                                                                                                                      | 1.9 kB     00:00     
base                                                                                                                                                                                                                        | 2.1 kB     00:00     
epel                                                                                                                                                                                                                        | 3.4 kB     00:00     
extras                                                                                                                                                                                                                      | 1.1 kB     00:00     
plesk                                                                                                                                                                                                                       |  951 B     00:00     
updates                                                                                                                                                                                                                     | 1.9 kB     00:00     
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-mhash.i386 0:5.2.12-2.el5.art set to be updated
--> Processing Dependency: php-common = 5.2.12-2.el5.art for package: php-mhash
--> Finished Dependency Resolution
php-mhash-5.2.12-2.el5.art.i386 from atomic has depsolving problems
  --> Missing Dependency: php-common = 5.2.12-2.el5.art is needed by package php-mhash-5.2.12-2.el5.art.i386 (atomic)
Error: Missing Dependency: php-common = 5.2.12-2.el5.art is needed by package php-mhash-5.2.12-2.el5.art.i386 (atomic)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

I have not yet checked if plesk still works, or if php 5.3 is running correctly, but yum compiled everything. Will report back.

Re: Dependancy Problems when trying to update

mhash extension is deprecated.
http://fr2.php.net/manual/en/intro.mhash.php

Should you Hash instead
http://fr2.php.net/manual/en/book.hash.php

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Dependancy Problems when trying to update

Now mysql wont start

[root@php53 ~]# service mysqld start
MySQL Daemon failed to start.
Starting MySQL:                                            [FAILED]
100110 22:59:30 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
100110 22:59:30 [Warning] option 'innodb-additional-mem-pool-size': signed value 512000 adjusted to 524288
100110 22:59:30 [Note] Plugin 'ndbcluster' is disabled.
/usr/libexec/mysqld: Table 'mysql.plugin' doesn't exist
100110 22:59:30 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
100110 22:59:30  InnoDB: Started; log sequence number 0 745387
100110 22:59:30 [ERROR] /usr/libexec/mysqld: unknown option '--skip-bdb'
100110 22:59:30 [ERROR] Aborting

100110 22:59:30  InnoDB: Starting shutdown...
100110 22:59:31  InnoDB: Shutdown completed; log sequence number 0 745387
100110 22:59:31 [Note] /usr/libexec/mysqld: Shutdown complete

100110 22:59:31 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended

Re: Dependancy Problems when trying to update

mhash not needed... didnt know it had been deprecated. thanks

just need to try and solve the mysql issue.

Re: Dependancy Problems when trying to update

I think, the answer is in the ERROR message... (mysql_upgrade)

Please :
http://dev.mysql.com/doc/refman/5.1/en/upgrade.html
http://dev.mysql.com/doc/refman/5.1/en/ … grade.html

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Dependancy Problems when trying to update

OK, I should have spent some more time with mysql before asking for help.

I had tried mysql_upgrade before the last post but it would not work because it needs to connect to a running server.

The key was the weird option in my my.cnf from before the upgrade.

It was --skip-bdb.

I commented it out and mysql started right up.

I then ran mysql_upgrade. And it seems all is well.

Thanks for all your help.

I am going to try and write a script to upgrade to php 5.3 specific to this host and your repos. I will post it here.

Re: Dependancy Problems when trying to update

#!/bin/bash

#install yum
rpm -Uvh http://mirror.centos.org/centos/5/os/i386/CentOS/python-iniparse-0.2.3-4.el5.noarch.rpm
rpm -Uvh http://mirror.centos.org/centos/5/os/i386/CentOS/yum-3.2.22-20.el5.centos.noarch.rpm http://mirror.centos.org/centos/5/os/i386/CentOS/yum-fastestmirror-1.1.16-13.el5.centos.noarch.rpm

#install atomic repo
wget -q -O - http://www.atomicorp.com/installers/atomic.sh | sh
wget http://www.atomicrocketturtle.com/RPM-GPG-KEY.art.txt
rpm --import RPM-GPG-KEY.art.txt

#install epel repo
wget http://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-3.noarch.rpm
rpm -Uvh epel-release-5*.rpm

#install remi repo
wget http://rpms.famillecollet.com/enterprise/remi-release-5.rpm
rpm -Uvh remi-release-5.rpm

#update
yum -y update

#remove php-mhash (depricated)
yum remove php-mhash

#update php
yum --enablerepo remi --enablerepo remi-test update php-\*

#comment out "skip-bdb"
vi /etc/my.cnf

#start mysql & upgrade
service mysqld start
mysql_upgrade -u admin -p`cat /etc/psa/.psa.shadow`

Re: Dependancy Problems when trying to update

Hi,

I'm not very well versed in all this but I'm trying to comment out "skip-bdb" in vim but have no idea how to do it once I'm in the editor.

Can you give me instructions on how to do this?

THanks for your help.

Re: Dependancy Problems when trying to update

@ekang

Although a simple google search on VI/VIM would prob answer your question...

Once in VIM, hit "i" (for insert) then enter the "#" character (i think) then "Esc" ":" "wq"

For more info on VI, here is a handy cheat sheet: http://www.atmos.albany.edu/deas/atmcla … _sheet.pdf

Re: Dependancy Problems when trying to update

Thanks for the quick reply.

Am I supposed to just put the "#" in front of "skip-bdb" or everything?

#skip-bdb

set-variable = innodb_buffer_pool_size=2M
set-variable = innodb_additional_mem_pool_size=500K
set-variable = innodb_log_buffer_size=500K
set-variable = innodb_thread_concurrency=2
[mysqld_safe]
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid
#skip-bdb


Thanks for your help dh.

Re: Dependancy Problems when trying to update

just every occurance of "skip-bdb" (like you have shown)

Re: Dependancy Problems when trying to update

NOTICE: I have officially moved this topic (PHP 5.3 on MT) to my blog so I can provide better help to those who need it. Please visit, comment, etc. I WILL NOT provide further support on the MT or Remi forums as it is taking too much of my time.

Thanks & Good Luck!

http://www.dbdblog.com/php-5-3-remi-mt- … emi-repos/