1 (edited by danypd69 2010-03-02 15:07:04)

Topic: PHP Suhosin - php5.3.1 / x86_64

Hello
I just installed a new server with CentOS 5.4,  I have added the remi repository for php+mysql and I'm unable to install php-suhosin

I get this error message

[root@localhost daniele]# yum install php-suhosin
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: centos.fastbull.org
* base: centos.fastbull.org
* epel: ftp.uni-bayreuth.de
* extras: centos.mirror.range-id.it
* remi: iut-info.univ-reims.fr
* updates: centos.mirror.range-id.it
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-suhosin.x86_64 0:0.9.29-3.el5 set to be updated
--> Processing Dependency: php-zend-abi = 20050922 for package: php-suhosin
--> Finished Dependency Resolution
php-suhosin-0.9.29-3.el5.x86_64 from epel has depsolving problems
  --> Missing Dependency: php-zend-abi = 20050922 is needed by package php-suhosin-0.9.29-3.el5.x86_64 (epel)
Error: Missing Dependency: php-zend-abi = 20050922 is needed by package php-suhosin-0.9.29-3.el5.x86_64 (epel)

The installed php package is php-5.3.1-1.el5.remi

Re: PHP Suhosin - php5.3.1 / x86_64

php-suhosin in EPEL repo works with PHP 5.1.6

php-suhosin from remi repo works with PHP 5.3.x

So

yum --enablerepo=remi --disablerepo=epel  install  php-suhosin

I should raise "release" in my repo (=1) to avoid this issue (>=3)

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: PHP Suhosin - php5.3.1 / x86_64

I've just upload the php-suhosin-0.9.29-3.el5.remi which fix the issue.

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: PHP Suhosin - php5.3.1 / x86_64

Thanks a lot... I did not see the (epel) tag in the error message :-(