Topic: PHP 5.3.0 vs 5.3.2

Dear Remi,
first of all, thank you very much for your repository!

I have two twin PCs, both installed with CentOS 5.4
The first machine was upgraded with PHP 5.3.0 using your repo, all is fine;

I installed the second one a few days ago, and upgraded with PHP 5.3.2 using your repo: all seemed fine, but PHP is continuously crashing with "Segmentation Faults" messages in the httpd's error.log

I searched on Internet, and I found that this may be a bug in the 5.3.2 version (many people reported that on different projects), so I searched a way to install the working 5.3.0, but I can't find any repo containing this version.

Since I would not like to go back to the 5.2.10 (available on CentOS-testing repo), can you suggest me a location where to find the 5.3.0 RPMs?
Or can you re-publish them on your repo, please?

Thank you in advance!

Re: PHP 5.3.0 vs 5.3.2

Which projects ? (can you give me some links, projects or upstream bugs ?)
I know that gallery2 is affected

Have you try 5.3.1 which is still available in the repo ?

Have you try a common workaround to set zend.enable_gc to off ?


+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: PHP 5.3.0 vs 5.3.2

Funny... it seems that I can't find any more other involved projects but gallery2!
Anyway, many of them reported the issue when using functions involving GD and Preg libraries.
In my case, I'm using a project of mine, in which I do some MySql queries via AdoDB with mysqli interface (tried v4.84 and v5.10 standalone, not the one in your repository): some queries goes OK and other crashes... and I did not find any precise rule that makes me understand where the problem is.

I tried the workaround you mentioned, but unfortunately it has not worked.

I did not tried the version 5.3.1, since I did not found it via yum, but now I see that's always been there, so I'll try it and make you know wink

Thank you!

Re: PHP 5.3.0 vs 5.3.2

Hi Remi,
I re-installed the new PC with CentOS 5.4 and upgraded php/mysql with:

yum --enablerepo=remi --exclude=php*5.3.2* php mysql

So now I have php 5.3.1 and mysql 5.1.14 installed and perfectly working, as expected.

Thank you very much for your suggestion!

Re: PHP 5.3.0 vs 5.3.2

I have work a bit on this issue.

It seems th bug is fixed in 5.3.3-dev

I will probably push RPM to remi-test and try to patch 5.3.2

Stay tuned.

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: PHP 5.3.0 vs 5.3.2

I have push a php 5.3.2 update

For EL5 in remi-test
For F12 in updates-testings

Please try this build. It seems to fix, at least, gallery2 issue.

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test