Topic: Postfix mysql-libs conflict?

Hello,

When attempting to install MySQL-libs 5.5 on CentOS 6.2 x86_64 (@base, @core), I run into the following issue:

Error: Package: 2:postfix-2.6.6-2.2.el6_1.x86_64 (@anaconda-CentOS-201107091641.x86_64/6.2)
           Requires: libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Removing: mysql-libs-5.1.52-1.el6_0.1.x86_64 (@anaconda-CentOS-201107091641.x86_64/6.2)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Updated By: mysql-libs-5.5.19-1.el6.x86_64 (mysql)
               Not found
Error: Package: 2:postfix-2.6.6-2.2.el6_1.x86_64 (@anaconda-CentOS-201107091641.x86_64/6.2)
           Requires: libmysqlclient.so.16()(64bit)
           Removing: mysql-libs-5.1.52-1.el6_0.1.x86_64 (@anaconda-CentOS-201107091641.x86_64/6.2)
               libmysqlclient.so.16()(64bit)
           Updated By: mysql-libs-5.5.19-1.el6.x86_64 (mysql)
               Not found

Admittedly, I used your mysql55.spec from github to compile the package. When I do rpm -qR postfix, I see that it relies on the following:

libmysqlclient.so.16()(64bit)
libmysqlclient.so.16(libmysqlclient_16)(64bit)

Is there a way to correct the issue to correct this particular issue?

Re: Postfix mysql-libs conflict?

Install compat-mysql51

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Postfix mysql-libs conflict?

Remi, thank you.