Topic: Comment revenir à une version précédente pour mysql

Bonjour,

Nous avons installé la dernière version rpm pour Mysql, la 5.5.28-3 sur RH 6 Linux 64bits, et depuis ce temps des problèmes d'accès disque très importants sont apparus. Nous aimerions pouvoir ré-installer la 5.5.28-1.

Pouvez-nous nous indiquer la procédure?

Merci.

Marc Langevin

Re: Comment revenir à une version précédente pour mysql

> À titre d'information, avez-vous eu d'autres commentaires au sujet de problèmes de performances avec le 5.5.28-3?
Non.

> Nous aimerions pouvoir ré-installer la 5.5.28-1.
Elle est toujours dans le dépôt (je garde toujours 2 versions en ligne)

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Comment revenir à une version précédente pour mysql

Je l'ai trouvé merci.

On a qu'à faire une rpm -Uhv du package?

Re: Comment revenir à une version précédente pour mysql

L'exécution de yum downgrade donnent les erreurs suivantes:
[root@si-bd01 lanm2434]# yum --enablerepo=remi  downgrade mysql
Loaded plugins: product-id, refresh-packagekit, rhnplugin, security, subscription-manager
Updating certificate-based repositories.
Unable to read consumer identity
Setting up Downgrade Process
Resolving Dependencies
--> Running transaction check
---> Package mysql.x86_64 0:5.5.28-1.el6.remi will be a downgrade
--> Processing Dependency: mysql-libs(x86-64) = 5.5.28-1.el6.remi for package: mysql-5.5.28-1.el6.remi.x86_64
---> Package mysql.x86_64 0:5.5.28-3.el6.remi will be erased
--> Finished Dependency Resolution
Error: Package: mysql-5.5.28-1.el6.remi.x86_64 (remi)
           Requires: mysql-libs(x86-64) = 5.5.28-1.el6.remi
           Installed: mysql-libs-5.5.28-3.el6.remi.x86_64 (@remi)
               mysql-libs(x86-64) = 5.5.28-3.el6.remi
           Available: mysql-libs-5.1.47-4.el6.x86_64 (rhel-x86_64-server-6)
               mysql-libs(x86-64) = 5.1.47-4.el6
           Available: mysql-libs-5.1.52-1.el6_0.1.x86_64 (rhel-x86_64-server-6)
               mysql-libs(x86-64) = 5.1.52-1.el6_0.1
           Available: mysql-libs-5.1.61-1.el6_2.1.x86_64 (rhel-x86_64-server-6)
               mysql-libs(x86-64) = 5.1.61-1.el6_2.1
           Available: mysql-libs-5.1.61-4.el6.x86_64 (rhel-x86_64-server-6)
               mysql-libs(x86-64) = 5.1.61-4.el6
           Available: mysql-libs-5.1.66-1.el6_3.x86_64 (rhel-x86_64-server-6)
               mysql-libs(x86-64) = 5.1.66-1.el6_3
           Available: mysql-libs-5.1.66-2.el6_3.x86_64 (rhel-x86_64-server-6)
               mysql-libs(x86-64) = 5.1.66-2.el6_3
           Available: mysql-libs-5.5.28-1.el6.remi.x86_64 (remi)
               mysql-libs(x86-64) = 5.5.28-1.el6.remi
Error: Package: mysql-server-5.5.28-3.el6.remi.x86_64 (@remi)
           Requires: mysql(x86-64) = 5.5.28-3.el6.remi
           Removing: mysql-5.5.28-3.el6.remi.x86_64 (@remi)
               mysql(x86-64) = 5.5.28-3.el6.remi
           Downgraded By: mysql-5.5.28-1.el6.remi.x86_64 (remi)
               mysql(x86-64) = 5.5.28-1.el6.remi
           Available: mysql-5.1.47-4.el6.x86_64 (rhel-x86_64-server-6)
               mysql(x86-64) = 5.1.47-4.el6
           Available: mysql-5.1.52-1.el6_0.1.x86_64 (rhel-x86_64-server-6)
               mysql(x86-64) = 5.1.52-1.el6_0.1
           Available: mysql-5.1.61-1.el6_2.1.x86_64 (rhel-x86_64-server-6)
               mysql(x86-64) = 5.1.61-1.el6_2.1
           Available: mysql-5.1.61-4.el6.x86_64 (rhel-x86_64-server-6)
               mysql(x86-64) = 5.1.61-4.el6
           Available: mysql-5.1.66-1.el6_3.x86_64 (rhel-x86_64-server-6)
               mysql(x86-64) = 5.1.66-1.el6_3
           Available: mysql-5.1.66-2.el6_3.x86_64 (rhel-x86_64-server-6)
               mysql(x86-64) = 5.1.66-2.el6_3
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
mailscanner-mrtg-0.10.00-1.noarch has missing requires of mailscanner >= ('0', '4.0', None)

Re: Comment revenir à une version précédente pour mysql

Il faut donner la liste explicite des paquets à rétrograder.

yum --enablerepo=remi  downgrade mysql mysql-server mysql-libs
Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Comment revenir à une version précédente pour mysql

Merci!