1 (edited by sido36 2010-09-04 11:34:22)

Topic: [Réglé] epel-release conflicts with fedora-release

Bonjour à tous,

yum upgrade me retourne l'erreur suivante:

# yum upgrade
Loading "installonlyn" plugin
Setting up Upgrade Process
Setting up repositories
epel                      100% |=========================| 3.4 kB    00:00
core                      100% |=========================| 1.1 kB    00:00
updates                   100% |=========================| 1.2 kB    00:00
remi                      100% |=========================| 2.6 kB    00:00
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
3e7232ad3a8bc103904d37429 100% |=========================| 145 kB    00:00
remi      : ################################################## 469/469
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package epel-release.noarch 0:5-4 set to be updated
--> Running transaction check
--> Processing Conflict: epel-release conflicts fedora-release
--> Finished Dependency Resolution
Error: epel-release conflicts with fedora-release

Une suggestion ?

Merci  wink

Re: [Réglé] epel-release conflicts with fedora-release

Tu as configuré le dépôt remi pour "Enterprise Linux" au lieu de celui pour "fedora"

Relit à nouveau la page de configuration

+

P.S. c'est quelle version de fedora ? visiblement une vieille version non maintenue...

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: [Réglé] epel-release conflicts with fedora-release

Salut,

Désolé de la réponse tardive.

Mon serveur est sous Centos x64. Mais ta question m'a fait réaliser que c'est une FC6.

J'ai essayé de mettre à jour le dépôt sur la page de config, mais ça ne passe pas pour les mêmes raisons que précédemment:

# rpm -Uvh epel-release-5*.rpm
error: Failed dependencies:
        fedora-release conflicts with epel-release-5-4.noarch

Pour l'instant, le dépôt 5.3 est installé. Impossible de mettre le 5.4.

Re: [Réglé] epel-release conflicts with fedora-release

EPEL est conçu pour Enterprise Linux (RHEL, CentOS), pas pour fedora.

Donc il ne faut pas l'installer.

Le controle étant récent, tu as certainement pu (à tord) installer la version précédente.
Donc commence par :

rpm --erase remi-release epel-release

Puisque c'est une FC6, il faut lire le paragraphe  "Pour Fedora Core 6 i386, ppc ou x86_64", donc :

wget http://rpms.famillecollet.com/remi-release-6.rpm
rpm -Uvh remi-release-6.rpm

+

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: [Réglé] epel-release conflicts with fedora-release

Merci, problème réglé !

La question maintenant est surtout de savoir pourquoi j'étais persuadé d'être sous Centos ! hmm