1 (edited by kiterfoo 2010-10-27 10:41:04)

Topic: installer une vieille version de php avec les SRC.RPM

Bonjour,
j'ai besoin de travailler sur la version 5.3.1 de php car le code de notre appli ne fonction pas sous 5.3.3.
serveur Centos 5  2.6.18-194.11.3.el5 #1 SMP Mon Aug 30 16:23:24 EDT 2010 i686 i686 i386 GNU/Linux.
de ce fait, je tente de refaire les rpm de la version 5.3.1 a partir des sources "php-5.3.1-1.remi.src.rpm".
cependant a la commande "rpmbuild --rebuild php-5.3.1-1.remi.src.rpm" ou "rpmbuild -ba rpmbuild/SPECS/php-5.3.1-remi.spec" apres un "rpm -ivh php-5.3.1-1.remi.src.rpm" me donne tout deux le meme message d'erreur :
erreur: /root/rpmbuild/SPECS/php-5.3.1-remi.spec:25: parseExpressionBoolean retourne -1
erreur: Le champ Name doit être présent dans le paquetage: (main package)
erreur: Le champ Version doit être présent dans le paquetage: (main package)
erreur: Le champ Release doit être présent dans le paquetage: (main package)
erreur: Le champ Summary doit être présent dans le paquetage: (main package)
erreur: Le champ Group doit être présent dans le paquetage: (main package)
erreur: Le champ License doit être présent dans le paquetage: (main package)

je n'ai pas trouver grand chose avec google, peut etre que quelqu'un de plus experimenter en RPM que moi connais deja la reponse ...
Cordialement

Re: installer une vieille version de php avec les SRC.RPM

> erreur: /root/rpmbuild/...
ça commence très mal... on ne construit jamais un RPM sous root

Essaie en utilisant : rpmbuild --define "rhel 5" ...

Et sinon, il serait pas plus simple / rentable de corriger l'application ?

Entre 5.3.1 et 5.3.3 il n'y a pas des masses de chagement... d'ailleurs je vois même pas ce qui pourrait bloquer (la seule incompatibilité, c'est les constructeurs dans les namespaces, qui est quand même d'une utilisation très rare, et très facile à corriger)

+

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: installer une vieille version de php avec les SRC.RPM

Bonjour,

Effectivement j'ai fait un copier/coller pour le compte root, mais c'est apres avoir essayer avec le compte "fairerpm" crée pour l'occasion, mais meme message d'erreur.

Sinon la solution que tu m'a donné, fonctionne parfaitement apres avoir resolu les quelques dependences renvoyé par la commande.
Mes sinceres remerciement.

en ce qui concerne la 5.3.3, je suis tout a fait pour, cependant les develloppeurs utilise sur leur postes Xamp qui lui est en 5.3.1, je fais mon possible pour qu'il devellope directement sur un serveur de teste, mais c'est pas facile avec des fonctionnaires smile
(ils utilisent eclipse/svn et me dise que ca ne fonctionne pas avec les serveurs de dev, je vais investiguer des que j'aurais un peu de temps)

Encore merci pour ton travaille, ca m'aide beaucoup dans le travail que l'on me demande.

Cordialement