Topic: Mise à jour php-5.5.4

Bonjour,

tout d'abord merci pour ton site et ton travail colossal :-)

voila j'ai un problème
lorsque je veux faire la mise à jour
je me retrouve avec ce message d'erreur

Error: Package: php-magickwand-1.0.9.2-4.el6.remi.x86_64 (@remi)
           Requires: php(zend-abi) = 20100525-x86-64
           Removing: php-common-5.4.20-1.el6.remi.x86_64 (@remi)
               php(zend-abi) = 20100525-x86-64
           Updated By: php-common-5.5.4-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(zend-abi) = 20090626
           Available: php-common-5.4.19-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.5.3-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
Error: Package: php-pecl-imagick-3.1.2-1.el6.remi.x86_64 (@remi)
           Requires: php(zend-abi) = 20100525-x86-64
           Removing: php-common-5.4.20-1.el6.remi.x86_64 (@remi)
               php(zend-abi) = 20100525-x86-64
           Updated By: php-common-5.5.4-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(zend-abi) = 20090626
           Available: php-common-5.4.19-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.5.3-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
Error: Package: php-pecl-imagick-3.1.2-1.el6.remi.x86_64 (@remi)
           Requires: php(api) = 20100412-x86-64
           Removing: php-common-5.4.20-1.el6.remi.x86_64 (@remi)
               php(api) = 20100412-x86-64
           Updated By: php-common-5.5.4-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(api) = 20090626
           Available: php-common-5.4.19-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.5.3-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
Error: Package: php-pecl-igbinary-1.1.2-0.1.git3b8ab7e.el6.remi.x86_64 (@remi)
           Requires: php(api) = 20100412-x86-64
           Removing: php-common-5.4.20-1.el6.remi.x86_64 (@remi)
               php(api) = 20100412-x86-64
           Updated By: php-common-5.5.4-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(api) = 20090626
           Available: php-common-5.4.19-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.5.3-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
Error: Package: php-pecl-memcached-2.1.0-6.el6.remi.1.x86_64 (@remi)
           Requires: php(api) = 20100412-x86-64
           Removing: php-common-5.4.20-1.el6.remi.x86_64 (@remi)
               php(api) = 20100412-x86-64
           Updated By: php-common-5.5.4-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(api) = 20090626
           Available: php-common-5.4.19-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.5.3-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
Error: Package: php-pecl-igbinary-1.1.2-0.1.git3b8ab7e.el6.remi.x86_64 (@remi)
           Requires: php(zend-abi) = 20100525-x86-64
           Removing: php-common-5.4.20-1.el6.remi.x86_64 (@remi)
               php(zend-abi) = 20100525-x86-64
           Updated By: php-common-5.5.4-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(zend-abi) = 20090626
           Available: php-common-5.4.19-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.5.3-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
Error: Package: php-pecl-memcached-2.1.0-6.el6.remi.1.x86_64 (@remi)
           Requires: php(zend-abi) = 20100525-x86-64
           Removing: php-common-5.4.20-1.el6.remi.x86_64 (@remi)
               php(zend-abi) = 20100525-x86-64
           Updated By: php-common-5.5.4-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(zend-abi) = 20090626
           Available: php-common-5.4.19-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.5.3-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
Error: Package: php-magickwand-1.0.9.2-4.el6.remi.x86_64 (@remi)
           Requires: php(api) = 20100412-x86-64
           Removing: php-common-5.4.20-1.el6.remi.x86_64 (@remi)
               php(api) = 20100412-x86-64
           Updated By: php-common-5.5.4-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(api) = 20090626
           Available: php-common-5.4.19-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.5.3-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

j'utilise la commande ci-dessous:
yum --enablerepo=remi-php55,remi update php\*

mon system
CentOS release 6.3 (Final)
PHP 5.4.20

dois je d'abord mettre à jour les packages incriminés depuis (remi-php55)?

cordialement !

Re: Mise à jour php-5.5.4

je ne pige pas pourquoi il ne tire pas les bonnes versions, présentes dans remi-php55
* php-magickwand-1.0.9.2-4.el6.remi.1
* php-pecl-imagick-3.1.2-1.el6.remi.1
* php-pecl-igbinary-1.1.2-0.5.git3b8ab7e.el6.remi.1
* php-pecl-memcached-2.1.0-6.el6.remi.5

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Mise à jour php-5.5.4

Même test

# rpm -q php
php-5.4.20-1.el6.remi.x86_64
# yum --enablerepo=remi-php55,remi update php\*
...
=========================================================================================================================================================================================
 Package                                       Arch                              Version                                                     Repository                             Size
=========================================================================================================================================================================================
Installing:
 php-opcache                                   x86_64                            5.5.4-1.el6.remi                                            remi-php55                            101 k
     replacing  php-pecl-zendopcache.x86_64 7.0.2-2.el6.remi
Updating:
 php                                           x86_64                            5.5.4-1.el6.remi                                            remi-php55                            2.5 M
 php-bcmath                                    x86_64                            5.5.4-1.el6.remi                                            remi-php55                             45 k
 php-cli                                       x86_64                            5.5.4-1.el6.remi                                            remi-php55                            2.4 M
 php-common                                    x86_64                            5.5.4-1.el6.remi                                            remi-php55                            1.0 M
 php-fpm                                       x86_64                            5.5.4-1.el6.remi                                            remi-php55                            1.3 M
 php-gd                                        x86_64                            5.5.4-1.el6.remi                                            remi-php55                             65 k
 php-ldap                                      x86_64                            5.5.4-1.el6.remi                                            remi-php55                             44 k
 php-mbstring                                  x86_64                            5.5.4-1.el6.remi                                            remi-php55                            954 k
 php-mcrypt                                    x86_64                            5.5.4-1.el6.remi                                            remi-php55                             36 k
 php-mysqlnd                                   x86_64                            5.5.4-1.el6.remi                                            remi-php55                            257 k
 php-pdo                                       x86_64                            5.5.4-1.el6.remi                                            remi-php55                            105 k
 php-pecl-apcu                                 x86_64                            4.0.2-2.el6.remi.1                                          remi-php55                             71 k
 php-pecl-igbinary                             x86_64                            1.1.2-0.5.git3b8ab7e.el6.remi.1                             remi-php55                             38 k
 php-pecl-imagick                              x86_64                            3.1.2-1.el6.remi.1                                          remi-php55                            169 k
 php-pecl-memcache                             x86_64                            3.0.8-1.el6.remi.1                                          remi-php55                             83 k
 php-pecl-memcached                            x86_64                            2.1.0-6.el6.remi.5                                          remi-php55                             57 k
 php-pecl-sphinx                               x86_64                            1.3.0-2.el6.remi.1                                          remi-php55                             29 k
 php-pgsql                                     x86_64                            5.5.4-1.el6.remi                                            remi-php55                             97 k
 php-process                                   x86_64                            5.5.4-1.el6.remi                                            remi-php55                             50 k
 php-recode                                    x86_64                            5.5.4-1.el6.remi                                            remi-php55                             22 k
 php-snmp                                      x86_64                            5.5.4-1.el6.remi                                            remi-php55                             43 k
 php-tidy                                      x86_64                            5.5.4-1.el6.remi                                            remi-php55                             41 k
 php-xml                                       x86_64                            5.5.4-1.el6.remi                                            remi-php55                            202 k
Installing for dependencies:
 gd-last                                       x86_64                            2.1.0-1.el6.remi                                            remi                                  134 k
 php-gmp                                       x86_64                            5.5.4-1.el6.remi                                            remi-php55                             39 k
 php-pecl-jsonc                                x86_64                            1.3.2-2.el6.remi.1                                          remi-php55                             45 k
 php-pecl-zip                                  x86_64                            1.12.1-2.el6.remi.1                                         remi-php55                             77 k

Transaction Summary
=========================================================================================================================================================================================
Install       5 Package(s)
Upgrade      23 Package(s)

Total download size: 10 M
Is this ok [y/N]: 

Quels sont les plugins yum actif ?

P.S. il me faudrait la sortie complète de yum.

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

4 (edited by cerealkiller 2013-10-15 11:29:53)

Re: Mise à jour php-5.5.4

voila jeune homme!! smile

yum --enablerepo=remi-php55,remi update php\*
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: mirror.ovh.net
 * epel: mirror.i3d.net
 * extras: distrib-coffee.ipsl.jussieu.fr
 * remi: remi.mirrors.hostinginnederland.nl
 * remi-php55: remi.mirrors.hostinginnederland.nl
 * updates: distrib-coffee.ipsl.jussieu.fr
939 packages excluded due to repository priority protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package php.x86_64 0:5.4.20-1.el6.remi will be updated
---> Package php.x86_64 0:5.5.4-1.el6.remi will be an update
---> Package php-cli.x86_64 0:5.4.20-1.el6.remi will be updated
---> Package php-cli.x86_64 0:5.5.4-1.el6.remi will be an update
---> Package php-common.x86_64 0:5.4.20-1.el6.remi will be updated
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-memcached-2.1.0-6.el6.remi.1.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-igbinary-1.1.2-0.1.git3b8ab7e.el6.remi.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-imagick-3.1.2-1.el6.remi.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-magickwand-1.0.9.2-4.el6.remi.x86_64
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-memcached-2.1.0-6.el6.remi.1.x86_64
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-igbinary-1.1.2-0.1.git3b8ab7e.el6.remi.x86_64
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-imagick-3.1.2-1.el6.remi.x86_64
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-magickwand-1.0.9.2-4.el6.remi.x86_64
--> Processing Dependency: php-pecl-zip(x86-64) for package: php-common-5.5.4-1.el6.remi.x86_64
---> Package php-common.x86_64 0:5.5.4-1.el6.remi will be an update
--> Processing Dependency: php-pecl-jsonc(x86-64) for package: php-common-5.5.4-1.el6.remi.x86_64
---> Package php-devel.x86_64 0:5.4.20-1.el6.remi will be updated
---> Package php-devel.x86_64 0:5.5.4-1.el6.remi will be an update
--> Processing Dependency: php-pecl-jsonc-devel(x86-64) for package: php-devel-5.5.4-1.el6.remi.x86_64
---> Package php-gd.x86_64 0:5.4.20-1.el6.remi will be updated
---> Package php-gd.x86_64 0:5.5.4-1.el6.remi will be an update
--> Processing Dependency: libvpx.so.0()(64bit) for package: php-gd-5.5.4-1.el6.remi.x86_64
--> Processing Dependency: libgd.so.3()(64bit) for package: php-gd-5.5.4-1.el6.remi.x86_64
---> Package php-imap.x86_64 0:5.4.20-1.el6.remi will be updated
---> Package php-imap.x86_64 0:5.5.4-1.el6.remi will be an update
---> Package php-mbstring.x86_64 0:5.4.20-1.el6.remi will be updated
---> Package php-mbstring.x86_64 0:5.5.4-1.el6.remi will be an update
---> Package php-mysql.x86_64 0:5.4.20-1.el6.remi will be obsoleted
---> Package php-mysqlnd.x86_64 0:5.5.4-1.el6.remi will be obsoleting
---> Package php-pdo.x86_64 0:5.4.20-1.el6.remi will be updated
---> Package php-pdo.x86_64 0:5.5.4-1.el6.remi will be an update
---> Package php-pear.noarch 1:1.9.4-12.el6.remi.1 will be updated
---> Package php-pear.noarch 1:1.9.4-23.el6.remi will be an update
--> Processing Dependency: php-posix for package: 1:php-pear-1.9.4-23.el6.remi.noarch
---> Package php-pecl-apc.x86_64 0:3.1.15-0.3.svn329913.el6.remi will be updated
---> Package php-pecl-apc.x86_64 0:3.1.15-0.3.svn329913.el6.remi.1 will be an update
---> Package php-xml.x86_64 0:5.4.20-1.el6.remi will be updated
---> Package php-xml.x86_64 0:5.5.4-1.el6.remi will be an update
--> Running transaction check
---> Package gd-last.x86_64 0:2.1.0-1.el6.remi will be installed
---> Package libvpx.x86_64 0:0.9.0-8.el6_0 will be installed
---> Package php-common.x86_64 0:5.4.20-1.el6.remi will be updated
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-memcached-2.1.0-6.el6.remi.1.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-igbinary-1.1.2-0.1.git3b8ab7e.el6.remi.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-imagick-3.1.2-1.el6.remi.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-magickwand-1.0.9.2-4.el6.remi.x86_64
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-memcached-2.1.0-6.el6.remi.1.x86_64
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-igbinary-1.1.2-0.1.git3b8ab7e.el6.remi.x86_64
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-imagick-3.1.2-1.el6.remi.x86_64
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-magickwand-1.0.9.2-4.el6.remi.x86_64
---> Package php-pecl-jsonc.x86_64 0:1.3.2-2.el6.remi.1 will be installed
---> Package php-pecl-jsonc-devel.x86_64 0:1.3.2-2.el6.remi.1 will be installed
---> Package php-pecl-zip.x86_64 0:1.12.1-2.el6.remi.1 will be installed
---> Package php-process.x86_64 0:5.5.4-1.el6.remi will be installed
--> Finished Dependency Resolution
Error: Package: php-magickwand-1.0.9.2-4.el6.remi.x86_64 (@remi)
           Requires: php(zend-abi) = 20100525-x86-64
           Removing: php-common-5.4.20-1.el6.remi.x86_64 (@remi)
               php(zend-abi) = 20100525-x86-64
           Updated By: php-common-5.5.4-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(zend-abi) = 20090626
           Available: php-common-5.4.19-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.5.3-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
Error: Package: php-pecl-imagick-3.1.2-1.el6.remi.x86_64 (@remi)
           Requires: php(zend-abi) = 20100525-x86-64
           Removing: php-common-5.4.20-1.el6.remi.x86_64 (@remi)
               php(zend-abi) = 20100525-x86-64
           Updated By: php-common-5.5.4-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(zend-abi) = 20090626
           Available: php-common-5.4.19-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.5.3-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
Error: Package: php-pecl-imagick-3.1.2-1.el6.remi.x86_64 (@remi)
           Requires: php(api) = 20100412-x86-64
           Removing: php-common-5.4.20-1.el6.remi.x86_64 (@remi)
               php(api) = 20100412-x86-64
           Updated By: php-common-5.5.4-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(api) = 20090626
           Available: php-common-5.4.19-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.5.3-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
Error: Package: php-pecl-igbinary-1.1.2-0.1.git3b8ab7e.el6.remi.x86_64 (@remi)
           Requires: php(api) = 20100412-x86-64
           Removing: php-common-5.4.20-1.el6.remi.x86_64 (@remi)
               php(api) = 20100412-x86-64
           Updated By: php-common-5.5.4-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(api) = 20090626
           Available: php-common-5.4.19-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.5.3-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
Error: Package: php-pecl-memcached-2.1.0-6.el6.remi.1.x86_64 (@remi)
           Requires: php(api) = 20100412-x86-64
           Removing: php-common-5.4.20-1.el6.remi.x86_64 (@remi)
               php(api) = 20100412-x86-64
           Updated By: php-common-5.5.4-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(api) = 20090626
           Available: php-common-5.4.19-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.5.3-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
Error: Package: php-pecl-igbinary-1.1.2-0.1.git3b8ab7e.el6.remi.x86_64 (@remi)
           Requires: php(zend-abi) = 20100525-x86-64
           Removing: php-common-5.4.20-1.el6.remi.x86_64 (@remi)
               php(zend-abi) = 20100525-x86-64
           Updated By: php-common-5.5.4-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(zend-abi) = 20090626
           Available: php-common-5.4.19-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.5.3-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
Error: Package: php-pecl-memcached-2.1.0-6.el6.remi.1.x86_64 (@remi)
           Requires: php(zend-abi) = 20100525-x86-64
           Removing: php-common-5.4.20-1.el6.remi.x86_64 (@remi)
               php(zend-abi) = 20100525-x86-64
           Updated By: php-common-5.5.4-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(zend-abi) = 20090626
           Available: php-common-5.4.19-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.5.3-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
Error: Package: php-magickwand-1.0.9.2-4.el6.remi.x86_64 (@remi)
           Requires: php(api) = 20100412-x86-64
           Removing: php-common-5.4.20-1.el6.remi.x86_64 (@remi)
               php(api) = 20100412-x86-64
           Updated By: php-common-5.5.4-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(api) = 20090626
           Available: php-common-5.4.19-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.5.3-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Re: Mise à jour php-5.5.4

bon si je desactive les repo autres que les tiennes

ca me donne ceci comme erreur a la fin ! smile

Error: Package: php-gd-5.5.4-1.el6.remi.x86_64 (remi-php55)
           Requires: libvpx.so.0()(64bit)
Error: Package: gd-last-2.1.0-1.el6.remi.x86_64 (remi)
           Requires: libvpx.so.0()(64bit)

tu as ça dans tes package ou je dois l’installer depuis epel ?

Re: Mise à jour php-5.5.4

bon je l'ai trouver mais pour CenOS 6.4 arff ! je suis en 6.3

bon je sais ce qu'il me reste a faire mais c'était pas prévu

à moins que tu es un rpm caché de derrière les fagots !!

merci

Re: Mise à jour php-5.5.4

Oui, clairement je build mes paquets avec une 6.4, donc certaines dépendances sont nécessaires.

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Mise à jour php-5.5.4

bon merci un gros boulot alors vue que j'ai plesk d'installer dessus (oui je sais tu n'aime pas) mais c'est intéressant pour leur système de gestion des clients pour l’hébergement

bon après pour leur mises à jour sont pas très réactif mais bon on peut pas tout avoir !! smile

merci encore et désoler pour le dérangement et pour le travail que tu fourni à la communauté