1 (edited by strategist922 2014-02-06 02:04:32)

Topic: Install apache httpd 2.4 with remi-php55 repo

Hi,

  I have already successfully installed Apache web server V2.4 by the instruction on remi blog. But encountered problem when I want to install php from remi-php55 repository. It show me that it will install a older version (Apache httpd_2.2 )

  How can I make Apache Server 2.4 and php55 working together?

Thanks in advance.
James Chang

Re: Install apache httpd 2.4 with remi-php55 repo

If you have installed httpd24 scl you must use php55 SCL.

php 5.5 in my repo is built with system httpd.
You can also use php-fpm instead og mod_php.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Install apache httpd 2.4 with remi-php55 repo

HI Remi,
Im a new member so forgive me for intruding with a simple question based on your last entry:   
Will SCL HTTPD24 play with RemiPHP56?  or I should back out and combine it with  SCL55? 
? is that a question for SCL ?
Thanks for your repos and support: before I saw your forum, I used your repo to update PHP53 > 56 on Centos6.
Apache is at 22 and CentOS is 68

Re: Install apache httpd 2.4 with remi-php55 repo

NOTICE: PHP 5.5 is EOL, unmaintained.


In official RHSCL collection

rh-php56-php (aka mopd_php) is designed to work with httpd24

In my repo

php (base package) or php*-php (SCL package), aka mod_php, is designed to work with system httpd

rh-php*-php-fpm or php*-php-fpm or php-fpm(FastCGI server) will work with all httpd/nginx/lighttpd versions.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70