Topic: Problem with updating ImageMagick

Hello all,

I've got a problem with updating ImageMagick:

ImageMagick-last-libs.i686          6.8.9.0-1.el6.remi                remi     
php-pear.noarch                     1:1.9.4-26.el6.remi.1             remi     
php-pecl-jsonc.i686                 1.3.5-1.el6.remi.5.5              remi-php55
php-pecl-jsonc-devel.i686           1.3.5-1.el6.remi.5.5              remi-php55
Error: Package: php-pecl-imagick-3.1.2-2.el6.remi.5.5.i686 (@remi-php55)
           Requires: libMagickCore-6.Q16.so.1
           Removing: ImageMagick-last-libs-6.8.7.4-1.el6.remi.i686 (@remi)
               libMagickCore-6.Q16.so.1
           Updated By: ImageMagick-last-libs-6.8.9.0-1.el6.remi.i686 (remi)
               Not found
Error: Package: php-pecl-imagick-3.1.2-2.el6.remi.5.5.i686 (@remi-php55)
           Requires: libMagickWand-6.Q16.so.1
           Removing: ImageMagick-last-libs-6.8.7.4-1.el6.remi.i686 (@remi)
               libMagickWand-6.Q16.so.1
           Updated By: ImageMagick-last-libs-6.8.9.0-1.el6.remi.i686 (remi)
               Not found

Maybe some dependencies are missing?

Best regards, Christian

Re: Problem with updating ImageMagick

$ rpm -qp --provides ImageMagick-last-libs-6.8.9.0-1.el6.remi.x86_64.rpm
libMagickCore-6.Q16.so.2()(64bit)
libMagickWand-6.Q16.so.2()(64bit)
...
$ rpm -qp --requires php-pecl-imagick-3.1.2-3.el6.remi.5.5.x86_64.rpm
libMagickCore-6.Q16.so.2()(64bit)
libMagickWand-6.Q16.so.2()(64bit)
...

So probably "remi" repository is enabled while "remi-php55" is not.

Desktop: Fedora 35 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 36 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Problem with updating ImageMagick

Hi, the remi-php55 repo was enabled. For some reason yum didn't see php-pecl-imagick-3.1.2-3, I tried yum clean all but it didn't help. I had to download the RPM and did a yum localinstall, after that it worked.

Regards, Christian

Re: Problem with updating ImageMagick

Probably a out of sync mirror...
Closing.

Desktop: Fedora 35 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 36 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi