1 (edited by Machavity 2016-06-17 13:04:05)

Topic: XDebug segfault on PHP 7.0.7 under EL7

Using CentOS 7 and the latest from the main Remi repo

I have an internal test server I've been having to rebuild and I ran into a problem with XDebug.
I had a configuration issue with Smarty that was causing a Fatal error in PHP, but with XDebug installed it was causing a Segmentation fault in Apache

Here's the stack trace. I'm not sure if this is an issue with the RPM or XDebug

#0  0x00007f62104fdc33 in __strncpy_sse2_unaligned () from /lib64/libc.so.6
#1  0x00007f6201bb067c in xdebug_error_cb () from /usr/lib64/php/modules/xdebug.so
#2  0x00007f6204325337 in zend_error_va () from /etc/xttpd/modules/libphp7.so
#3  0x00007f6204325896 in zend_exception_error () from /etc/xttpd/modules/libphp7.so
#4  0x00007f62044a006b in zend_execute_scripts () from /etc/xttpd/modules/libphp7.so
#5  0x00007f6204441218 in php_execute_script () from /etc/xttpd/modules/libphp7.so
#6  0x00007f620452a6ad in php_handler () from /etc/xttpd/modules/libphp7.so
#7  0x00007f6211faa270 in ap_run_handler ()
#8  0x00007f6211faa7b9 in ap_invoke_handler ()
#9  0x00007f6211fbeb3a in ap_process_async_request ()
#10 0x00007f6211fbee14 in ap_process_request ()
#11 0x00007f6211fbb7a2 in ap_process_xttp_connection ()
#12 0x00007f6211fb3840 in ap_run_process_connection ()
#13 0x00007f620798480f in child_main () from /etc/xttpd/modules/mod_mpm_prefork.so
#14 0x00007f6207984a55 in make_child () from /etc/xttpd/modules/mod_mpm_prefork.so
#15 0x00007f6207984ab6 in startup_children () from /etc/xttpd/modules/mod_mpm_prefork.so
#16 0x00007f62079857c0 in prefork_run () from /etc/xttpd/modules/mod_mpm_prefork.so
#17 0x00007f6211f905ae in ap_run_mpm ()
#18 0x00007f6211f89b36 in main ()

Won't let me post the full stack trace since I guess it sees the file paths as URL

I should note that it's the fatal error, not the strcopy error causing the segfault. In that case, it was unable to open a directory it didn't have permissions to.

Re: XDebug segfault on PHP 7.0.7 under EL7

Very probably a upstream (XDebug) issue.

The backtrace will help (replacing the http:// by xxxx, should be accepted by anti-spam)

Desktop: Fedora 35 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 34 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: XDebug segfault on PHP 7.0.7 under EL7

Yeah, that worked. replace httpd with xttpd. Full stack trace in the OP now