1 (edited by lph9 2016-12-21 10:52:45)

Topic: Problem with php-pecl-imagick remi-php56

# yum update
Loaded plugins: fastestmirror, priorities
Setting up Update Process
Loading mirror speeds from cached hostfile
 * base: mirrors.cicku.me
 * extras: centos.datente.com
 * remi-php56: mirror.23media.de
 * updates: centosmirror.netcup.net
remi-php56                                                                                                   | 2.9 kB     00:00     
Resolving Dependencies
--> Running transaction check
---> Package php-pecl-imagick.x86_64 0:3.4.2-1.el6.remi.5.6 will be updated
---> Package php-pecl-imagick.x86_64 0:3.4.3-0.4.RC1.el6.remi.5.6 will be an update
--> Processing Dependency: ImageMagick6-libs(x86-64) >= 6.9.6 for package: php-pecl-imagick-3.4.3-0.4.RC1.el6.remi.5.6.x86_64
--> Processing Dependency: libMagickWand-6.Q16.so.3()(64bit) for package: php-pecl-imagick-3.4.3-0.4.RC1.el6.remi.5.6.x86_64
--> Processing Dependency: libMagickCore-6.Q16.so.3()(64bit) for package: php-pecl-imagick-3.4.3-0.4.RC1.el6.remi.5.6.x86_64
--> Finished Dependency Resolution
Error: Package: php-pecl-imagick-3.4.3-0.4.RC1.el6.remi.5.6.x86_64 (remi-php56)
           Requires: libMagickWand-6.Q16.so.3()(64bit)
Error: Package: php-pecl-imagick-3.4.3-0.4.RC1.el6.remi.5.6.x86_64 (remi-php56)
           Requires: ImageMagick6-libs(x86-64) >= 6.9.6
Error: Package: php-pecl-imagick-3.4.3-0.4.RC1.el6.remi.5.6.x86_64 (remi-php56)
           Requires: libMagickCore-6.Q16.so.3()(64bit)
 You could try using --skip-broken to work around the problem

Re: Problem with php-pecl-imagick remi-php56

You need remi-safe repository which is enabled by default (when using remi-release auto-configuration package)

See the Wizard: https://rpms.remirepo.net/wizard/

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70

Re: Problem with php-pecl-imagick remi-php56

I did:

yum-config-manager --enable remi-safe

and after that

yum update

which got it updated.
remi-safe WAS DISABLED (I didn't disable it).

Thanks

Re: Problem with php-pecl-imagick remi-php56

smile

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70