Topic: Unable to install php-pecl-sphinx - Centos 6, php 5.6

Hello

It looks like EPEL have removed a lot of orphaned packages recently. Remi's Php-pecl-sphinx is depending on libsphinxclient, that was removed. Here is a log:

# yum install php-pecl-sphinx
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
* base: mirror.daniel-jost.net
* epel: mirrors.n-ix.net
* extras: mirror.daniel-jost.net
* remi-php56: mirror.23media.de
* remi-safe: mirror.23media.de
* updates: mirror.daniel-jost.net
Resolving Dependencies
--> Running transaction check
---> Package php-pecl-sphinx.x86_64 0:1.3.3-1.el6.remi.5.6 will be installed
--> Processing Dependency: libsphinxclient-0.0.1.so()(64bit) for package: php-pecl-sphinx-1.3.3-1.el6.remi.5.6.x86_64
--> Finished Dependency Resolution
Error: Package: php-pecl-sphinx-1.3.3-1.el6.remi.5.6.x86_64 (remi-php56)
           Requires: libsphinxclient-0.0.1.so()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Re: Unable to install php-pecl-sphinx - Centos 6, php 5.6

Thanks for the notice.

Indeed this happen sometime... sad

As a quick fix, I have rebuild the same version which was in EPEL-6 and EPEL-7, and push them in "remi-safe" repository (2.0.8 for EL-6 and 2.1.5 for EL-7)

Will see later if it worth to be updated to a more recent version (knowing that the pecl extension seems dead... no update for PHP 7).

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Unable to install php-pecl-sphinx - Centos 6, php 5.6

Yes, it works now. Thank you smile.