Topic: gmime errors

I installed some packages from remi's repos and have had this error for some time. I have fixed the java portion but now I have this last one I can't get rid of. Anyone have any suggestions?


# yum update
Loaded plugins: aliases, changelog, downloadonly, fastestmirror, filter-data,
              : keys, kmod, list-data, priorities, protect-packages,
              : protectbase, security, tmprepo, verify, versionlock
Loading mirror speeds from cached hostfile
* base: mirrors.versaweb.com
* epel: epel.mirror.freedomvoice.com
* extras: mirror.san.fastserv.com
* updates: centos-distro.cavecreek.net
Skipping filters plugin, no data
0 packages excluded due to repository protections
Skipping security plugin, no data
Reading version lock configuration
Setting up Update Process
Resolving Dependencies
Skipping filters plugin, no data
Skipping security plugin, no data
--> Running transaction check
--> Processing Dependency: gmime = 2.2.10-5.el5.centos for package: gmime-sharp
---> Package gmime.x86_64 0:2.2.26-1.el5 set to be updated
--> Finished Dependency Resolution
gmime-sharp-2.2.10-5.el5.centos.x86_64 from installed has depsolving problems
  --> Missing Dependency: gmime = 2.2.10-5.el5.centos is needed by package gmime-sharp-2.2.10-5.el5.centos.x86_64 (installed)
Error: Missing Dependency: gmime = 2.2.10-5.el5.centos is needed by package gmime-sharp-2.2.10-5.el5.centos.x86_64 (installed)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Re: gmime errors

Your issue is not from remi repo

It's from "gmime-sharp" package which is not available in any repository I known/use.

+

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: gmime errors

It came when I installed one of the packages. It was a dependency installed from the epel repo I believe. Any suggestions on how to fix it?

Re: gmime errors

I couldn't find anything that needed it so, I removed it. We'll see if anything gives issue. Thanks!