Topic: How To Configure fully support php7 & Apache 2,4,x Modules On Centos

I successfully install multy php version php56 php70 and php71 with various modules that I need and can be read

Usually remi repository automatically install modules needed by php module that we install, I'm having problems with ht tpd module, I do not see httpd module for php7, I just look libphp5,so libphp5-zts,so in the directory /usr/lib64/h ttpd/modules/


Also

Error when installing memcached for php70 and php56:

---> Package php70-php-pecl-memcached.x86_64 0:3.0.0-0.4.20161207gite65be32.el7.remi will be installed
--> Processing Dependency: libfastlz.so.0()(64bit) for package: php70-php-pecl-memcached-3.0.0-0.4.20161207gite65be32.el7.remi.x86_64
---> Package php70-php-pecl-msgpack.x86_64 0:2.0.2-1.el7.remi will be installed
--> Finished Dependency Resolution
Error: Package: php70-php-pecl-memcached-3.0.0-0.4.20161207gite65be32.el7.remi.x86_64 (remi-safe)
           **Requires: libfastlz.so.0()(64bit)**

Because I am not an expert recompile module, please explain how to install php7 correctly, and all module needed also cgi/fcgi module.

Re: How To Configure fully support php7 & Apache 2,4,x Modules On Centos

>           **Requires: libfastlz.so.0()(64bit)**

fastlz is in EPEL.

> I do not see httpd module for php7,

"mod_php" is in php70-php package => libphp7.so

> I successfully install multy php version php56 php70 and php71 with various modules that I need and can be read

BTW, only a single mod_php can be installed / loaded in apache at the same time, the reason one, in such configuration, you should rather consider php-fpm.

See https://blog.remirepo.net/post/2016/04/ … orkstation

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

3 (edited by hendra 2017-02-04 16:07:42)

Re: How To Configure fully support php7 & Apache 2,4,x Modules On Centos

Sir remi, you rock

Ahh, i forget to enable epel repo. Now memcached worked smile

I'am using virtualmin with mod_fcgid, so no need other module php70 for fcgi?

Re: How To Configure fully support php7 & Apache 2,4,x Modules On Centos

I don't know mod_fcgid, as I prefer mod_proxy_fastcgi
but all SAPI are available (cli, cgi, fcgi, fpm, mod_php, litespeed...)

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70