Topic: update : php-common-5.6.30-1 available: php-common-5.6.29-1

Hi, i would like install php56 in Centos 7.2

yum --enablerepo=remi-php56
yum-config-manager --enable remi-php56
yum update

and then i get multiple errors (translate from german ;-):

Fehler: Paket: php-tidy-5.4.16-7.el7.x86_64 (@epel)
            require: php(api) = 20100412-64
            remove: php-common-5.4.16-42.el7.x86_64 (@base)
                php(api) = 20100412-64
            update : php-common-5.6.30-1.el7.remi.x86_64 (remi-php56)
                php(api) = 20131106-64
            available: php-common-5.6.29-1.el7.remi.x86_64 (remi-php56)
                php(api) = 20131106-64

it seems to be that there are more then one php is available....please explain.

Regards fol

Re: update : php-common-5.6.30-1 available: php-common-5.6.29-1

Please post full yum output (using: LANG=C yum ....)

Looks like you have protectbase or priority plugin enable, try to disable (of fix priority of remi-php56 to be > epel one)


P.S. the issue is not with 5.6.30/5.6.29 being online (I always keep 1 old version to allow downgrade if needed), but with php-tidy from epel being selected instead of php-tidy from remi-php56.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70

Re: update : php-common-5.6.30-1 available: php-common-5.6.29-1

I cannot post output here:

Warning! The following errors must be corrected before your message can be posted:
Too more links in message. Allowed 1 links. Reduce number of links and post it again.

Re: update : php-common-5.6.30-1 available: php-common-5.6.29-1

so, changing the yum.repos files to 56 works, thanks