Topic: installing graphviz-php with php 5.6

Hi

I'm tried to install graphviz-php with php 5.6.

but i couldn't install it.

copy paste for the error, i searched via google but no good solutions for it.

my server o/s is centos 6.9.

please, tell me a good solutions.

# yum install --enablerepo=remi,remi-php56 graphviz-php
Loaded plugins: fastestmirror, priorities
Setting up Install Process
Loading mirror speeds from cached hostfile
* epel: mirror.premi.st
* remi: mirror.innosol.asia
* remi-php56: mirror.innosol.asia
* remi-safe: mirror.innosol.asia
* rpmforge: ftp.riken.jp
1572 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package graphviz-php.x86_64 0:2.26.0-10.el6 will be installed
--> Processing Dependency: php(zend-abi) = 20090626 for package: graphviz-php-2.26.0-10.el6.x86_64
--> Processing Dependency: php(api) = 20090626 for package: graphviz-php-2.26.0-10.el6.x86_64
--> Finished Dependency Resolution
Error: Package: graphviz-php-2.26.0-10.el6.x86_64 (base)
           Requires: php(api) = 20090626
           Installed: php-common-5.6.30-1.el6.remi.x86_64 (@remi-php56)
               php(api) = 20131106-64
           Available: php-common-5.3.3-49.el6.x86_64 (base)
               php(api) = 20090626
           Available: php-common-5.4.45-13.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.6.29-1.el6.remi.x86_64 (remi-php56)
               php(api) = 20131106-64
Error: Package: graphviz-php-2.26.0-10.el6.x86_64 (base)
           Requires: php(zend-abi) = 20090626
           Installed: php-common-5.6.30-1.el6.remi.x86_64 (@remi-php56)
               php(zend-abi) = 20131226-64
           Available: php-common-5.3.3-49.el6.x86_64 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.4.45-13.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.6.29-1.el6.remi.x86_64 (remi-php56)
               php(zend-abi) = 20131226-64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Re: installing graphviz-php with php 5.6

> please, tell me a good solutions.

Sorry, I don't have for now
I maintain >150 extension package (mostly from PECL) which are standalone projects

Didn't have a "simple" way for such extension bundle in other projects.
(versions differ in each distro... and don't want to maintain whole graphiz here)

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70

Re: installing graphviz-php with php 5.6

More, this is not a real PHP extension, only a twig generated bindings...

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70