Topic: php7.1.10 el7 unexpected dependencies

I have unexpected dependencies arising when upgrading from 7.1.9 to 7.1.10 on an el7.remi.x86_64.

Does anyone have any suggestions?

[root@42xxxxxxxxxxx42 ~]# yum upgrade php
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.sov.uk.goscomb.net
 * epel: mirrors.coreix.net
 * extras: mirrors.clouvider.net
 * remi-php71: fr.mirror.babylon.network
 * remi-safe: fr.mirror.babylon.network
 * updates: mirrors.coreix.net
Resolving Dependencies
--> Running transaction check
---> Package php.x86_64 0:7.1.9-1.el7.remi will be updated
---> Package php.x86_64 0:7.1.10-1.el7.remi will be an update
--> Processing Dependency: php-common(x86-64) = 7.1.10-1.el7.remi for package: php-7.1.10-1.el7.remi.x86_64
--> Processing Dependency: php-cli(x86-64) = 7.1.10-1.el7.remi for package: php-7.1.10-1.el7.remi.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-7.1.10-1.el7.remi.x86_64
--> Running transaction check
---> Package php.x86_64 0:7.1.10-1.el7.remi will be an update
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-7.1.10-1.el7.remi.x86_64
---> Package php-cli.x86_64 0:7.1.9-1.el7.remi will be updated
--> Processing Dependency: php-cli(x86-64) = 7.1.9-1.el7.remi for package: php-devel-7.1.9-1.el7.remi.x86_64
---> Package php-cli.x86_64 0:7.1.10-1.el7.remi will be an update
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-cli-7.1.10-1.el7.remi.x86_64
---> Package php-common.x86_64 0:7.1.9-1.el7.remi will be updated
--> Processing Dependency: php-common(x86-64) = 7.1.9-1.el7.remi for package: php-process-7.1.9-1.el7.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 7.1.9-1.el7.remi for package: php-mbstring-7.1.9-1.el7.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 7.1.9-1.el7.remi for package: php-xml-7.1.9-1.el7.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 7.1.9-1.el7.remi for package: php-pdo-7.1.9-1.el7.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 7.1.9-1.el7.remi for package: php-mcrypt-7.1.9-1.el7.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 7.1.9-1.el7.remi for package: php-json-7.1.9-1.el7.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 7.1.9-1.el7.remi for package: php-gd-7.1.9-1.el7.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 7.1.9-1.el7.remi for package: php-imap-7.1.9-1.el7.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 7.1.9-1.el7.remi for package: php-opcache-7.1.9-1.el7.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 7.1.9-1.el7.remi for package: php-fpm-7.1.9-1.el7.remi.x86_64
---> Package php-common.x86_64 0:7.1.10-1.el7.remi will be an update
--> Running transaction check
---> Package php.x86_64 0:7.1.10-1.el7.remi will be an update
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-7.1.10-1.el7.remi.x86_64
---> Package php-cli.x86_64 0:7.1.10-1.el7.remi will be an update
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-cli-7.1.10-1.el7.remi.x86_64
---> Package php-devel.x86_64 0:7.1.9-1.el7.remi will be updated
---> Package php-devel.x86_64 0:7.1.10-1.el7.remi will be an update
---> Package php-fpm.x86_64 0:7.1.9-1.el7.remi will be updated
---> Package php-fpm.x86_64 0:7.1.10-1.el7.remi will be an update
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-fpm-7.1.10-1.el7.remi.x86_64
---> Package php-gd.x86_64 0:7.1.9-1.el7.remi will be updated
---> Package php-gd.x86_64 0:7.1.10-1.el7.remi will be an update
---> Package php-imap.x86_64 0:7.1.9-1.el7.remi will be updated
---> Package php-imap.x86_64 0:7.1.10-1.el7.remi will be an update
---> Package php-json.x86_64 0:7.1.9-1.el7.remi will be updated
---> Package php-json.x86_64 0:7.1.10-1.el7.remi will be an update
---> Package php-mbstring.x86_64 0:7.1.9-1.el7.remi will be updated
---> Package php-mbstring.x86_64 0:7.1.10-1.el7.remi will be an update
---> Package php-mcrypt.x86_64 0:7.1.9-1.el7.remi will be updated
---> Package php-mcrypt.x86_64 0:7.1.10-1.el7.remi will be an update
---> Package php-opcache.x86_64 0:7.1.9-1.el7.remi will be updated
---> Package php-opcache.x86_64 0:7.1.10-1.el7.remi will be an update
---> Package php-pdo.x86_64 0:7.1.9-1.el7.remi will be updated
--> Processing Dependency: php-pdo(x86-64) = 7.1.9-1.el7.remi for package: php-mysqlnd-7.1.9-1.el7.remi.x86_64
---> Package php-pdo.x86_64 0:7.1.10-1.el7.remi will be an update
---> Package php-process.x86_64 0:7.1.9-1.el7.remi will be updated
---> Package php-process.x86_64 0:7.1.10-1.el7.remi will be an update
---> Package php-xml.x86_64 0:7.1.9-1.el7.remi will be updated
---> Package php-xml.x86_64 0:7.1.10-1.el7.remi will be an update
--> Running transaction check
---> Package php.x86_64 0:7.1.10-1.el7.remi will be an update
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-7.1.10-1.el7.remi.x86_64
---> Package php-cli.x86_64 0:7.1.10-1.el7.remi will be an update
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-cli-7.1.10-1.el7.remi.x86_64
---> Package php-fpm.x86_64 0:7.1.10-1.el7.remi will be an update
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-fpm-7.1.10-1.el7.remi.x86_64
---> Package php-mysqlnd.x86_64 0:7.1.9-1.el7.remi will be updated
---> Package php-mysqlnd.x86_64 0:7.1.10-1.el7.remi will be an update
--> Finished Dependency Resolution
Error: Package: php-cli-7.1.10-1.el7.remi.x86_64 (remi-php71)
           Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Error: Package: php-fpm-7.1.10-1.el7.remi.x86_64 (remi-php71)
           Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Error: Package: php-7.1.10-1.el7.remi.x86_64 (remi-php71)
           Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
 You could try using --skip-broken to work around the problem
[root@42xxxxxxxxxxx42 ~]# 

Re: php7.1.10 el7 unexpected dependencies

You need openssl 1.0.2 from updates (have been rebased in 7.4)

* Check you are not on 7.3 (in base/updates repository definition)
* Check your mirror is synced
* Check metadata are refreshed (yum clean metadata)

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: php7.1.10 el7 unexpected dependencies

Thanks guys for this discussion. Very helpful.