Topic: libmysqlclient conflict with compat-mysql51

Hello,

this my Centos information:
centos-release-6-7.el6.centos.12.3.x86_64


I want to upgrade from php 5.5 to php5.6.32, after struggling with various information from the web, i found the wizard which is an interesting idea, so I went on,
I followed the steps in the wizard, here is the output from the different steps:

[root@ns371776 ~]# /usr/bin/yum install remi-php56
Modules complémentaires chargés : fastestmirror
Configuration du processus d'installation
Loading mirror speeds from cached hostfile
 * base: centos.mirrors.ovh.net
 * epel: epel.mirror.wearetriple.com
 * epel-source: epel.mirror.wearetriple.com
 * extras: centos.mirrors.ovh.net
 * remi: rpms.remirepo.net
 * remi-php55: rpms.remirepo.net
 * remi-php56: rpms.remirepo.net
 * remi-safe: rpms.remirepo.net
 * updates: centos.mirrors.ovh.net
remi                                                                                      | 2.9 kB     00:00
Aucun paquet remi-php56 disponible.
Erreur : Rien à faire
[root@ns371776 ~]# /usr/bin/yum install //dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm
Modules complémentaires chargés : fastestmirror
Configuration du processus d'installation
epel-release-latest-6.noarch.rpm                                                          |  14 kB     00:00
Examen de /var/tmp/yum-root-j8EfUu/epel-release-latest-6.noarch.rpm : epel-release-6-8.noarch
/var/tmp/yum-root-j8EfUu/epel-release-latest-6.noarch.rpm : ne met pas à jour le paquet installé.
Erreur : Rien à faire
[root@ns371776 ~]# /usr/bin/yum install htp://rpms.remirepo.net/enterprise/remi-release-6.rpm
Modules complémentaires chargés : fastestmirror
Configuration du processus d'installation
remi-release-6.rpm                                                                        |  11 kB     00:00
Examen de /var/tmp/yum-root-j8EfUu/remi-release-6.rpm : remi-release-6.9-1.el6.remi.noarch
Sélection de /var/tmp/yum-root-j8EfUu/remi-release-6.rpm pour mise à jour de remi-release-6.6-1.el6.remi.noarch
Loading mirror speeds from cached hostfile
 * base: centos.mirrors.ovh.net
 * epel: epel.mirror.wearetriple.com
 * epel-source: epel.mirror.wearetriple.com
 * extras: centos.mirrors.ovh.net
 * remi: rpms.remirepo.net
 * remi-php55: rpms.remirepo.net
 * remi-php56: rpms.remirepo.net
 * remi-safe: rpms.remirepo.net
 * updates: centos.mirrors.ovh.net
Résolution des dépendances
--> Lancement de la transaction de test
---> Package remi-release.noarch 0:6.6-1.el6.remi will be mis à jour
---> Package remi-release.noarch 0:6.9-1.el6.remi will be an update
--> Résolution des dépendances terminée

Dépendances résolues
.
.
.
.
.

Taille totale des téléchargements : 425 M
Est-ce correct [o/N] : o
Téléchargement des paquets :
(1/237): ConsoleKit-0.4.1-6.el6.x86_64.rpm                                                |  83 kB     00:00 ...
(2/237): ConsoleKit-libs-0.4.1-6.el6.x86_64.rpm                                           |  18 kB     00:00
(3/237): GConf2-2.28.0-7.el6.x86_64.rpm                                                   | 963 kB     00:00 ...
(4/237): GeoIP-GeoLite-data-2017.07-1.el6.noarch.rpm                                      | 492 kB     00:00
(5/237): GeoIP-GeoLite-data-extra-2017.07-1.el6.noarch.rpm                                |  24 MB     00:00
(6/237): ImageMagick-6.7.2.7-6.el6.x86_64.rpm                                             | 1.9 MB     00:00 ...
(7/237): ImageMagick-devel-6.7.2.7-6.el6.x86_64.rpm                                       |  95 kB     00:00 ...
(8/237): ImageMagick-perl-6.7.2.7-6.el6.x86_64.rpm                                        | 162 kB     00:00 ...
(9/237): ORBit2-2.14.17-6.el6_8.x86_64.rpm                                                | 169 kB     00:00 ...
(10/237): acl-2.2.49-7.el6_9.1.x86_64.rpm                                                 |  76 kB     00:00 ...
(11/237): alsa-lib-1.1.0-4.el6.x86_64.rpm                                                 | 389 kB     00:00 ...
(12/237): alsa-utils-1.1.0-10.el6.x86_64.rpm                                              | 2.0 MB     00:00 ...
(13/237): at-3.1.10-49.el6.x86_64.rpm                                                     |  61 kB     00:00 ...
(14/237): audit-2.4.5-6.el6.x86_64.rpm                                                    | 204 kB     00:00 ...
(15/237): audit-libs-2.4.5-6.el6.x86_64.rpm                                               |  74 kB     00:00 ...
(16/237): avahi-libs-0.6.25-17.el6.x86_64.rpm                                             |  55 kB     00:00 ...
(17/237): bash-4.1.2-48.el6.x86_64.rpm                                                    | 910 kB     00:00 ...
(18/237): binutils-2.20.51.0.2-5.47.el6_9.1.x86_64.rpm                                    | 2.8 MB     00:00 ...
(19/237): ca-certificates-2017.2.14-65.0.1.el6_9.noarch.rpm                               | 1.3 MB     00:00 ...
(20/237): centos-release-6-9.el6.12.3.x86_64.rpm                                          |  22 kB     00:00
(21/237): chkconfig-1.3.49.5-1.el6.x86_64.rpm                                             | 160 kB     00:00 ...
(22/237): clamav-0.99.2-2.el6.x86_64.rpm                                                  | 4.3 MB     00:00
(23/237): clamav-db-0.99.2-2.el6.x86_64.rpm                                               | 110 MB     00:01
(24/237): clamd-0.99.2-2.el6.x86_64.rpm                                                   | 167 kB     00:00
(25/237): collectd-4.10.9-4.el6.x86_64.rpm                                                | 433 kB     00:00
(26/237): collectd-apache-4.10.9-4.el6.x86_64.rpm                                         |  16 kB     00:00
(27/237): collectd-mysql-4.10.9-4.el6.x86_64.rpm                                          |  17 kB     00:00
(28/237): collectd-rrdtool-4.10.9-4.el6.x86_64.rpm                                        |  20 kB     00:00
(29/237): coreutils-8.4-46.el6.x86_64.rpm                                                 | 3.0 MB     00:00 ...
(30/237): coreutils-libs-8.4-46.el6.x86_64.rpm                                            |  52 kB     00:00 ...
(31/237): cpio-2.10-13.el6.x86_64.rpm                                                     | 192 kB     00:00 ...
(32/237): cpp-4.4.7-18.el6.x86_64.rpm                                                     | 3.7 MB     00:00 ...
(33/237): crda-3.13_2015.10.22-3.el6.x86_64.rpm                                           |  31 kB     00:00
(34/237): createrepo-0.9.9-27.el6_9.noarch.rpm                                            |  97 kB     00:00 ...
(35/237): cronie-1.4.4-16.el6_8.2.x86_64.rpm                                              |  75 kB     00:00 ...
(36/237): cronie-anacron-1.4.4-16.el6_8.2.x86_64.rpm                                      |  31 kB     00:00 ...
(37/237): cups-libs-1.4.2-78.el6_9.x86_64.rpm                                             | 322 kB     00:00 ...
(38/237): curl-7.19.7-53.el6_9.x86_64.rpm                                                 | 197 kB     00:00 ...
(39/237): db4-4.7.25-22.el6.x86_64.rpm                                                    | 564 kB     00:00 ...
(40/237): db4-cxx-4.7.25-22.el6.x86_64.rpm                                                | 589 kB     00:00 ...
(41/237): db4-devel-4.7.25-22.el6.x86_64.rpm                                              | 6.6 MB     00:00 ...
(42/237): db4-utils-4.7.25-22.el6.x86_64.rpm                                              | 131 kB     00:00 ...
(43/237): device-mapper-1.02.117-12.el6.x86_64.rpm                                        | 218 kB     00:00 ...
(44/237): device-mapper-event-1.02.117-12.el6.x86_64.rpm                                  | 134 kB     00:00 ...
(45/237): device-mapper-event-libs-1.02.117-12.el6.x86_64.rpm                             | 126 kB     00:00 ...
(46/237): device-mapper-libs-1.02.117-12.el6.x86_64.rpm                                   | 257 kB     00:00 ...
(47/237): device-mapper-persistent-data-0.6.2-0.1.rc7.el6.x86_64.rpm                      | 463 kB     00:00 ...
(48/237): dhclient-4.1.1-53.P1.el6.centos.1.x86_64.rpm                                    | 322 kB     00:00 ...
(49/237): dhcp-common-4.1.1-53.P1.el6.centos.1.x86_64.rpm                                 | 144 kB     00:00 ...
(50/237): dialog-1.1-10.20080819.el6.x86_64.rpm                                           | 196 kB     00:00 ...
(51/237): dmidecode-2.12-7.el6.x86_64.rpm                                                 |  74 kB     00:00 ...
(52/237): dovecot-2.0.9-22.el6.x86_64.rpm                                                 | 1.9 MB     00:00 ...
(53/237): dovecot-mysql-2.0.9-22.el6.x86_64.rpm                                           |  40 kB     00:00 ...
(54/237): dovecot-pigeonhole-2.0.9-22.el6.x86_64.rpm                                      | 100 kB     00:00 ...
(55/237): e2fsprogs-1.41.12-23.el6.x86_64.rpm                                             | 554 kB     00:00 ...
(56/237): e2fsprogs-libs-1.41.12-23.el6.x86_64.rpm                                        | 121 kB     00:00 ...
(57/237): efibootmgr-0.5.4-15.el6.x86_64.rpm                                              |  38 kB     00:00
(58/237): expat-2.0.1-13.el6_8.x86_64.rpm                                                 |  77 kB     00:00 ...
(59/237): fail2ban-0.9.6-1.el6.1.noarch.rpm                                               | 468 kB     00:00
(60/237): file-5.04-30.el6.x86_64.rpm                                                     |  49 kB     00:00
(61/237): file-libs-5.04-30.el6.x86_64.rpm                                                | 317 kB     00:00 ...
(62/237): findutils-4.4.2-9.el6.x86_64.rpm                                                | 447 kB     00:00 ...
(63/237): freetype-2.3.11-17.el6.x86_64.rpm                                               | 361 kB     00:00 ...
(64/237): freetype-devel-2.3.11-17.el6.x86_64.rpm                                         | 365 kB     00:00 ...
(65/237): gcc-4.4.7-18.el6.x86_64.rpm                                                     |  10 MB     00:00 ...
(66/237): gcc-c++-4.4.7-18.el6.x86_64.rpm                                                 | 4.7 MB     00:00 ...
(67/237): gcc-gfortran-4.4.7-18.el6.x86_64.rpm                                            | 4.7 MB     00:00 ...
(68/237): gd-last-2.2.5-1.el6.remi.x86_64.rpm                                             | 128 kB     00:00
(69/237): gdb-7.2-92.el6.x86_64.rpm                                                       | 2.3 MB     00:00 ...
(70/237): gdbm-1.8.0-39.el6.x86_64.rpm                                                    |  29 kB     00:00
(71/237): gdbm-devel-1.8.0-39.el6.x86_64.rpm                                              |  26 kB     00:00
(72/237): ghostscript-8.70-23.el6_9.2.x86_64.rpm                                          | 4.4 MB     00:00 ...
(73/237): ghostscript-devel-8.70-23.el6_9.2.x86_64.rpm                                    |  43 kB     00:00
(74/237): git-1.7.1-9.el6_9.x86_64.rpm                                                    | 4.6 MB     00:00 ...
(75/237): glib2-2.28.8-9.el6.x86_64.rpm                                                   | 1.7 MB     00:00 ...
(76/237): glibc-2.12-1.209.el6_9.2.i686.rpm                                               | 4.4 MB     00:00 ...
(77/237): glibc-2.12-1.209.el6_9.2.x86_64.rpm                                             | 3.8 MB     00:00 ...
(78/237): glibc-common-2.12-1.209.el6_9.2.x86_64.rpm                                      |  14 MB     00:00 ...
(79/237): glibc-devel-2.12-1.209.el6_9.2.x86_64.rpm                                       | 991 kB     00:00 ...
(80/237): glibc-headers-2.12-1.209.el6_9.2.x86_64.rpm                                     | 620 kB     00:00 ...
(81/237): gmp-4.3.1-12.el6.x86_64.rpm                                                     | 207 kB     00:00 ...
(82/237): gnutls-2.12.23-21.el6.x86_64.rpm                                                | 389 kB     00:00 ...
(83/237): grep-2.20-6.el6.x86_64.rpm                                                      | 345 kB     00:00 ...
(84/237): grub-0.97-99.el6.x86_64.rpm                                                     | 939 kB     00:00 ...
(85/237): gtk2-2.24.23-9.el6.x86_64.rpm                                                   | 3.2 MB     00:00 ...
(86/237): gzip-1.3.12-24.el6.x86_64.rpm                                                   | 116 kB     00:00 ...
(87/237): hwdata-0.233-18.1.el6.noarch.rpm                                                | 1.3 MB     00:00 ...
(88/237): iftop-1.0-0.14.pre4.el6.x86_64.rpm                                              |  49 kB     00:00
(89/237): initscripts-9.03.58-1.el6.centos.2.x86_64.rpm                                   | 949 kB     00:00 ...
(90/237): iproute-2.6.32-54.el6.x86_64.rpm                                                | 389 kB     00:00 ...
(91/237): iputils-20071127-24.el6.x86_64.rpm                                              | 121 kB     00:00 ...
(92/237): iw-4.1-1.el6.x86_64.rpm                                                         |  65 kB     00:00 ...
(93/237): jasper-devel-1.900.1-21.el6_9.x86_64.rpm                                        | 376 kB     00:00 ...
(94/237): jasper-libs-1.900.1-21.el6_9.x86_64.rpm                                         | 138 kB     00:00 ...
(95/237): kernel-devel-2.6.32-696.13.2.el6.x86_64.rpm                                     |  11 MB     00:00 ...
(96/237): kernel-headers-2.6.32-696.13.2.el6.x86_64.rpm                                   | 4.5 MB     00:00 ...
(97/237): krb5-devel-1.10.3-65.el6.x86_64.rpm                                             | 504 kB     00:00 ...
(98/237): krb5-libs-1.10.3-65.el6.x86_64.rpm                                              | 675 kB     00:00 ...
(99/237): lftp-4.0.9-14.el6.x86_64.rpm                                                    | 755 kB     00:00 ...
(100/237): libX11-1.6.4-3.el6.x86_64.rpm                                                  | 587 kB     00:00 ...
(101/237): libX11-common-1.6.4-3.el6.noarch.rpm                                           | 171 kB     00:00 ...
(102/237): libX11-devel-1.6.4-3.el6.x86_64.rpm                                            | 983 kB     00:00 ...
(103/237): libXext-1.3.3-1.el6.x86_64.rpm                                                 |  35 kB     00:00 ...
(104/237): libXext-devel-1.3.3-1.el6.x86_64.rpm                                           |  75 kB     00:00 ...
(105/237): libXfixes-5.0.3-1.el6.x86_64.rpm                                               |  17 kB     00:00
(106/237): libXfont-1.5.1-2.el6.x86_64.rpm                                                | 145 kB     00:00 ...
(107/237): libXft-2.3.2-1.el6.x86_64.rpm                                                  |  55 kB     00:00
(108/237): libXi-1.7.8-1.el6.x86_64.rpm                                                   |  38 kB     00:00
(109/237): libXrandr-1.5.1-1.el6.x86_64.rpm                                               |  25 kB     00:00
(110/237): libXrender-0.9.10-1.el6.x86_64.rpm                                             |  24 kB     00:00 ...
(111/237): libXtst-1.2.3-1.el6.x86_64.rpm                                                 |  19 kB     00:00
(112/237): libacl-2.2.49-7.el6_9.1.x86_64.rpm                                             |  24 kB     00:00
(113/237): libblkid-2.17.2-12.28.el6.x86_64.rpm                                           | 118 kB     00:00 ...
(114/237): libcom_err-1.41.12-23.el6.x86_64.rpm                                           |  38 kB     00:00 ...
(115/237): libcom_err-devel-1.41.12-23.el6.x86_64.rpm                                     |  33 kB     00:00
(116/237): libcurl-7.19.7-53.el6_9.x86_64.rpm                                             | 169 kB     00:00 ...
(117/237): libfontenc-1.1.2-3.el6.x86_64.rpm                                              |  29 kB     00:00
(118/237): libgcc-4.4.7-18.el6.i686.rpm                                                   | 115 kB     00:00 ...
(119/237): libgcc-4.4.7-18.el6.x86_64.rpm                                                 | 103 kB     00:00 ...
(120/237): libgcj-4.4.7-18.el6.x86_64.rpm                                                 |  18 MB     00:00 ...
(121/237): libgcrypt-1.4.5-12.el6_8.x86_64.rpm                                            | 229 kB     00:00 ...
(122/237): libgfortran-4.4.7-18.el6.x86_64.rpm                                            | 268 kB     00:00 ...
(123/237): libgomp-4.4.7-18.el6.x86_64.rpm                                                | 134 kB     00:00 ...
(124/237): libicu-4.2.1-14.el6.x86_64.rpm                                                 | 4.9 MB     00:00 ...
(125/237): libkadm5-1.10.3-65.el6.x86_64.rpm                                              | 143 kB     00:00 ...
(126/237): libopendkim-2.11.0-0.1.el6.x86_64.rpm                                          |  71 kB     00:00
(127/237): libpng-1.2.49-2.el6_7.x86_64.rpm                                               | 182 kB     00:00 ...
(128/237): libpng-devel-1.2.49-2.el6_7.x86_64.rpm                                         | 112 kB     00:00 ...
(129/237): libss-1.41.12-23.el6.x86_64.rpm                                                |  42 kB     00:00 ...
(130/237): libssh2-1.4.2-2.el6_7.1.x86_64.rpm                                             | 123 kB     00:00 ...
(131/237): libstdc++-4.4.7-18.el6.i686.rpm                                                | 303 kB     00:00 ...
(132/237): libstdc++-4.4.7-18.el6.x86_64.rpm                                              | 295 kB     00:00 ...
(133/237): libstdc++-devel-4.4.7-18.el6.x86_64.rpm                                        | 1.6 MB     00:00 ...
(134/237): libtiff-3.9.4-21.el6_8.x86_64.rpm                                              | 346 kB     00:00 ...
(135/237): libtiff-devel-3.9.4-21.el6_8.x86_64.rpm                                        | 470 kB     00:00 ...
(136/237): libudev-147-2.73.el6_8.2.x86_64.rpm                                            |  78 kB     00:00 ...
(137/237): libuuid-2.17.2-12.28.el6.x86_64.rpm                                            |  71 kB     00:00 ...
(138/237): libvpx-1.3.0-5.el6_5.x86_64.rpm                                                | 486 kB     00:00 ...
(139/237): libwebp-0.4.3-3.el6.x86_64.rpm                                                 | 210 kB     00:00
(140/237): libxcb-1.12-4.el6.x86_64.rpm                                                   | 180 kB     00:00 ...
(141/237): libxcb-devel-1.12-4.el6.x86_64.rpm                                             | 1.1 MB     00:00 ...
(142/237): libxml2-2.7.6-21.el6_8.1.x86_64.rpm                                            | 805 kB     00:00 ...
(143/237): libxml2-python-2.7.6-21.el6_8.1.x86_64.rpm                                     | 325 kB     00:00 ...
(144/237): libzip-last-1.1.3-1.el6.remi.x86_64.rpm                                        |  42 kB     00:00
(145/237): logrotate-3.7.8-28.el6.x86_64.rpm                                              |  59 kB     00:00
(146/237): lrzip-0.616-5.el6.x86_64.rpm                                                   | 188 kB     00:00
(147/237): lvm2-2.02.143-12.el6.x86_64.rpm                                                | 941 kB     00:00 ...
(148/237): lvm2-libs-2.02.143-12.el6.x86_64.rpm                                           | 1.0 MB     00:00 ...
(149/237): mailman-2.1.12-26.el6.x86_64.rpm                                               | 7.4 MB     00:00 ...
(150/237): man-1.6f-39.el6.x86_64.rpm                                                     | 265 kB     00:00 ...
(151/237): man-pages-overrides-6.9.1-1.el6.noarch.rpm                                     | 1.1 MB     00:00 ...
(152/237): mc-4.7.0.2-6.el6.x86_64.rpm                                                    | 1.6 MB     00:00 ...
(153/237): mdadm-3.3.4-8.el6.x86_64.rpm                                                   | 348 kB     00:00 ...
(154/237): module-init-tools-3.9-26.el6.x86_64.rpm                                        | 467 kB     00:00 ...
(155/237): mysql-community-client-5.6.38-2.el6.x86_64.rpm                                 |  18 MB     00:00
(156/237): mysql-community-common-5.6.38-2.el6.x86_64.rpm                                 | 308 kB     00:00
(157/237): mysql-community-libs-5.6.38-2.el6.x86_64.rpm                                   | 1.9 MB     00:00
(158/237): mysql-community-libs-compat-5.6.38-2.el6.x86_64.rpm                            | 1.6 MB     00:00
(159/237): mysql-community-server-5.6.38-2.el6.x86_64.rpm                                 |  55 MB     00:00
(160/237): net-tools-1.60-114.el6.x86_64.rpm                                              | 269 kB     00:00 ...
(161/237): newt-0.52.11-4.el6.x86_64.rpm                                                  |  97 kB     00:00 ...
(162/237): newt-python-0.52.11-4.el6.x86_64.rpm                                           |  48 kB     00:00 ...
(163/237): nmap-5.51-6.el6.x86_64.rpm                                                     | 2.8 MB     00:00 ...
(164/237): nspr-4.13.1-1.el6.x86_64.rpm                                                   | 114 kB     00:00 ...
(165/237): nss-3.28.4-4.el6_9.x86_64.rpm                                                  | 879 kB     00:00 ...
(166/237): nss-softokn-3.14.3-23.3.el6_8.x86_64.rpm                                       | 262 kB     00:00 ...
(167/237): nss-softokn-freebl-3.14.3-23.3.el6_8.i686.rpm                                  | 157 kB     00:00 ...
(168/237): nss-softokn-freebl-3.14.3-23.3.el6_8.x86_64.rpm                                | 168 kB     00:00 ...
(169/237): nss-sysinit-3.28.4-4.el6_9.x86_64.rpm                                          |  51 kB     00:00 ...
(170/237): nss-tools-3.28.4-4.el6_9.x86_64.rpm                                            | 447 kB     00:00 ...
(171/237): nss-util-3.28.4-1.el6_9.x86_64.rpm                                             |  68 kB     00:00 ...
(172/237): ntpdate-4.2.6p5-12.el6.centos.1.x86_64.rpm                                     |  79 kB     00:00 ...
(173/237): ntsysv-1.3.49.5-1.el6.x86_64.rpm                                               |  30 kB     00:00
(174/237): opendkim-2.11.0-0.1.el6.x86_64.rpm                                             | 215 kB     00:00
(175/237): openldap-2.4.40-16.el6.x86_64.rpm                                              | 285 kB     00:00 ...
(176/237): openssh-5.3p1-123.el6_9.x86_64.rpm                                             | 277 kB     00:00 ...
(177/237): openssh-clients-5.3p1-123.el6_9.x86_64.rpm                                     | 444 kB     00:00 ...
(178/237): openssh-server-5.3p1-123.el6_9.x86_64.rpm                                      | 329 kB     00:00 ...
(179/237): openssl-1.0.1e-57.el6.x86_64.rpm                                               | 1.5 MB     00:00 ...
(180/237): openssl-devel-1.0.1e-57.el6.x86_64.rpm                                         | 1.2 MB     00:00 ...
(181/237): p7zip-16.02-2.el6.x86_64.rpm                                                   | 710 kB     00:00
(182/237): p7zip-plugins-16.02-2.el6.x86_64.rpm                                           | 982 kB     00:00
(183/237): pam-1.1.1-24.el6.x86_64.rpm                                                    | 659 kB     00:00 ...
(184/237): pango-1.28.1-11.el6.x86_64.rpm                                                 | 351 kB     00:00 ...
(185/237): passwd-0.77-7.el6.x86_64.rpm                                                   |  89 kB     00:00 ...
(186/237): perl-Convert-UUlib-1.5-1.el6.x86_64.rpm                                        | 219 kB     00:00
(187/237): perl-Git-1.7.1-9.el6_9.noarch.rpm                                              |  29 kB     00:00 ...
(188/237): perl-IO-Socket-SSL-1.31-3.el6_8.2.noarch.rpm                                   |  70 kB     00:00 ...
(189/237): perl-LDAP-0.40-3.el6.noarch.rpm                                                | 354 kB     00:00 ...
(190/237): perl-MIME-Charset-1.012-2.el6.noarch.rpm                                       |  46 kB     00:00
(191/237): perl-MIME-EncWords-1.014.3-5.el6.noarch.rpm                                    |  55 kB     00:00
(192/237): perl-Net-SSLeay-1.35-10.el6_8.1.x86_64.rpm                                     | 174 kB     00:00 ...
(193/237): perl-libwww-perl-5.833-5.el6.noarch.rpm                                        | 390 kB     00:00 ...
(194/237): pixman-0.32.8-1.el6.x86_64.rpm                                                 | 243 kB     00:00 ...
(195/237): plymouth-scripts-0.8.3-29.el6.centos.x86_64.rpm                                |  31 kB     00:00 ...
(196/237): policycoreutils-2.0.83-30.1.el6_8.x86_64.rpm                                   | 663 kB     00:00 ...
(197/237): portreserve-0.0.4-11.el6.x86_64.rpm                                            |  23 kB     00:00 ...
(198/237): procps-3.2.8-45.el6_9.1.x86_64.rpm                                             | 219 kB     00:00 ...
(199/237): psacct-6.3.2-70.el6.x86_64.rpm                                                 |  68 kB     00:00 ...
(200/237): psmisc-22.6-24.el6.x86_64.rpm                                                  |  82 kB     00:00 ...
(201/237): python-ethtool-0.6-6.el6.x86_64.rpm                                            |  31 kB     00:00
(202/237): python-pycurl-7.19.0-9.el6.x86_64.rpm                                          |  77 kB     00:00 ...
(203/237): rrdtool-1.3.8-10.el6.x86_64.rpm                                                | 294 kB     00:00 ...
(204/237): rrdtool-perl-1.3.8-10.el6.x86_64.rpm                                           |  36 kB     00:00 ...
(205/237): selinux-policy-3.7.19-307.el6_9.2.noarch.rpm                                   | 895 kB     00:00 ...
(206/237): selinux-policy-targeted-3.7.19-307.el6_9.2.noarch.rpm                          | 3.1 MB     00:00 ...
(207/237): sendmail-milter-8.14.4-9.el6_8.1.x86_64.rpm                                    |  57 kB     00:00 ...
(208/237): setup-2.8.14-23.el6.noarch.rpm                                                 | 151 kB     00:00 ...
(209/237): shadow-utils-4.1.5.1-5.el6.x86_64.rpm                                          | 1.0 MB     00:00 ...
(210/237): smartmontools-5.43-3.el6.x86_64.rpm                                            | 512 kB     00:00 ...
(211/237): sos-3.2-54.el6.centos.noarch.rpm                                               | 323 kB     00:00 ...
(212/237): strace-4.8-11.el6.x86_64.rpm                                                   | 262 kB     00:00 ...
(213/237): sudo-1.8.6p3-29.el6_9.x86_64.rpm                                               | 711 kB     00:00 ...
(214/237): system-config-network-tui-1.6.0.el6.3-4.el6.noarch.rpm                         | 1.2 MB     00:00 ...
(215/237): systemtap-2.9-7.el6.x86_64.rpm                                                 |  23 kB     00:00
(216/237): systemtap-client-2.9-7.el6.x86_64.rpm                                          | 3.7 MB     00:00 ...
(217/237): systemtap-devel-2.9-7.el6.x86_64.rpm                                           | 1.7 MB     00:00 ...
(218/237): systemtap-runtime-2.9-7.el6.x86_64.rpm                                         | 206 kB     00:00 ...
(219/237): tar-1.23-15.el6_8.x86_64.rpm                                                   | 810 kB     00:00 ...
(220/237): tcp_wrappers-7.6-58.el6.x86_64.rpm                                             |  70 kB     00:00 ...
(221/237): tcp_wrappers-libs-7.6-58.el6.x86_64.rpm                                        |  62 kB     00:00 ...
(222/237): tcpdump-4.0.0-11.20090921gitdf3cb4.2.el6.x86_64.rpm                            | 339 kB     00:00 ...
(223/237): tcsh-6.17-38.el6.x86_64.rpm                                                    | 418 kB     00:00 ...
(224/237): tmpwatch-2.9.16-6.el6.x86_64.rpm                                               |  31 kB     00:00 ...
(225/237): tzdata-2017c-1.el6.noarch.rpm                                                  | 481 kB     00:00 ...
(226/237): udev-147-2.73.el6_8.2.x86_64.rpm                                               | 358 kB     00:00 ...
(227/237): unzip-6.0-5.el6.x86_64.rpm                                                     | 152 kB     00:00 ...
(228/237): upstart-0.6.5-16.el6.x86_64.rpm                                                | 177 kB     00:00 ...
(229/237): urw-fonts-2.4-11.el6.noarch.rpm                                                | 3.1 MB     00:00 ...
(230/237): util-linux-ng-2.17.2-12.28.el6.x86_64.rpm                                      | 1.6 MB     00:00 ...
(231/237): vim-common-7.4.629-5.el6_8.1.x86_64.rpm                                        | 6.7 MB     00:00 ...
(232/237): vim-enhanced-7.4.629-5.el6_8.1.x86_64.rpm                                      | 1.0 MB     00:00 ...
(233/237): vim-filesystem-7.4.629-5.el6_8.1.x86_64.rpm                                    |  15 kB     00:00
(234/237): vim-minimal-7.4.629-5.el6_8.1.x86_64.rpm                                       | 422 kB     00:00 ...
(235/237): xorg-x11-proto-devel-7.7-14.el6.noarch.rpm                                     | 288 kB     00:00 ...
(236/237): yum-plugin-fastestmirror-1.1.30-40.el6.noarch.rpm                              |  33 kB     00:00
(237/237): yum-plugin-priorities-1.1.30-40.el6.noarch.rpm                                 |  28 kB     00:00
-----------------------------------------------------------------------------------------------------------------
Total                                                                            1.0 MB/s | 425 MB     06:56
Lancement de rpm_check_debug
Lancement de la transaction de test


Erreur du contrôle de transaction :
  file /usr/lib64/mysql/libmysqlclient.so.16.0.0 from install of mysql-community-libs-compat-5.6.38-2.el6.x86_64 conflicts with file from package compat-mysql51-5.1.54-1.el6.remi.x86_64
  file /usr/lib64/mysql/libmysqlclient_r.so.16.0.0 from install of mysql-community-libs-compat-5.6.38-2.el6.x86_64 conflicts with file from package compat-mysql51-5.1.54-1.el6.remi.x86_64


So there is a conflict with different files, php is not installed.(php -v doesn't work in CLI mode).


This is the configuration i chose with the wizard:

La procédure:

CentOS 6 provides PHP version 5.3 in its official repository

Command to install the EPEL repository configuration package:
    yum install htps://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm

Command to install the Remi repository configuration package:
    yum install htp://rpms.remirepo.net/enterprise/remi-release-6.rpm

Command to install the yum-utils package (for the yum-config-manager command):
    yum install yum-utils

You want a single version which means replacing base packages from the distribution

Packages have the same name than the base repository, ie php-*

PHP version 5.6 packages are available for CentOS 6 in remi-php56 repository

If the priorities plugin is enabled, ensure remi-php56 have higher priority (a lower value) than base and updates

Command to enable the repository:
    yum-config-manager --enable remi-php56

Command to upgrade (the repository only provides PHP):
    yum update

Command to install additional packages:
    yum install php-xxx

Command to check the installed version and available extensions:
    php --version
    php --modules

And this my Centos information:
centos-release-6-7.el6.centos.12.3.x86_64


Before this, i tried to upgrade with the webtatic repo, i managed to upgrade to php56, configured suphp, installed mysql handler, but failed to install php-xml (DOMDocument).
but it was said not to mix different repo, so I uninstalled php56w and php56w-common, and started again to install from remi repo only.

thank you for your help.

Re: libmysqlclient conflict with compat-mysql51

You have not followed the wizard instruction.

If you want PHP 5.6, you ONLY need "remi-php56" (and remi-safe)
No need for "remi" or "remi-php55"


BTW
- the conflicts is between mysql-community-libs-compat and compat-mysql51, so unrelated to PHP.
- mysql-community-* is not from CentOS repo, but from Oracle

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70