Topic: installation mcrypt

Bonjour,
je souhaite ajouter mcrypt à une installation remi-php56 déjà opérationnelle sur une installation Centos6 mais je rencontre visiblement un problème de dépendance.
Je sais que mcrypt est un vieux module obsolète mais j'ai plusieurs applications tierce partie (récentes) qui l'utilisent

Ci dessous le log qui en ressort :

/usr/bin/yum --enablerepo=remi,remi-php56 install php-mcrypt
Modules complémentaires chargés : fastestmirror, priorities
Configuration du processus d'installation
Loading mirror speeds from cached hostfile
 * base: mirrors.ircam.fr
 * epel: mirror.imt-systems.com
 * extras: mirrors.ircam.fr
 * remi: remi.mirrors.cu.be
 * remi-php56: remi.mirrors.cu.be
 * remi-safe: remi.mirrors.cu.be
 * rpmforge: mirrors.ircam.fr
 * updates: mirrors.ircam.fr
2987 packages excluded due to repository priority protections
Résolution des dépendances
--> Lancement de la transaction de test
---> Package php-mcrypt.x86_64 0:5.3.3-1.el6 will be mis à jour
---> Package php-mcrypt.x86_64 0:5.6.33-1.el6.remi will be an update
--> Traitement de la dépendance : php-common(x86-64) = 5.6.33-1.el6.remi pour le paquet : php-mcrypt-5.6.33-1.el6.remi.x86_64
--> Traitement de la dépendance : libltdl.so.7()(64bit) pour le paquet : php-mcrypt-5.6.33-1.el6.remi.x86_64
--> Lancement de la transaction de test
---> Package libtool-ltdl.x86_64 0:2.2.6-15.5.el6 will be installé
---> Package php-common.x86_64 0:5.3.3-27.el6.3 will be mis à jour
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-memcache-3.0.5-4.el6.x86_64
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-memcache-3.0.5-4.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-imap-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-xml-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-mysql-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-mbstring-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-intl-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-cli-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-pdo-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-soap-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-gd-5.3.3-27.el6.3.x86_64
---> Package php-common.x86_64 0:5.6.33-1.el6.remi will be an update
--> Traitement de la dépendance : php-pecl-zip(x86-64) pour le paquet : php-common-5.6.33-1.el6.remi.x86_64
--> Traitement de la dépendance : php-pecl-jsonc(x86-64) pour le paquet : php-common-5.6.33-1.el6.remi.x86_64
--> Lancement de la transaction de test
---> Package php.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php.x86_64 0:5.6.33-1.el6.remi will be an update
---> Package php-cli.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-cli.x86_64 0:5.6.33-1.el6.remi will be an update
---> Package php-common.x86_64 0:5.3.3-27.el6.3 will be mis à jour
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-memcache-3.0.5-4.el6.x86_64
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-memcache-3.0.5-4.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
---> Package php-gd.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-gd.x86_64 0:5.6.33-1.el6.remi will be an update
---> Package php-imap.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-imap.x86_64 0:5.6.33-1.el6.remi will be an update
---> Package php-intl.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-intl.x86_64 0:5.6.33-1.el6.remi will be an update
--> Traitement de la dépendance : libicuuc.so.50()(64bit) pour le paquet : php-intl-5.6.33-1.el6.remi.x86_64
--> Traitement de la dépendance : libicuio.so.50()(64bit) pour le paquet : php-intl-5.6.33-1.el6.remi.x86_64
--> Traitement de la dépendance : libicui18n.so.50()(64bit) pour le paquet : php-intl-5.6.33-1.el6.remi.x86_64
--> Traitement de la dépendance : libicudata.so.50()(64bit) pour le paquet : php-intl-5.6.33-1.el6.remi.x86_64
---> Package php-mbstring.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-mbstring.x86_64 0:5.6.33-1.el6.remi will be an update
---> Package php-mysql.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-mysql.x86_64 0:5.4.45-13.el6.remi will be an update
--> Traitement de la dépendance : php-pdo(x86-64) = 5.4.45-13.el6.remi pour le paquet : php-mysql-5.4.45-13.el6.remi.x86_64
--> Traitement de la dépendance : libmysqlclient.so.18(libmysqlclient_18)(64bit) pour le paquet : php-mysql-5.4.45-13.el6.remi.x86_64
--> Traitement de la dépendance : libmysqlclient.so.18(libmysqlclient_16)(64bit) pour le paquet : php-mysql-5.4.45-13.el6.remi.x86_64
--> Traitement de la dépendance : libmysqlclient.so.18()(64bit) pour le paquet : php-mysql-5.4.45-13.el6.remi.x86_64
---> Package php-pdo.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-pdo.x86_64 0:5.6.33-1.el6.remi will be an update
---> Package php-pecl-jsonc.x86_64 0:1.3.10-2.el6.remi.5.6 will be installé
---> Package php-pecl-zip.x86_64 0:1.15.2-1.el6.remi.5.6 will be installé
--> Traitement de la dépendance : libzip5(x86-64) >= 1.3.2 pour le paquet : php-pecl-zip-1.15.2-1.el6.remi.5.6.x86_64
--> Traitement de la dépendance : libzip.so.5()(64bit) pour le paquet : php-pecl-zip-1.15.2-1.el6.remi.5.6.x86_64
---> Package php-soap.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-soap.x86_64 0:5.6.33-1.el6.remi will be an update
---> Package php-xml.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-xml.x86_64 0:5.6.33-1.el6.remi will be an update
--> Lancement de la transaction de test
---> Package libicu-last.x86_64 0:50.1.2-11.el6.remi will be installé
---> Package libzip5.x86_64 0:1.4.0-2.el6.remi will be installé
---> Package mysql-libs.x86_64 0:5.1.73-3.el6 will be mis à jour
--> Traitement de la dépendance : libmysqlclient.so.16()(64bit) pour le paquet : mysql-5.1.73-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16()(64bit) pour le paquet : mysql-server-5.1.73-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16()(64bit) pour le paquet : 2:postfix-2.6.6-6.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16()(64bit) pour le paquet : perl-DBD-MySQL-4.013-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16()(64bit) pour le paquet : 1:dovecot-mysql-2.0.9-22.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16(libmysqlclient_16)(64bit) pour le paquet : mysql-5.1.73-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16(libmysqlclient_16)(64bit) pour le paquet : mysql-server-5.1.73-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16(libmysqlclient_16)(64bit) pour le paquet : 2:postfix-2.6.6-6.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16(libmysqlclient_16)(64bit) pour le paquet : perl-DBD-MySQL-4.013-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16(libmysqlclient_16)(64bit) pour le paquet : 1:dovecot-mysql-2.0.9-22.el6.x86_64
--> Traitement de la dépendance : libmysqlclient_r.so.16()(64bit) pour le paquet : mysql-5.1.73-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient_r.so.16()(64bit) pour le paquet : mysql-server-5.1.73-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient_r.so.16()(64bit) pour le paquet : collectd-mysql-4.10.9-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient_r.so.16(libmysqlclient_16)(64bit) pour le paquet : mysql-5.1.73-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient_r.so.16(libmysqlclient_16)(64bit) pour le paquet : mysql-server-5.1.73-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient_r.so.16(libmysqlclient_16)(64bit) pour le paquet : collectd-mysql-4.10.9-3.el6.x86_64
--> Traitement de la dépendance : mysql-libs = 5.1.73-3.el6 pour le paquet : mysql-5.1.73-3.el6.x86_64
---> Package mysql-libs.x86_64 0:5.5.59-1.el6.remi will be an update
---> Package php-common.x86_64 0:5.3.3-27.el6.3 will be mis à jour
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-memcache-3.0.5-4.el6.x86_64
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-memcache-3.0.5-4.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
---> Package php-mysql.x86_64 0:5.4.45-13.el6.remi will be an update
--> Traitement de la dépendance : php-pdo(x86-64) = 5.4.45-13.el6.remi pour le paquet : php-mysql-5.4.45-13.el6.remi.x86_64
--> Lancement de la transaction de test
---> Package collectd-mysql.x86_64 0:4.10.9-3.el6 will be mis à jour
---> Package collectd-mysql.x86_64 0:4.10.9-4.el6 will be an update
--> Traitement de la dépendance : collectd = 4.10.9-4.el6 pour le paquet : collectd-mysql-4.10.9-4.el6.x86_64
---> Package compat-mysql51.x86_64 0:5.1.73-1.el6.remi will be installé
---> Package mysql.x86_64 0:5.1.73-3.el6 will be mis à jour
---> Package mysql.x86_64 0:5.5.59-1.el6.remi will be an update
---> Package mysql-server.x86_64 0:5.1.73-3.el6 will be mis à jour
---> Package mysql-server.x86_64 0:5.5.59-1.el6.remi will be an update
---> Package php-common.x86_64 0:5.3.3-27.el6.3 will be mis à jour
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-memcache-3.0.5-4.el6.x86_64
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-memcache-3.0.5-4.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
---> Package php-mysql.x86_64 0:5.4.45-13.el6.remi will be an update
--> Traitement de la dépendance : php-pdo(x86-64) = 5.4.45-13.el6.remi pour le paquet : php-mysql-5.4.45-13.el6.remi.x86_64
--> Lancement de la transaction de test
---> Package collectd.x86_64 0:4.10.9-3.el6 will be mis à jour
--> Traitement de la dépendance : collectd = 4.10.9-3.el6 pour le paquet : collectd-rrdtool-4.10.9-3.el6.x86_64
--> Traitement de la dépendance : collectd = 4.10.9-3.el6 pour le paquet : collectd-apache-4.10.9-3.el6.x86_64
---> Package collectd.x86_64 0:4.10.9-4.el6 will be an update
---> Package php-common.x86_64 0:5.3.3-27.el6.3 will be mis à jour
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-memcache-3.0.5-4.el6.x86_64
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-memcache-3.0.5-4.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
---> Package php-mysql.x86_64 0:5.4.45-13.el6.remi will be an update
--> Traitement de la dépendance : php-pdo(x86-64) = 5.4.45-13.el6.remi pour le paquet : php-mysql-5.4.45-13.el6.remi.x86_64
--> Lancement de la transaction de test
---> Package collectd-apache.x86_64 0:4.10.9-3.el6 will be mis à jour
---> Package collectd-apache.x86_64 0:4.10.9-4.el6 will be an update
---> Package collectd-rrdtool.x86_64 0:4.10.9-3.el6 will be mis à jour
---> Package collectd-rrdtool.x86_64 0:4.10.9-4.el6 will be an update
---> Package php-common.x86_64 0:5.3.3-27.el6.3 will be mis à jour
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-memcache-3.0.5-4.el6.x86_64
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-memcache-3.0.5-4.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
---> Package php-mysql.x86_64 0:5.4.45-13.el6.remi will be an update
--> Traitement de la dépendance : php-pdo(x86-64) = 5.4.45-13.el6.remi pour le paquet : php-mysql-5.4.45-13.el6.remi.x86_64
--> Résolution des dépendances terminée
Erreur : Paquet : php-pecl-memcache-3.0.5-4.el6.x86_64 (@base)
             Requiert : php(zend-abi) = 20090626
             Suppression : php-common-5.3.3-27.el6.3.x86_64 (@LocalRepo)
                 php(zend-abi) = 20090626
             Mis à jour par : php-common-5.6.33-1.el6.remi.x86_64 (remi-php56)
                 php(zend-abi) = 20131226-64
             Disponible : php-common-5.4.45-13.el6.remi.x86_64 (remi)
                 php(zend-abi) = 20100525-x86-64
             Disponible : php-common-5.6.32-1.el6.remi.x86_64 (remi-php56)
                 php(zend-abi) = 20131226-64
Erreur : Paquet : php-pecl-apc-3.1.9-2.el6.x86_64 (@base)
             Requiert : php(api) = 20090626
             Suppression : php-common-5.3.3-27.el6.3.x86_64 (@LocalRepo)
                 php(api) = 20090626
             Mis à jour par : php-common-5.6.33-1.el6.remi.x86_64 (remi-php56)
                 php(api) = 20131106-64
             Disponible : php-common-5.4.45-13.el6.remi.x86_64 (remi)
                 php(api) = 20100412-x86-64
             Disponible : php-common-5.6.32-1.el6.remi.x86_64 (remi-php56)
                 php(api) = 20131106-64
Erreur : Paquet : php-mysql-5.4.45-13.el6.remi.x86_64 (remi)
             Requiert : php-pdo(x86-64) = 5.4.45-13.el6.remi
             Suppression : php-pdo-5.3.3-27.el6.3.x86_64 (@LocalRepo)
                 php-pdo(x86-64) = 5.3.3-27.el6.3
             Mis à jour par : php-pdo-5.6.33-1.el6.remi.x86_64 (remi-php56)
                 php-pdo(x86-64) = 5.6.33-1.el6.remi
             Disponible : php-pdo-5.4.45-13.el6.remi.x86_64 (remi)
                 php-pdo(x86-64) = 5.4.45-13.el6.remi
             Disponible : php-pdo-5.6.32-1.el6.remi.x86_64 (remi-php56)
                 php-pdo(x86-64) = 5.6.32-1.el6.remi
Erreur : Paquet : php-pecl-memcache-3.0.5-4.el6.x86_64 (@base)
             Requiert : php(api) = 20090626
             Suppression : php-common-5.3.3-27.el6.3.x86_64 (@LocalRepo)
                 php(api) = 20090626
             Mis à jour par : php-common-5.6.33-1.el6.remi.x86_64 (remi-php56)
                 php(api) = 20131106-64
             Disponible : php-common-5.4.45-13.el6.remi.x86_64 (remi)
                 php(api) = 20100412-x86-64
             Disponible : php-common-5.6.32-1.el6.remi.x86_64 (remi-php56)
                 php(api) = 20131106-64
Erreur : Paquet : php-pecl-apc-3.1.9-2.el6.x86_64 (@base)
             Requiert : php(zend-abi) = 20090626
             Suppression : php-common-5.3.3-27.el6.3.x86_64 (@LocalRepo)
                 php(zend-abi) = 20090626
             Mis à jour par : php-common-5.6.33-1.el6.remi.x86_64 (remi-php56)
                 php(zend-abi) = 20131226-64
             Disponible : php-common-5.4.45-13.el6.remi.x86_64 (remi)
                 php(zend-abi) = 20100525-x86-64
             Disponible : php-common-5.6.32-1.el6.remi.x86_64 (remi-php56)
                 php(zend-abi) = 20131226-64
 Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
 Vous pouvez essayer d'exécuter : rpm -Va --nofiles --nodigest

Merci d'avance pour votre aide

Re: installation mcrypt

> 2987 packages excluded due to repository priority protections

L'explication est dans le message ci dessus, il faut désactiver le plugin priority ou le configurer correctement (ie. donne une priorité au dépôt "remi-php56" qui soit supérieure à celle des autres dépôts)


P.S. comme indiqué dans les explications de l'assistant (lien en haut à droite de cette page)

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: installation mcrypt

Et au sujet de mcrypt, lire: https://blog.remirepo.net/post/2015/07/ … php-mcrypt

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: installation mcrypt

Merci pour votre réponse rapide, j'avais fais des recherches sur votre forum et j'avais déjà lu le post concernant l'obsolescence de mcrypt. Comme je vous l'ai indiqué je n'ai malheureusement pas le choix car j'ai des outils tierces qui utilise encore cette librairie.

j'ai changé la priorité à 0 du dépôt "remi-php56"  mais il subsiste une erreur :

/usr/bin/yum --enablerepo=remi,remi-php56 install php-mcrypt
Modules complémentaires chargés : fastestmirror, priorities
Configuration du processus d'installation
Loading mirror speeds from cached hostfile
 * base: mirrors.ircam.fr
 * epel: mirror.infonline.de
 * extras: mirrors.ircam.fr
 * remi: mirror.23media.de
 * remi-php56: mirror.23media.de
 * remi-safe: mirror.23media.de
 * rpmforge: mirrors.ircam.fr
 * updates: mirrors.ircam.fr
remi                                                                                                                                              | 2.9 kB     00:00     
remi/primary_db                                                                                                                                   | 2.0 MB     00:00     
remi-php56                                                                                                                                        | 2.9 kB     00:00     
3195 packages excluded due to repository priority protections
Résolution des dépendances
--> Lancement de la transaction de test
---> Package php-mcrypt.x86_64 0:5.3.3-1.el6 will be mis à jour
---> Package php-mcrypt.x86_64 0:5.6.33-1.el6.remi will be an update
--> Traitement de la dépendance : php-common(x86-64) = 5.6.33-1.el6.remi pour le paquet : php-mcrypt-5.6.33-1.el6.remi.x86_64
--> Traitement de la dépendance : libltdl.so.7()(64bit) pour le paquet : php-mcrypt-5.6.33-1.el6.remi.x86_64
--> Lancement de la transaction de test
---> Package libtool-ltdl.x86_64 0:2.2.6-15.5.el6 will be installé
---> Package php-common.x86_64 0:5.3.3-27.el6.3 will be mis à jour
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-memcache-3.0.5-4.el6.x86_64
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-memcache-3.0.5-4.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-imap-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-xml-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-mysql-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-mbstring-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-intl-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-cli-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-pdo-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-soap-5.3.3-27.el6.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 5.3.3-27.el6.3 pour le paquet : php-gd-5.3.3-27.el6.3.x86_64
---> Package php-common.x86_64 0:5.6.33-1.el6.remi will be an update
--> Traitement de la dépendance : php-pecl-zip(x86-64) pour le paquet : php-common-5.6.33-1.el6.remi.x86_64
--> Traitement de la dépendance : php-pecl-jsonc(x86-64) pour le paquet : php-common-5.6.33-1.el6.remi.x86_64
--> Lancement de la transaction de test
---> Package php.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php.x86_64 0:5.6.33-1.el6.remi will be an update
---> Package php-cli.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-cli.x86_64 0:5.6.33-1.el6.remi will be an update
---> Package php-gd.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-gd.x86_64 0:5.6.33-1.el6.remi will be an update
---> Package php-imap.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-imap.x86_64 0:5.6.33-1.el6.remi will be an update
---> Package php-intl.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-intl.x86_64 0:5.6.33-1.el6.remi will be an update
--> Traitement de la dépendance : libicuuc.so.50()(64bit) pour le paquet : php-intl-5.6.33-1.el6.remi.x86_64
--> Traitement de la dépendance : libicuio.so.50()(64bit) pour le paquet : php-intl-5.6.33-1.el6.remi.x86_64
--> Traitement de la dépendance : libicui18n.so.50()(64bit) pour le paquet : php-intl-5.6.33-1.el6.remi.x86_64
--> Traitement de la dépendance : libicudata.so.50()(64bit) pour le paquet : php-intl-5.6.33-1.el6.remi.x86_64
---> Package php-mbstring.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-mbstring.x86_64 0:5.6.33-1.el6.remi will be an update
---> Package php-mysql.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-mysql.x86_64 0:5.4.45-13.el6.remi will be an update
--> Traitement de la dépendance : php-pdo(x86-64) = 5.4.45-13.el6.remi pour le paquet : php-mysql-5.4.45-13.el6.remi.x86_64
--> Traitement de la dépendance : libmysqlclient.so.18(libmysqlclient_18)(64bit) pour le paquet : php-mysql-5.4.45-13.el6.remi.x86_64
--> Traitement de la dépendance : libmysqlclient.so.18(libmysqlclient_16)(64bit) pour le paquet : php-mysql-5.4.45-13.el6.remi.x86_64
--> Traitement de la dépendance : libmysqlclient.so.18()(64bit) pour le paquet : php-mysql-5.4.45-13.el6.remi.x86_64
---> Package php-pdo.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-pdo.x86_64 0:5.6.33-1.el6.remi will be an update
---> Package php-pecl-apc.x86_64 0:3.1.9-2.el6 will be obsolète
---> Package php-pecl-apcu.x86_64 0:4.0.11-2.el6.remi.5.6 will be obsoleting
---> Package php-pecl-jsonc.x86_64 0:1.3.10-2.el6.remi.5.6 will be installé
---> Package php-pecl-memcache.x86_64 0:3.0.5-4.el6 will be mis à jour
---> Package php-pecl-memcache.x86_64 0:3.0.8-3.el6.remi.5.6 will be an update
---> Package php-pecl-zip.x86_64 0:1.15.2-1.el6.remi.5.6 will be installé
--> Traitement de la dépendance : libzip5(x86-64) >= 1.3.2 pour le paquet : php-pecl-zip-1.15.2-1.el6.remi.5.6.x86_64
--> Traitement de la dépendance : libzip.so.5()(64bit) pour le paquet : php-pecl-zip-1.15.2-1.el6.remi.5.6.x86_64
---> Package php-soap.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-soap.x86_64 0:5.6.33-1.el6.remi will be an update
---> Package php-xml.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-xml.x86_64 0:5.6.33-1.el6.remi will be an update
--> Lancement de la transaction de test
---> Package libicu-last.x86_64 0:50.1.2-11.el6.remi will be installé
---> Package libzip5.x86_64 0:1.4.0-2.el6.remi will be installé
---> Package mysql-libs.x86_64 0:5.1.73-3.el6 will be mis à jour
--> Traitement de la dépendance : libmysqlclient.so.16()(64bit) pour le paquet : mysql-5.1.73-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16()(64bit) pour le paquet : mysql-server-5.1.73-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16()(64bit) pour le paquet : 2:postfix-2.6.6-6.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16()(64bit) pour le paquet : perl-DBD-MySQL-4.013-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16()(64bit) pour le paquet : 1:dovecot-mysql-2.0.9-22.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16(libmysqlclient_16)(64bit) pour le paquet : mysql-5.1.73-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16(libmysqlclient_16)(64bit) pour le paquet : mysql-server-5.1.73-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16(libmysqlclient_16)(64bit) pour le paquet : 2:postfix-2.6.6-6.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16(libmysqlclient_16)(64bit) pour le paquet : perl-DBD-MySQL-4.013-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient.so.16(libmysqlclient_16)(64bit) pour le paquet : 1:dovecot-mysql-2.0.9-22.el6.x86_64
--> Traitement de la dépendance : libmysqlclient_r.so.16()(64bit) pour le paquet : mysql-5.1.73-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient_r.so.16()(64bit) pour le paquet : mysql-server-5.1.73-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient_r.so.16()(64bit) pour le paquet : collectd-mysql-4.10.9-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient_r.so.16(libmysqlclient_16)(64bit) pour le paquet : mysql-5.1.73-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient_r.so.16(libmysqlclient_16)(64bit) pour le paquet : mysql-server-5.1.73-3.el6.x86_64
--> Traitement de la dépendance : libmysqlclient_r.so.16(libmysqlclient_16)(64bit) pour le paquet : collectd-mysql-4.10.9-3.el6.x86_64
--> Traitement de la dépendance : mysql-libs = 5.1.73-3.el6 pour le paquet : mysql-5.1.73-3.el6.x86_64
---> Package mysql-libs.x86_64 0:5.5.59-1.el6.remi will be an update
---> Package php-mysql.x86_64 0:5.4.45-13.el6.remi will be an update
--> Traitement de la dépendance : php-pdo(x86-64) = 5.4.45-13.el6.remi pour le paquet : php-mysql-5.4.45-13.el6.remi.x86_64
--> Lancement de la transaction de test
---> Package collectd-mysql.x86_64 0:4.10.9-3.el6 will be mis à jour
---> Package collectd-mysql.x86_64 0:4.10.9-4.el6 will be an update
--> Traitement de la dépendance : collectd = 4.10.9-4.el6 pour le paquet : collectd-mysql-4.10.9-4.el6.x86_64
---> Package compat-mysql51.x86_64 0:5.1.73-1.el6.remi will be installé
---> Package mysql.x86_64 0:5.1.73-3.el6 will be mis à jour
---> Package mysql.x86_64 0:5.5.59-1.el6.remi will be an update
---> Package mysql-server.x86_64 0:5.1.73-3.el6 will be mis à jour
---> Package mysql-server.x86_64 0:5.5.59-1.el6.remi will be an update
---> Package php-mysql.x86_64 0:5.4.45-13.el6.remi will be an update
--> Traitement de la dépendance : php-pdo(x86-64) = 5.4.45-13.el6.remi pour le paquet : php-mysql-5.4.45-13.el6.remi.x86_64
--> Lancement de la transaction de test
---> Package collectd.x86_64 0:4.10.9-3.el6 will be mis à jour
--> Traitement de la dépendance : collectd = 4.10.9-3.el6 pour le paquet : collectd-rrdtool-4.10.9-3.el6.x86_64
--> Traitement de la dépendance : collectd = 4.10.9-3.el6 pour le paquet : collectd-apache-4.10.9-3.el6.x86_64
---> Package collectd.x86_64 0:4.10.9-4.el6 will be an update
---> Package php-mysql.x86_64 0:5.4.45-13.el6.remi will be an update
--> Traitement de la dépendance : php-pdo(x86-64) = 5.4.45-13.el6.remi pour le paquet : php-mysql-5.4.45-13.el6.remi.x86_64
--> Lancement de la transaction de test
---> Package collectd-apache.x86_64 0:4.10.9-3.el6 will be mis à jour
---> Package collectd-apache.x86_64 0:4.10.9-4.el6 will be an update
---> Package collectd-rrdtool.x86_64 0:4.10.9-3.el6 will be mis à jour
---> Package collectd-rrdtool.x86_64 0:4.10.9-4.el6 will be an update
---> Package php-mysql.x86_64 0:5.4.45-13.el6.remi will be an update
--> Traitement de la dépendance : php-pdo(x86-64) = 5.4.45-13.el6.remi pour le paquet : php-mysql-5.4.45-13.el6.remi.x86_64
--> Résolution des dépendances terminée
Erreur : Paquet : php-mysql-5.4.45-13.el6.remi.x86_64 (remi)
             Requiert : php-pdo(x86-64) = 5.4.45-13.el6.remi
             Suppression : php-pdo-5.3.3-27.el6.3.x86_64 (@LocalRepo)
                 php-pdo(x86-64) = 5.3.3-27.el6.3
             Mis à jour par : php-pdo-5.6.33-1.el6.remi.x86_64 (remi-php56)
                 php-pdo(x86-64) = 5.6.33-1.el6.remi
             Disponible : php-pdo-5.6.32-1.el6.remi.x86_64 (remi-php56)
                 php-pdo(x86-64) = 5.6.32-1.el6.remi
 Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
 Vous pouvez essayer d'exécuter : rpm -Va --nofiles --nodigest

Je suis navré si la question peut paraître futile et que la solution est peut être simple, n'étant pas un expert et la machine étant en production je préfère être certain de ne pas faire de bêtise

Merci d'avance

Re: installation mcrypt

> 3195 packages excluded due to repository priority protections

Same Player Shoot Again

Il faut que les priorités soient: remi-php56 > remi > base


P.S. le plus simple reste quand même de virer le plugin priority

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: installation mcrypt

Et, encore une fois depuis les instructions de l'assistant, il est préférable de:

1/ activer de façon permanente le dépôt remi-php56

2/ "yum update" (mise à jour 5.3 => 5.6)

3/ "yum install php-xxx" pour les extensions supplémentaires


(compter sur la mise à jour lors d'un "yum install" peut provoquer des déceptions)

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70