Topic: Soucis pour installer PHPMyAdmin 4.7.7 avec PHP 7.1

Salut Remi,

Merci beaucoup pour ton fantastique travail.

Lorsque je souhaite installer PHPMyAdmin 4.7.7 j'ai des conflits :

# yum --enablerepo=remi install phpMyAdmin --skip-broken
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.switch.ch
 * epel: mirror.imt-systems.com
 * extras: mirror.switch.ch
 * remi: remi.schlundtech.de
 * remi-php71: remi.schlundtech.de
 * remi-safe: remi.schlundtech.de
 * updates: mirror.switch.ch
 * webtatic: uk.repo.webtatic.com
Resolving Dependencies
--> Running transaction check
---> Package phpMyAdmin.noarch 0:4.7.7-1.el7.remi will be installed
--> Processing Dependency: php-composer(tecnickcom/tcpdf) < 7 for package: phpMyAdmin-4.7.7-1.el7.remi.noarch
--> Processing Dependency: php-composer(phpseclib/phpseclib) < 3 for package: phpMyAdmin-4.7.7-1.el7.remi.noarch
--> Processing Dependency: php-composer(phpmyadmin/sql-parser) < 5 for package: phpMyAdmin-4.7.7-1.el7.remi.noarch
--> Processing Dependency: php-composer(phpmyadmin/shapefile) < 3 for package: phpMyAdmin-4.7.7-1.el7.remi.noarch
--> Processing Dependency: php-composer(phpmyadmin/motranslator) < 4 for package: phpMyAdmin-4.7.7-1.el7.remi.noarch
--> Processing Dependency: php-composer(google/recaptcha) < 2 for package: phpMyAdmin-4.7.7-1.el7.remi.noarch
--> Processing Dependency: php-composer(tecnickcom/tcpdf) >= 6.2 for package: phpMyAdmin-4.7.7-1.el7.remi.noarch
--> Processing Dependency: php-composer(phpseclib/phpseclib) >= 2.0.9 for package: phpMyAdmin-4.7.7-1.el7.remi.noarch
--> Processing Dependency: php-composer(phpmyadmin/sql-parser) >= 4.2.3 for package: phpMyAdmin-4.7.7-1.el7.remi.noarch
--> Processing Dependency: php-composer(phpmyadmin/shapefile) >= 2.0 for package: phpMyAdmin-4.7.7-1.el7.remi.noarch
--> Processing Dependency: php-composer(phpmyadmin/motranslator) >= 3.4 for package: phpMyAdmin-4.7.7-1.el7.remi.noarch
--> Processing Dependency: php-composer(google/recaptcha) >= 1.1 for package: phpMyAdmin-4.7.7-1.el7.remi.noarch
--> Processing Dependency: php-zip for package: phpMyAdmin-4.7.7-1.el7.remi.noarch
Package php71w-common-7.1.11-1.w7.x86_64 is obsoleted by php-common-7.1.13-1.el7.remi.x86_64 which is already installed
--> Processing Dependency: php-tcpdf-dejavu-sans-fonts for package: phpMyAdmin-4.7.7-1.el7.remi.noarch
--> Running transaction check
---> Package php-google-recaptcha.noarch 0:1.1.3-1.el7.remi will be installed
---> Package php-phpmyadmin-motranslator.noarch 0:3.4-1.el7.remi will be installed
---> Package php-phpmyadmin-shapefile.noarch 0:2.1-1.el7.remi will be installed
---> Package php-phpmyadmin-sql-parser.noarch 0:4.2.4-1.el7.remi will be installed
---> Package php-phpseclib.noarch 0:2.0.9-1.el7.remi will be installed
--> Processing Dependency: php-gmp for package: php-phpseclib-2.0.9-1.el7.remi.noarch
---> Package php-tcpdf.noarch 0:6.2.13-4.el7.remi will be installed
---> Package php-tcpdf-dejavu-sans-fonts.noarch 0:6.2.13-4.el7.remi will be installed
---> Package phpMyAdmin.noarch 0:4.7.7-1.el7.remi will be installed
--> Processing Dependency: php-zip for package: phpMyAdmin-4.7.7-1.el7.remi.noarch
Package php71w-common-7.1.11-1.w7.x86_64 is obsoleted by php-common-7.1.13-1.el7.remi.x86_64 which is already installed
--> Running transaction check
---> Package php-gmp.x86_64 0:7.1.13-1.el7.remi will be installed
---> Package phpMyAdmin.noarch 0:4.7.7-1.el7.remi will be installed
--> Processing Dependency: php-zip for package: phpMyAdmin-4.7.7-1.el7.remi.noarch
Package php71w-common-7.1.11-1.w7.x86_64 is obsoleted by php-common-7.1.13-1.el7.remi.x86_64 which is already installed

Packages skipped because of dependency problems:
    php-gmp-7.1.13-1.el7.remi.x86_64 from remi-php71
    php-google-recaptcha-1.1.3-1.el7.remi.noarch from remi
    php-phpmyadmin-motranslator-3.4-1.el7.remi.noarch from remi
    php-phpmyadmin-shapefile-2.1-1.el7.remi.noarch from remi
    php-phpmyadmin-sql-parser-4.2.4-1.el7.remi.noarch from remi
    php-phpseclib-2.0.9-1.el7.remi.noarch from remi
    php-tcpdf-6.2.13-4.el7.remi.noarch from remi
    php-tcpdf-dejavu-sans-fonts-6.2.13-4.el7.remi.noarch from remi
    phpMyAdmin-4.7.7-1.el7.remi.noarch from remi
#

Aurais-tu un conseil à me donner afin de pouvoir procéder à l'install ?

Re: Soucis pour installer PHPMyAdmin 4.7.7 avec PHP 7.1

> Package php71w-common-7.1.11-1.w7.x86_64 is obsoleted by php-common-7.1.13-1.el7.remi.x86_64 which is already installed

Désolé... webtatic... pas mon dépôt.

Donc:

1/ virer webtatic

2/ yum install php-pecl-zip

3/ yum install --enablerepo=remi phpMyAdmin

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Soucis pour installer PHPMyAdmin 4.7.7 avec PHP 7.1

Félicitations, j'ai suivi tes étapes et tout fonctionne maintenant, BRAVO !!!

Re: Soucis pour installer PHPMyAdmin 4.7.7 avec PHP 7.1

smile

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test