Topic: CentOS 6.9 - PHP 7.0 upgrade - Not found error

Hello,
I am running CentOS 6.9 and try to upgrade php to 7.0 (default/single version) by configuration wizard

On  step "yum update" getting following error:

Error: Package: php-common-7.0.28-1.el6.remi.x86_64 (remi-php70)
           Requires: php-json(x86-64) = 7.0.28-1.el6.remi
           Removing: php-common-5.3.29-2.el6.x86_64 (@centosup)
               php-json(x86-64)
           Updated By: php-common-7.0.28-1.el6.remi.x86_64 (remi-php70)
               Not found
           Available: php-json-7.0.27-1.el6.remi.x86_64 (remi-php70)
               php-json(x86-64) = 7.0.27-1.el6.remi
           Available: php-json-7.0.28-1.el6.remi.x86_64 (remi-php70)
               php-json(x86-64) = 7.0.28-1.el6.remi
           Available: php54-common-5.4.44-1.el6.x86_64 (centosup)
               php-json(x86-64)
           Available: php55-common-5.5.28-1.el6.x86_64 (centosup)
               php-json(x86-64)
           Available: php56-common-5.6.12-1.el6.x86_64 (centosup)
               php-json(x86-64)

Could you please guide me in right direction?

Here the output of some info commands:

    # rpm -qa php\*
php56-php-pecl-zip-1.15.2-1.el6.remi.x86_64
php-cli-5.3.29-2.el6.x86_64
php70-php-common-7.0.28-1.el6.remi.x86_64
php-common-5.3.29-2.el6.x86_64
php70-runtime-1.0-5.el6.remi.x86_64
php70-1.0-5.el6.remi.x86_64
php56-runtime-2.3-1.el6.remi.x86_64
php56-php-pecl-jsonc-1.3.10-1.el6.remi.x86_64
php-mbstring-5.3.29-2.el6.x86_64
php70-php-cli-7.0.28-1.el6.remi.x86_64
php56-php-common-5.6.34-1.el6.remi.x86_64
php-5.3.29-2.el6.x86_64
php70-php-json-7.0.28-1.el6.remi.x86_64

    #rpm -Va php\*
empty

    # which php
/usr/bin/php

    # php -v
PHP 5.3.29 (cli) (built: Oct 27 2014 09:29:20)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2014 Zend Technologies

Re: CentOS 6.9 - PHP 7.0 upgrade - Not found error

It looks like your installation is a bit of a mess

Why have you install php-* and php56-* and php70* if you want a single version ?

Start by removing unneeded packages, and disable unneeded repo (centosup) and try again.

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test