Topic: Changes in ImageMagick6-libs?

Yesterday, I updated one of my servers (RHEL 7, PHP 7.2.12 from Remi) from ImageMagick6-libs-6.9.10-14.1, to 6.9.10-15.1. Immediately after performing this update, some of my WordPress sites began displaying errors when uploading images -- specifically, WordPress was no longer able to generate automatically image thumbnails. The page displayed a vague "HTTP Error" message that didn't really tell me anything, and the error wasn't logged in the php-fpm log file.

Reverting that RPM update immediately resolved the error.

Where should I begin in trying to identify the differences between those two versions of the package? I'm more than a little out of my depth, but everyone has to start somewhere. smile

Re: Changes in ImageMagick6-libs?

Damn... nothing have changed on my side, so all change are ImageMagick upstream)
And I didn't notice any ABI change... and imagick test suite passes with new version...

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Changes in ImageMagick6-libs?

Which exact package name provides imagick extension ?

I can try a rebuild against latest version to see if this solve your problem, if you have time to test it.

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Changes in ImageMagick6-libs?

These packages are currently installed:

ImageMagick-6.7.8.9-15.el7_2.x86_64
php-pecl-imagick-3.4.3-10.el7.remi.7.2.x86_64
ImageMagick6-libs-6.9.10.14-1.el7.remi.x86_64


(I think the first one is the RHEL-specific one that shouldn't be relevant here.)

I also see that PHP 7.2.13 is out; this server still is on 7.2.12. I'm going to try doing this ImageMagick6-libs update along with PHP 7.2.13, on a test server, and maybe that'll clear everything up. If not, at least I'll (hopefully) be able to reproduce everything in test, and we can go from there. Probably wouldn't worry about building any new packages just yet.

Re: Changes in ImageMagick6-libs?

Updating my test server to PHP 7.2.13, along with updating ImageMagick6-libs, seems to have resolved the issue. I don't know if it was resolved by some interaction between the software, or just indirectly by the upgrade forcing a restart of the php-fpm service, but upgrading everything at the same time seems to have fixed things.

Maybe I just had bad luck in updating yesterday, when my servers saw the ImageMagick update but not the PHP 7.2.13 update? I don't know. It works for me now.

Thanks for hopping in so quickly, and thanks for everything you do generally. smile

Re: Changes in ImageMagick6-libs?

> Maybe I just had bad luck in updating yesterday, when my servers saw the ImageMagick update but not the PHP 7.2.13 update?

Because IM was updated on Monday, PHP today wink

> but upgrading everything at the same time seems to have fixed things.

This may happen when coders used are not synced with the main library. There is a message to inform user when directory change, but such ABI breakage should not happen... IM is a terribly upstream... I'm still trying to understand why people use it.

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Changes in ImageMagick6-libs?

Hi,

I've also done update today, and it said:

WARNING : ImageMagick6 modules directory have changed.
You need to restart some services to take care of
the new location (e.g. httpd, php-fpm).

So PHP-FPM restart was the solution smile

Re: Changes in ImageMagick6-libs?

smile

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test