Topic: Update php-redis to recent version

Hi!
Is there any plan to update php-redis module?
The latest one is https://github.com/phpredis/phpredis/re … tag/4.2.0, however, the repo has 3.1.6.


Name        : php-pecl-redis
Arch        : x86_64
Version     : 3.1.6
Release     : 1.el6.remi.7.2
Size        : 964 k
Repo        : installed
From repo   : remi-php72
Summary     : Extension for communicating with the Redis key-value store
License     : PHP
Description : The phpredis extension provides an API for communicating
            : with the Redis key-value store.
            :
            : This Redis client implements most of the latest Redis API.
            : As method only only works when also implemented on the server side,
            : some doesn't work with an old redis server version.
            :
            : Package built for PHP 7.2.

Re: Update php-redis to recent version

See https://blog.remirepo.net/pages/PECL-ex … RPM-status

You need the php-pecl-redis4 package (different name, as API is not the same, and to offer user the choice of which API)



P.S. starting with Fedora 29, RHEL/CentOS 8 or PHP 7.3, php-pecl-redis (v3) is no more provided (so v4 is installed by default)

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Update php-redis to recent version

Also see official Fedora packages

* https://apps.fedoraproject.org/packages/php-pecl-redis4
* https://apps.fedoraproject.org/packages/php-pecl-redis


P.S. so, available since February 7th 2018 (with 4.0.0RC1)

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Update php-redis to recent version

Thanks, Remi!