Topic: Upgrading F29->F30, getting "Public key for *.remi is not installed

Sorry if this has already been covered by I see no posts about Fedora 30 and the FAQ doesn't mention it.  The Configuration Wizard still says "WARNING: Fedora 30 is a development version, not ready for production." so maybe this is my answer.

Is it possible to upgrade to Fedora 30 while using the remi repositories yet?

I am getting:

dnf system-upgrade download --releasever=30 --setopt=module_platform_id=platform:f30 --skip-broken
[.. cut.. ]
(3952/3953): nvidia-driver-libs-418.56-1.fc30.i686.rpm                                                                                 478 kB/s |  19 MB     00:39    
(3953/3953): nvidia-driver-libs-418.56-1.fc30.x86_64.rpm                                                                               547 kB/s |  34 MB     01:04    
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                  849 kB/s |  78 MB     01:33     
warning: /var/lib/dnf/system-upgrade/remi-1fec5bde41d0bbcc/packages/ImageMagick-6.9.10.44-1.fc30.remi.x86_64.rpm: Header V4 RSA/SHA256 Signature, key ID bbae6f1b: NOKEY
Remi's RPM repository - Fedora 30 - x86_64                                                                                             1.3 MB/s | 1.3 kB     00:00    
Importing GPG key 0x00F97F56:
 Userid     : "Remi Collet <RPMS@FamilleCollet.com>"
 Fingerprint: 1EE0 4CCE 88A4 AE4A A29A 5DF5 004E 6F47 00F9 7F56
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Is this ok [y/N]: y
Key imported successfully
Import of key(s) didn't help, wrong key(s)?
Public key for ImageMagick-6.9.10.44-1.fc30.remi.x86_64.rpm is not installed. Failing package is: ImageMagick-1:6.9.10.44-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for ImageMagick-c++-6.9.10.44-1.fc30.remi.x86_64.rpm is not installed. Failing package is: ImageMagick-c++-1:6.9.10.44-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for ImageMagick-libs-6.9.10.44-1.fc30.remi.x86_64.rpm is not installed. Failing package is: ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for libzip-1.5.2-1.fc30.remi.x86_64.rpm is not installed. Failing package is: libzip-1.5.2-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php-pear-1.10.9-2.fc30.remi.noarch.rpm is not installed. Failing package is: php-pear-1:1.10.9-2.fc30.remi.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-3.0-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-3.0-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-5.6.40-8.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-php-5.6.40-8.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-cli-5.6.40-8.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-php-cli-5.6.40-8.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-common-5.6.40-8.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-php-common-5.6.40-8.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-fpm-5.6.40-8.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-php-fpm-5.6.40-8.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-gd-5.6.40-8.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-php-gd-5.6.40-8.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-imap-5.6.40-8.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-php-imap-5.6.40-8.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-mcrypt-5.6.40-8.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-php-mcrypt-5.6.40-8.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-mssql-5.6.40-8.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-php-mssql-5.6.40-8.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-mysqlnd-5.6.40-8.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-php-mysqlnd-5.6.40-8.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-odbc-5.6.40-8.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-php-odbc-5.6.40-8.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-pdo-5.6.40-8.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-php-pdo-5.6.40-8.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-pear-1.10.9-2.fc30.remi.noarch.rpm is not installed. Failing package is: php56-php-pear-1:1.10.9-2.fc30.remi.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-pecl-imagick-3.4.4-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-php-pecl-imagick-3.4.4-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-pecl-jsonc-1.3.10-3.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-php-pecl-jsonc-1.3.10-3.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-pecl-xdebug-2.5.5-4.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-php-pecl-xdebug-2.5.5-4.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-pecl-zip-1.15.4-2.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-php-pecl-zip-1.15.4-2.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-process-5.6.40-8.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-php-process-5.6.40-8.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-php-xml-5.6.40-8.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-php-xml-5.6.40-8.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php56-runtime-3.0-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php56-runtime-3.0-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php70-php-common-7.0.33-8.fc30.remi.x86_64.rpm is not installed. Failing package is: php70-php-common-7.0.33-8.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php70-php-imap-7.0.33-8.fc30.remi.x86_64.rpm is not installed. Failing package is: php70-php-imap-7.0.33-8.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php70-php-json-7.0.33-8.fc30.remi.x86_64.rpm is not installed. Failing package is: php70-php-json-7.0.33-8.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php70-runtime-2.0-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php70-runtime-2.0-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php71-php-common-7.1.29-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php71-php-common-7.1.29-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php71-php-imap-7.1.29-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php71-php-imap-7.1.29-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php71-php-json-7.1.29-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php71-php-json-7.1.29-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php71-runtime-2.0-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php71-runtime-2.0-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php72-php-common-7.2.18-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php72-php-common-7.2.18-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php72-php-imap-7.2.18-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php72-php-imap-7.2.18-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php72-php-json-7.2.18-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php72-php-json-7.2.18-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php72-php-mysqlnd-7.2.18-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php72-php-mysqlnd-7.2.18-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php72-php-pdo-7.2.18-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php72-php-pdo-7.2.18-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php72-runtime-2.0-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php72-runtime-2.0-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php73-php-common-7.3.5-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php73-php-common-7.3.5-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php73-php-json-7.3.5-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php73-php-json-7.3.5-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php73-php-odbc-7.3.5-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php73-php-odbc-7.3.5-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php73-php-pdo-7.3.5-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php73-php-pdo-7.3.5-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php73-runtime-2.0-1.fc30.remi.x86_64.rpm is not installed. Failing package is: php73-runtime-2.0-1.fc30.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for remi-release-30-1.fc30.remi.noarch.rpm is not installed. Failing package is: remi-release-30-1.fc30.remi.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: GPG check FAILED

So apparently a GPG key 0x00F97F56 was installed successfully, but still the fc30.remi packages were signed with a key that is not installed.

Perhaps f30 support is being worked on and we need to wait?

Many thanks!

Re: Upgrading F29->F30, getting "Public key for *.remi is not installed

> The Configuration Wizard still says "WARNING: Fedora 30 is a development version, not ready for production."

Indeed, I forgot to remove this warnig, fixed.

> From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-remi

Check repo configuration, should be /etc/pki/rpm-gpg/RPM-GPG-KEY-remi-$releasever, so /etc/pki/rpm-gpg/RPM-GPG-KEY-remi-30

On Fedora 29 the provided keys are:

# ll /etc/pki/rpm-gpg/*remi*
-rw-r--r--. 1 root root 1340 23 mars   2017 /etc/pki/rpm-gpg/RPM-GPG-KEY-remi
-rw-r--r--. 1 root root 3100 23 mars   2017 /etc/pki/rpm-gpg/RPM-GPG-KEY-remi2017
-rw-r--r--. 1 root root 3143 16 janv.  2018 /etc/pki/rpm-gpg/RPM-GPG-KEY-remi2018
-rw-r--r--. 1 root root 3183  1 mars  11:49 /etc/pki/rpm-gpg/RPM-GPG-KEY-remi2019
lrwxrwxrwx. 1 root root   20  1 mars  12:10 /etc/pki/rpm-gpg/RPM-GPG-KEY-remi-29 -> RPM-GPG-KEY-remi2018
lrwxrwxrwx. 1 root root   20  1 mars  12:10 /etc/pki/rpm-gpg/RPM-GPG-KEY-remi-30 -> RPM-GPG-KEY-remi2019

The "30" key is provided especially to allow upgrade.

BTW, You can import it manually before the upgrade

rppm --import  /etc/pki/rpm-gpg/RPM-GPG-KEY-remi-30
Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Upgrading F29->F30, getting "Public key for *.remi is not installed

FAQ is updated
https://blog.remirepo.net/pages/English-FAQ#fedup

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Upgrading F29->F30, getting "Public key for *.remi is not installed

Thank you Remi, this got me back on track.  I did have exactly the same /etc/pki/rpm-gpg files are you show above.  I added the 30 key manually as you suggest:

rpm --import  /etc/pki/rpm-gpg/RPM-GPG-KEY-remi-30

Then my upgrade transaction could progress further.

After adding the key my transaction failed because of some conflicts, FYI:

[SKIPPED] xorg-x11-drv-nvidia-kmodsrc-418.56-1.fc30.x86_64.rpm: Already downloaded                                                                  
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/lib64/ImageMagick-6.9.10/config-Q16/configure.xml from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/aai.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/art.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/avs.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/bgr.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/bmp.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/braille.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/cals.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/caption.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/cin.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/cip.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/clip.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/cmyk.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/cut.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/dcm.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/dds.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/debug.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/dib.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/dng.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/dot.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/dpx.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/ept.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/exr.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/fax.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/fits.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/gif.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/gradient.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/gray.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/hald.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/hdr.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/histogram.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/hrz.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/html.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/icon.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/info.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/inline.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/ipl.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/jbig.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/jnx.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/jp2.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/jpeg.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/json.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/label.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/mac.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/magick.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/map.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/mask.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/mat.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/matte.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/meta.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/miff.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/mono.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/mpc.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/mpeg.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/mpr.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/msl.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/mtv.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/mvg.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/null.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/otb.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/palm.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/pango.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/pattern.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/pcd.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/pcl.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/pcx.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/pdb.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/pdf.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/pes.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/pgx.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/pict.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/pix.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/plasma.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/png.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/pnm.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/preview.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/ps.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/ps2.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/ps3.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/psd.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/pwp.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/raw.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/rgb.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/rgf.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/rla.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/rle.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/scr.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/sct.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/sfw.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/sgi.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/sixel.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/stegano.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/sun.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/svg.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/tga.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/thumbnail.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/tiff.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/tile.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/tim.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/ttf.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/txt.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/uil.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/url.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/uyvy.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/vicar.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/vid.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/viff.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/vips.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/wbmp.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/webp.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/wmf.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/wpg.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/x.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/xbm.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/xc.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/xcf.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/xpm.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/xps.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/xtrn.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/xwd.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/ycbcr.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/coders/yuv.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/ImageMagick-6.9.10/modules-Q16/filters/analyze.so from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/libMagickCore-6.Q16.so.6.0.0 from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64
  file /usr/lib64/libMagickWand-6.Q16.so.6.0.0 from install of ImageMagick-libs-1:6.9.10.44-1.fc30.remi.x86_64 conflicts with file from package ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64

Error Summary
-------------

Since they are all complaints about ImageMagick-libs and I'm happy to remove it temporarily:

$ sudo dnf remove ImageMagick-libs
Dependencies resolved.
================================================================================
 Package               Arch        Version                  Repository     Size
================================================================================
Removing:
 ImageMagick-libs      x86_64      1:6.9.9.38-3.fc29        @fedora       8.5 M
Removing dependent packages:
 inkscape              x86_64      0.92.4-5.fc29            @updates      151 M
Removing unused dependencies:
 ImageMagick-c++       x86_64      1:6.9.9.38-3.fc29        @fedora       666 k
 python2-nose          noarch      1.3.7-21.fc29            @fedora       1.1 M
 python2-numpy         x86_64      1:1.15.1-1.fc29          @fedora        18 M
 python2-scour         noarch      0.37-1.fc29              @updates      316 k

Transaction Summary
================================================================================
Remove  6 Packages

Freed space: 180 M
Is this ok [y/N]: y
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Erasing          : inkscape-0.92.4-5.fc29.x86_64                          1/6 
  Erasing          : python2-scour-0.37-1.fc29.noarch                       2/6 
  Erasing          : ImageMagick-c++-1:6.9.9.38-3.fc29.x86_64               3/6 
  Running scriptlet: ImageMagick-c++-1:6.9.9.38-3.fc29.x86_64               3/6 
  Erasing          : python2-numpy-1:1.15.1-1.fc29.x86_64                   4/6 
  Erasing          : python2-nose-1.3.7-21.fc29.noarch                      5/6 
  Erasing          : ImageMagick-libs-1:6.9.9.38-3.fc29.x86_64              6/6 
warning: /etc/ImageMagick-6/delegates.xml saved as /etc/ImageMagick-6/delegates.xml.rpmsave

  Running scriptlet: ImageMagick-libs-1:6.9.9.38-3.fc29.x86_64              6/6 
  Verifying        : ImageMagick-c++-1:6.9.9.38-3.fc29.x86_64               1/6 
  Verifying        : ImageMagick-libs-1:6.9.9.38-3.fc29.x86_64              2/6 
  Verifying        : inkscape-0.92.4-5.fc29.x86_64                          3/6 
  Verifying        : python2-nose-1.3.7-21.fc29.noarch                      4/6 
  Verifying        : python2-numpy-1:1.15.1-1.fc29.x86_64                   5/6 
  Verifying        : python2-scour-0.37-1.fc29.noarch                       6/6 

Removed:
  ImageMagick-libs-1:6.9.9.38-3.fc29.x86_64  inkscape-0.92.4-5.fc29.x86_64     
  ImageMagick-c++-1:6.9.9.38-3.fc29.x86_64   python2-nose-1.3.7-21.fc29.noarch 
  python2-numpy-1:1.15.1-1.fc29.x86_64       python2-scour-0.37-1.fc29.noarch  

Complete!

But I made a mistake, it was ImageMagick6-libs on my system that was conflicting with the incoming f30 package, so now I remove the correct package tongue

$ sudo dnf remove ImageMagick6-libs
Dependencies resolved.
================================================================================
 Package                  Arch     Version                     Repository  Size
================================================================================
Removing:
 ImageMagick6-libs        x86_64   1:6.9.10.43-1.fc29.remi     @remi      8.9 M
Removing dependent packages:
 php56-php-pecl-imagick   x86_64   3.4.4-1.fc29.remi           @remi      526 k
 playonlinux              x86_64   4.3.4-3.fc29                @updates   3.8 M
Removing unused dependencies:
 ImageMagick6             x86_64   1:6.9.10.43-1.fc29.remi     @remi      207 k
 jq                       x86_64   1.5-13.fc29                 @fedora    356 k
 libraqm                  x86_64   0.5.0-2.fc29                @fedora     25 k
 python2-wxpython         x86_64   3.0.2.0-24.fc29             @fedora     41 M
 wxGTK3-gl                x86_64   3.0.4-4.fc29                @fedora    105 k
 wxGTK3-media             x86_64   3.0.4-4.fc29                @fedora    144 k

Transaction Summary
================================================================================
Remove  9 Packages

Freed space: 56 M
Is this ok [y/N]: y
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Running scriptlet: playonlinux-4.3.4-3.fc29.x86_64                        1/1 
  Erasing          : playonlinux-4.3.4-3.fc29.x86_64                        1/9 
  Erasing          : ImageMagick6-1:6.9.10.43-1.fc29.remi.x86_64            2/9 
  Erasing          : python2-wxpython-3.0.2.0-24.fc29.x86_64                3/9 
  Erasing          : php56-php-pecl-imagick-3.4.4-1.fc29.remi.x86_64        4/9 
  Erasing          : ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64       5/9 
warning: /etc/ImageMagick6/ImageMagick-6/delegates.xml saved as /etc/ImageMagick6/ImageMagick-6/delegates.xml.rpmsave

  Erasing          : libraqm-0.5.0-2.fc29.x86_64                            6/9 
  Erasing          : wxGTK3-gl-3.0.4-4.fc29.x86_64                          7/9 
  Erasing          : wxGTK3-media-3.0.4-4.fc29.x86_64                       8/9 
  Erasing          : jq-1.5-13.fc29.x86_64                                  9/9 
  Running scriptlet: jq-1.5-13.fc29.x86_64                                  9/9 
  Verifying        : ImageMagick6-1:6.9.10.43-1.fc29.remi.x86_64            1/9 
  Verifying        : ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64       2/9 
  Verifying        : jq-1.5-13.fc29.x86_64                                  3/9 
  Verifying        : libraqm-0.5.0-2.fc29.x86_64                            4/9 
  Verifying        : php56-php-pecl-imagick-3.4.4-1.fc29.remi.x86_64        5/9 
  Verifying        : playonlinux-4.3.4-3.fc29.x86_64                        6/9 
  Verifying        : python2-wxpython-3.0.2.0-24.fc29.x86_64                7/9 
  Verifying        : wxGTK3-gl-3.0.4-4.fc29.x86_64                          8/9 
  Verifying        : wxGTK3-media-3.0.4-4.fc29.x86_64                       9/9 

Removed:
  ImageMagick6-libs-1:6.9.10.43-1.fc29.remi.x86_64                              
  php56-php-pecl-imagick-3.4.4-1.fc29.remi.x86_64                               
  playonlinux-4.3.4-3.fc29.x86_64                                               
  ImageMagick6-1:6.9.10.43-1.fc29.remi.x86_64                                   
  jq-1.5-13.fc29.x86_64                                                         
  libraqm-0.5.0-2.fc29.x86_64                                                   
  python2-wxpython-3.0.2.0-24.fc29.x86_64                                       
  wxGTK3-gl-3.0.4-4.fc29.x86_64                                                 
  wxGTK3-media-3.0.4-4.fc29.x86_64                                              

Complete!

And finally everything is happy and I'm ready to reboot for the upgrade.  Maybe this will help others going through the upgrade.

Thank you for the quick response smile

Re: Upgrading F29->F30, getting "Public key for *.remi is not installed

Interesting...

$  rpm -qp --obsoletes ImageMagick-libs-6.9.10.44-1.fc30.remi.x86_64.rpm 
ImageMagick-last-libs < 6.9.10.44
ImageMagick2 < 6.9.10.44
ImageMagick6-libs <= 6.9.10.44-1.fc30.remi

$  rpm -qp --obsoletes ImageMagick-c++-6.9.10.44-1.fc30.remi.x86_64.rpm 
ImageMagick-last-c++ < 1:6.9.10.44
ImageMagick6-c++ <= 1:6.9.10.44-1.fc30.remi

So epoch is missing for "libs"...

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Upgrading F29->F30, getting "Public key for *.remi is not installed

Fixed by https://git.remirepo.net/cgit/rpms/Imag … 6bad35bf10

So:

$ rpm -qp --obsoletes ImageMagick-libs-6.9.10.44-2.fc30.remi.x86_64.rpm
ImageMagick-last-libs < 1:6.9.10.44
ImageMagick2 < 1:6.9.10.44
ImageMagick6-libs <= 1:6.9.10.44-2.fc30.remi
Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test