Topic: php73 memcached dependency error Requires: libsasl2.so.2()(64bit)

Hi,

I use Amazon Linux and I installed php73 without any problem but when I try to install yum install php73-php-pecl-memcached I got the error below :


[root@ip-XXXXXX ec2-user]# yum install php73-php-pecl-memcached
Loaded plugins: extras_suggestions, langpacks, priorities, update-motd
880 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package php73-php-pecl-memcached.x86_64 0:3.1.3-1.el6.remi will be installed
--> Processing Dependency: fastlz(x86-64) for package: php73-php-pecl-memcached-3.1.3-1.el6.remi.x86_64
--> Processing Dependency: libmemcached-opt-libs(x86-64) for package: php73-php-pecl-memcached-3.1.3-1.el6.remi.x86_64
--> Processing Dependency: php73-php-pecl-igbinary(x86-64) for package: php73-php-pecl-memcached-3.1.3-1.el6.remi.x86_64
--> Processing Dependency: php73-php-pecl-msgpack(x86-64) for package: php73-php-pecl-memcached-3.1.3-1.el6.remi.x86_64
--> Running transaction check
---> Package fastlz.x86_64 0:0.1.0-0.1.20070619svnrev12.el6.remi will be installed
---> Package libmemcached-opt-libs.x86_64 0:1.0.18-2.el6.remi will be installed
--> Processing Dependency: libsasl2.so.2()(64bit) for package: libmemcached-opt-libs-1.0.18-2.el6.remi.x86_64
---> Package php73-php-pecl-igbinary.x86_64 0:3.0.1-1.el6.remi will be installed
---> Package php73-php-pecl-msgpack.x86_64 0:2.0.3-1.el6.remi will be installed
--> Finished Dependency Resolution
Error: Package: libmemcached-opt-libs-1.0.18-2.el6.remi.x86_64 (remi)
           Requires: libsasl2.so.2()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


So I couldn't find libsasl2.so.2. Should I install extra packages to solve this problem.

Re: php73 memcached dependency error Requires: libsasl2.so.2()(64bit)

libsasl2.so.so.2 is provided by cyrus-sasl-lib-2.1.23-15.el6_6.2.x86_64 (from base repository), in RHEL / CentOS 6

Sorry, don't know for Amazon Linux

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: php73 memcached dependency error Requires: libsasl2.so.2()(64bit)

I solved the problem. AWS Linux 2 uses RH7 libraries. I was using remi release 6 when I changed to  yum install http://rpms.remirepo.net/enterprise/remi-release-7.rpm It solved the problem.

Thanks for your answer.

Re: php73 memcached dependency error Requires: libsasl2.so.2()(64bit)

smile

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test