Topic: php 7.2 from the remi-php72 repo cannot be installed due to dependency

Hi,
I just tried to install php from the remi-php72 repo doing a "yum install php". This pulls in php-cli which tries to pull in libargon which apparently doesn't exist in any of the repositories. Is this a problem with the package or am I doing something wrong?

Regards,
  Dennis

Re: php 7.2 from the remi-php72 repo cannot be installed due to dependency

On which distro ?

Fedora : lilbargon2 is part of the distro (base repository)
EL-6 : libargon2 is in "remi-safe", which is mandatory for common dependencies
EL-7 : libargon2 is in EPEL, which is required
EL-8 : libargon2 is for now on "remi", which is required for now, as EPEL doesn't exists yet

See repository configuration instuctions

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: php 7.2 from the remi-php72 repo cannot be installed due to dependency

Also read the FAQ: https://blog.remirepo.net/pages/English-FAQ#deps

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: php 7.2 from the remi-php72 repo cannot be installed due to dependency

Hi,
As it turns out the system had the remi-release package for EL-6 installed even though it is an EL-7 system.
With the correct release package everything works as it should.

Sorry for the trouble.

Regards,
  Dennis

Re: php 7.2 from the remi-php72 repo cannot be installed due to dependency

smile

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test