Topic: php-devel install can't find prereq

[root@li730-188 ~]# yum -y --enablerepo=remi install php-devel
Last metadata expiration check: 0:48:14 ago on Wed Jan 15 10:36:34 2020.
Error:
Problem: cannot install the best candidate for the job
  - nothing provides libedit-devel(x86-64) needed by php-devel-7.4.1-1.el8.remi.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[root@li730-188 ~]#

Thanks

Re: php-devel install can't find prereq

On CentOS you need the PowerTools repository
On RHEL you need the CodeReady Linux Builder channel

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: php-devel install can't find prereq

BTW, you mostly never need the "devel" packages, as most extensions are already built, available as packages.
See the list: https://blog.remirepo.net/pages/PECL-ex … RPM-status

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test