Topic: error updating to latest php-pecl-mongodb

Hi - this started when php-pecl-mongodb-1.7.1-1.el8.remi.7.3.x86_64 was released.  I just haven't had a chance to post this note:

I am running PHP 7.3 on CentOS 8, and currently have php-pecl-mongodb-1.6.1-1.el8.remi.7.3.x86_64 installed.  When I run yum update, I'm getting:

Error:
 Problem: cannot install the best update candidate for package php-pecl-mongodb-1.6.1-1.el8.remi.7.3.x86_64
  - nothing provides libbson(x86-64) >= 1.16.1 needed by php-pecl-mongodb-1.7.2-1.el8.remi.7.3.x86_64
  - nothing provides mongo-c-driver-libs(x86-64) >= 1.16.1 needed by php-pecl-mongodb-1.7.2-1.el8.remi.7.3.x86_64
  - nothing provides libmongocrypt(x86-64) >= 1.0.3 needed by php-pecl-mongodb-1.7.2-1.el8.remi.7.3.x86_64

Is there something I have to change to update to the latest php-pecl-mongodb package?

Thanks for your help.

Ryan

Re: error updating to latest php-pecl-mongodb

you need new version of library in "reml" or in "epel-testing"

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: error updating to latest php-pecl-mongodb

Thanks for the quick reply - enabling remi did it.

Re: error updating to latest php-pecl-mongodb

And FYI, mongo-c-driver 1.16.1 is now in EPEL stable

https://bodhi.fedoraproject.org/updates … 56fd45971f

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test