1 (edited by advlad 2020-04-13 20:28:39)

Topic: Unable to load 'imagick.so' from remi-php71 and remi-php72

PHP Startup: Unable to load dynamic library 'imagick.so' (tried: /usr/lib64/php/modules/imagick.so (/usr/lib64/libMagickCore-6.Q16.so.6: undefined symbol: cmsGetContextUserData), /usr/lib64/php/modules/imagick.so.so (/usr/lib64/libMagickCore-6.Q16.so.6: undefined symbol: cmsGetContextUserData)) in Unknown on line 0

CentOS release 6.5
Installed packages:
php-7.2.29-1.el6.remi.x86_64
php-pecl-imagick-3.4.4-9.el6.remi.7.2.x86_64
ImageMagick6-libs-6.9.11.6-1.el6.remi.x86_64

Re: Unable to load 'imagick.so' from remi-php71 and remi-php72

Sorry, cannot reproduce.

Please check that your system is fully updated, especially:

# rpm -qf /usr/lib64/liblcms2.so.2
lcms2-2.8-6.el6.x86_64

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Unable to load 'imagick.so' from remi-php71 and remi-php72

> CentOS release 6.5

Lastest is 6.10
6.5 is >6 years old


BTW, also remind than 6 is close to its end of life, in a few month.

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Unable to load 'imagick.so' from remi-php71 and remi-php72

Yes, lcms2 update did the trick. Thanks a lot.

Re: Unable to load 'imagick.so' from remi-php71 and remi-php72

smile

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test