Topic: Fedora 32 remi repo (and GPG key)

Sorry if this is premature but I don't see F32 mentioned here yet and you're probably still working on the final release (F32 final was released yesterday April 28).

# sudo dnf system-upgrade download --refresh --releasever=32
[.. cut lots of output ..]
(4277/4278): intel-media-driver-20.1.1-1.fc32.x 1.6 MB/s | 5.6 MB     00:03
(4278/4278): vlc-core-3.0.9.2-3.fc32.x86_64.rpm 1.5 MB/s | 9.7 MB     00:06
--------------------------------------------------------------------------------
Total                                           2.9 MB/s | 4.6 GB     26:47
[.. cut some normal key imports for RPM-GPG-KEY-fedora-32-x86_64 etc ..]
warning: /var/lib/dnf/system-upgrade/remi-6c3b6edc151e3fde/packages/libdvdcss-1.4.2-1.fc32.remi.x86_64.rpm: Header V4 RSA/SHA256 Signature, key ID 4c21a808: NOKEY
Remi's RPM repository - Fedora 32 - x86_64      615 kB/s | 1.3 kB     00:00
GPG key at file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi (0x00F97F56) is already installed
[.. cut more output ..]
The GPG keys listed for the "Remi's RPM repository - Fedora 32 - x86_64" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.. Failing package is: libdvdcss-1.4.2-1.fc32.remi.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for php-horde-horde-lz4-1.0.10-7.fc32.remi.7.4.x86_64.rpm is not installed. Failing package is: php-horde-horde-lz4-1.0.10-7.fc32.remi.7.4.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Public key for ImageMagick-6.9.11.10-1.fc32.remi.x86_64.rpm is not installed. Failing package is: ImageMagick-1:6.9.11.10-1.fc32.remi.x86_64
[.. cut lots more packages complaining ..]

My output said my key for "Remi's RPM repository - Fedora 32 - x86_64" "is already installed" .. however, later the key is "already installed but they are not correct for this package" or "is not installed".

Also the Wizard still shows "Fedora 32 (development version)"

All this is perfectly understandable, but please indicate when it is safe to try an upgrade using your repos, and if necessary, how to remove any previous F32 remi key and install a replacement (perhaps simply installing the correct one will overwrite any previous one).

Thank you for your work!

Re: Fedora 32 remi repo (and GPG key)

What is the "remi-release" version ?

> GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi

GPG should be file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi-$releasever
so /etc/pki/rpm-gpg/RPM-GPG-KEY-remi-32 (linked to RPM-GPG-KEY-remi2020)

> Also the Wizard still shows "Fedora 32 (development version)"

Wizard have been fixed

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Fedora 32 remi repo (and GPG key)

I have also updated the FAQ
https://blog.remirepo.net/pages/English-FAQ#fedup

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Fedora 32 remi repo (and GPG key)

> All this is perfectly understandable, but please indicate when it is safe to try an upgrade using your repos

It is safe since the repo was open, a few weeks ago.

> how to remove any previous F32 remi key and install a replacement

It is managed with the proper repository configuration but can be false on old installation (check for any .rpmnew file present in yum.repos.d)

BTW, the simple workaround:

rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-remi2020

Still worth to fix your configuration (to use file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi-$releasever) and to avoid same issue for Fedora 33 or 34...

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Fedora 32 remi repo (and GPG key)

Ah, it looks like I had a very old remi.repo file, and as you suggested, the correct (newer) one had been installed as remi.repo.rpmnew and I guess was being ignored on my system.

> What is the "remi-release" version ?

# rpm -qa | grep remi-release
remi-release-31-2.fc31.remi.noarch

> GPG should be file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi-$releasever
> so /etc/pki/rpm-gpg/RPM-GPG-KEY-remi-32 (linked to RPM-GPG-KEY-remi2020)

This seems to be correct:

lrwxrwxrwx. 1 root root   20 Feb 17 20:58 RPM-GPG-KEY-remi-32 -> RPM-GPG-KEY-remi2020

> Still worth to fix your configuration (to use file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi-$releasever) and to avoid same issue for Fedora 33 or 34...

# ls -ltr /etc/yum.repos.d/remi.repo*
-rw-r--r--. 1 root root 437 Aug 21  2018 /etc/yum.repos.d/remi.repo
-rw-r--r--. 1 root root 435 Dec  3  2018 /etc/yum.repos.d/remi.repo.rpmnew

And remi.repo is using what looks like an obsolete key:

# grep GPG-KEY /etc/yum.repos.d/remi.repo*
/etc/yum.repos.d/remi.repo:gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
/etc/yum.repos.d/remi.repo.rpmnew:gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi-$releasever

So, my solution:

# mv remi.repo remi.repo.obsolete
# mv remi.repo.rpmnew remi.repo

By the way, after the upgrade command refreshes its repo data and before it attempts the transaction, I get this output:

Modular dependency problems:

 Problem 1: conflicting requests
  - nothing provides module(platform:f31) needed by module glpi:9.4:20200429052250:00000000-0.x86_64
 Problem 2: conflicting requests
  - nothing provides module(platform:f31) needed by module php:remi-7.3:20200429052250:00000000-0.x86_64
 Problem 3: conflicting requests
  - nothing provides module(platform:f31) needed by module gimp:2.10:3120191106095052:f636be4b-0.x86_64

However, it continues and seems to succeed so I'm going ahead anyway smile

Re: Fedora 32 remi repo (and GPG key)

I just fixed some bad links (to F31) in the mirrorlist
Everything should be ok now

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Fedora 32 remi repo (and GPG key)

Thanks for the very nice response, as always.  My upgrade to F32 went without problems.  All is good.

I doubt you need this, but just FYI, a 'clean all' and 'dnf update' now gives this output, possibly due to your fixes in the mirrorlist (or not smile ).

Dependencies resolved.
================================================================================
 Package               Arch     Version                    Repository      Size
================================================================================
Installing:
 php-horde-horde-lz4   x86_64   1.0.10-7.fc32.remi.7.4     remi-modular    18 k
     replacing  php73.x86_64 1.0-2.fc31.remi
Upgrading:
 php-bcmath            x86_64   7.4.5-1.fc32.remi          remi-modular    47 k
 php-cli               x86_64   7.4.5-1.fc32.remi          remi-modular   4.6 M
 php-common            x86_64   7.4.5-1.fc32.remi          remi-modular   793 k
 php-devel             x86_64   7.4.5-1.fc32.remi          remi-modular   674 k
 php-gd                x86_64   7.4.5-1.fc32.remi          remi-modular    57 k
 php-imap              x86_64   7.4.5-1.fc32.remi          remi-modular    66 k
 php-json              x86_64   7.4.5-1.fc32.remi          remi-modular    40 k
 php-mbstring          x86_64   7.4.5-1.fc32.remi          remi-modular   549 k
 php-mysqlnd           x86_64   7.4.5-1.fc32.remi          remi-modular   231 k
 php-pdo               x86_64   7.4.5-1.fc32.remi          remi-modular   108 k
 php-pecl-krb5         x86_64   1.1.3-1.fc32.remi.7.4      remi-modular    67 k
 php-pecl-mcrypt       x86_64   1.0.3-1.fc32.remi.7.4      remi-modular    36 k
 php-pecl-xdebug       x86_64   2.9.5-1.fc32.remi.7.4      remi-modular   245 k
 php-pgsql             x86_64   7.4.5-1.fc32.remi          remi-modular   108 k
 php-process           x86_64   7.4.5-1.fc32.remi          remi-modular    61 k
 php-soap              x86_64   7.4.5-1.fc32.remi          remi-modular   196 k
 php-xml               x86_64   7.4.5-1.fc32.remi          remi-modular   179 k
Installing dependencies:
 php-channel-horde     noarch   1.0-14.fc32                fedora         8.1 k
Enabling module streams:
 php                            remi-7.4                                       

Transaction Summary
================================================================================
Install   2 Packages
Upgrade  17 Packages

Total download size: 8.0 M
Is this ok [y/N]: y
Downloading Packages:
(1/19): php-horde-horde-lz4-1.0.10-7.fc32.remi.  21 kB/s |  18 kB     00:00    
(2/19): php-bcmath-7.4.5-1.fc32.remi.x86_64.rpm  38 kB/s |  47 kB     00:01    
(3/19): php-common-7.4.5-1.fc32.remi.x86_64.rpm 598 kB/s | 793 kB     00:01    
(4/19): php-devel-7.4.5-1.fc32.remi.x86_64.rpm  1.0 MB/s | 674 kB     00:00    
(5/19): php-gd-7.4.5-1.fc32.remi.x86_64.rpm     167 kB/s |  57 kB     00:00    
(6/19): php-imap-7.4.5-1.fc32.remi.x86_64.rpm   202 kB/s |  66 kB     00:00    
(7/19): php-json-7.4.5-1.fc32.remi.x86_64.rpm   131 kB/s |  40 kB     00:00    
(8/19): php-mbstring-7.4.5-1.fc32.remi.x86_64.r 1.1 MB/s | 549 kB     00:00    
(9/19): php-mysqlnd-7.4.5-1.fc32.remi.x86_64.rp 581 kB/s | 231 kB     00:00    
(10/19): php-pdo-7.4.5-1.fc32.remi.x86_64.rpm   308 kB/s | 108 kB     00:00    
(11/19): php-pecl-krb5-1.1.3-1.fc32.remi.7.4.x8 193 kB/s |  67 kB     00:00    
(12/19): php-channel-horde-1.0-14.fc32.noarch.r 1.4 kB/s | 8.1 kB     00:05    
(13/19): php-pecl-mcrypt-1.0.3-1.fc32.remi.7.4.  99 kB/s |  36 kB     00:00    
(14/19): php-pgsql-7.4.5-1.fc32.remi.x86_64.rpm 317 kB/s | 108 kB     00:00    
(15/19): php-process-7.4.5-1.fc32.remi.x86_64.r 185 kB/s |  61 kB     00:00    
(16/19): php-soap-7.4.5-1.fc32.remi.x86_64.rpm  441 kB/s | 196 kB     00:00    
(17/19): php-xml-7.4.5-1.fc32.remi.x86_64.rpm   492 kB/s | 179 kB     00:00    
(18/19): php-pecl-xdebug-2.9.5-1.fc32.remi.7.4. 139 kB/s | 245 kB     00:01    
(19/19): php-cli-7.4.5-1.fc32.remi.x86_64.rpm   544 kB/s | 4.6 MB     00:08    
--------------------------------------------------------------------------------
Total                                           541 kB/s | 8.0 MB     00:15     
warning: /var/cache/dnf/remi-modular-3cc3da1e83f386c0/packages/php-horde-horde-lz4-1.0.10-7.fc32.remi.7.4.x86_64.rpm: Header V4 RSA/SHA256 Signature, key ID 4c21a808: NOKEY
Remi's Modular repository - Fedora 32 - x86_64  3.0 MB/s | 3.1 kB     00:00    
Importing GPG key 0x4C21A808:
 Userid     : "Remi's RPM repository (https://rpms.remirepo.net/) <remi@remirepo.net>"
 Fingerprint: 34C1 0BDB CC6F 1B25 2E50 BA1A 0714 919E 4C21 A808
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-remi-32
Is this ok [y/N]: y
Key imported successfully
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Running scriptlet: php-json-7.4.5-1.fc32.remi.x86_64                      1/1 
Cannot load Xdebug - it was already loaded
Cannot load Xdebug - it was already loaded
Cannot load Xdebug - it was already loaded
Cannot load Xdebug - it was already loaded

  Upgrading        : php-json-7.4.5-1.fc32.remi.x86_64                     1/37 
  Running scriptlet: php-common-7.4.5-1.fc32.remi.x86_64                   2/37 
  Upgrading        : php-common-7.4.5-1.fc32.remi.x86_64                   2/37 
warning: /etc/php.ini created as /etc/php.ini.rpmnew

  Upgrading        : php-pdo-7.4.5-1.fc32.remi.x86_64                      3/37 
  Upgrading        : php-cli-7.4.5-1.fc32.remi.x86_64                      4/37 
  Installing       : php-channel-horde-1.0-14.fc32.noarch                  5/37 
  Running scriptlet: php-channel-horde-1.0-14.fc32.noarch                  5/37 
Cannot load Xdebug - it was already loaded

  Installing       : php-horde-horde-lz4-1.0.10-7.fc32.remi.7.4.x86_64     6/37 
  Upgrading        : php-devel-7.4.5-1.fc32.remi.x86_64                    7/37 
  Upgrading        : php-mysqlnd-7.4.5-1.fc32.remi.x86_64                  8/37 
  Upgrading        : php-pgsql-7.4.5-1.fc32.remi.x86_64                    9/37 
  Upgrading        : php-bcmath-7.4.5-1.fc32.remi.x86_64                  10/37 
  Upgrading        : php-gd-7.4.5-1.fc32.remi.x86_64                      11/37 
  Upgrading        : php-imap-7.4.5-1.fc32.remi.x86_64                    12/37 
  Upgrading        : php-mbstring-7.4.5-1.fc32.remi.x86_64                13/37 
  Upgrading        : php-pecl-krb5-1.1.3-1.fc32.remi.7.4.x86_64           14/37 
  Upgrading        : php-pecl-mcrypt-1.0.3-1.fc32.remi.7.4.x86_64         15/37 
  Upgrading        : php-pecl-xdebug-2.9.5-1.fc32.remi.7.4.x86_64         16/37 
warning: /etc/php.d/15-xdebug.ini created as /etc/php.d/15-xdebug.ini.rpmnew

  Upgrading        : php-process-7.4.5-1.fc32.remi.x86_64                 17/37 
  Upgrading        : php-soap-7.4.5-1.fc32.remi.x86_64                    18/37 
  Upgrading        : php-xml-7.4.5-1.fc32.remi.x86_64                     19/37 
  Cleanup          : php-devel-7.4.5-1.fc32.x86_64                        20/37 
  Obsoleting       : php73-1.0-2.fc31.remi.x86_64                         21/37 
  Cleanup          : php-pecl-xdebug-2.9.4-1.fc32.x86_64                  22/37 
  Cleanup          : php-pecl-mcrypt-1.0.3-1.fc32.x86_64                  23/37 
  Cleanup          : php-pecl-krb5-1.1.3-1.fc32.x86_64                    24/37 
  Cleanup          : php-cli-7.4.5-1.fc32.x86_64                          25/37 
  Cleanup          : php-xml-7.4.5-1.fc32.x86_64                          26/37 
  Cleanup          : php-soap-7.4.5-1.fc32.x86_64                         27/37 
  Cleanup          : php-process-7.4.5-1.fc32.x86_64                      28/37 
  Cleanup          : php-pgsql-7.4.5-1.fc32.x86_64                        29/37 
  Cleanup          : php-mysqlnd-7.4.5-1.fc32.x86_64                      30/37 
  Cleanup          : php-pdo-7.4.5-1.fc32.x86_64                          31/37 
  Cleanup          : php-mbstring-7.4.5-1.fc32.x86_64                     32/37 
  Cleanup          : php-json-7.4.5-1.fc32.x86_64                         33/37 
  Cleanup          : php-imap-7.4.5-1.fc32.x86_64                         34/37 
  Cleanup          : php-gd-7.4.5-1.fc32.x86_64                           35/37 
  Cleanup          : php-bcmath-7.4.5-1.fc32.x86_64                       36/37 
  Cleanup          : php-common-7.4.5-1.fc32.x86_64                       37/37 
  Running scriptlet: php-common-7.4.5-1.fc32.x86_64                       37/37 
Cannot load Xdebug - it was already loaded
Cannot load Xdebug - it was already loaded
Cannot load Xdebug - it was already loaded
Cannot load Xdebug - it was already loaded

  Verifying        : php-channel-horde-1.0-14.fc32.noarch                  1/37 
  Verifying        : php-horde-horde-lz4-1.0.10-7.fc32.remi.7.4.x86_64     2/37 
  Verifying        : php73-1.0-2.fc31.remi.x86_64                          3/37 
  Verifying        : php-bcmath-7.4.5-1.fc32.remi.x86_64                   4/37 
  Verifying        : php-bcmath-7.4.5-1.fc32.x86_64                        5/37 
  Verifying        : php-cli-7.4.5-1.fc32.remi.x86_64                      6/37 
  Verifying        : php-cli-7.4.5-1.fc32.x86_64                           7/37 
  Verifying        : php-common-7.4.5-1.fc32.remi.x86_64                   8/37 
  Verifying        : php-common-7.4.5-1.fc32.x86_64                        9/37 
  Verifying        : php-devel-7.4.5-1.fc32.remi.x86_64                   10/37 
  Verifying        : php-devel-7.4.5-1.fc32.x86_64                        11/37 
  Verifying        : php-gd-7.4.5-1.fc32.remi.x86_64                      12/37 
  Verifying        : php-gd-7.4.5-1.fc32.x86_64                           13/37 
  Verifying        : php-imap-7.4.5-1.fc32.remi.x86_64                    14/37 
  Verifying        : php-imap-7.4.5-1.fc32.x86_64                         15/37 
  Verifying        : php-json-7.4.5-1.fc32.remi.x86_64                    16/37 
  Verifying        : php-json-7.4.5-1.fc32.x86_64                         17/37 
  Verifying        : php-mbstring-7.4.5-1.fc32.remi.x86_64                18/37 
  Verifying        : php-mbstring-7.4.5-1.fc32.x86_64                     19/37 
  Verifying        : php-mysqlnd-7.4.5-1.fc32.remi.x86_64                 20/37 
  Verifying        : php-mysqlnd-7.4.5-1.fc32.x86_64                      21/37 
  Verifying        : php-pdo-7.4.5-1.fc32.remi.x86_64                     22/37 
  Verifying        : php-pdo-7.4.5-1.fc32.x86_64                          23/37 
  Verifying        : php-pecl-krb5-1.1.3-1.fc32.remi.7.4.x86_64           24/37 
  Verifying        : php-pecl-krb5-1.1.3-1.fc32.x86_64                    25/37 
  Verifying        : php-pecl-mcrypt-1.0.3-1.fc32.remi.7.4.x86_64         26/37 
  Verifying        : php-pecl-mcrypt-1.0.3-1.fc32.x86_64                  27/37 
  Verifying        : php-pecl-xdebug-2.9.5-1.fc32.remi.7.4.x86_64         28/37 
  Verifying        : php-pecl-xdebug-2.9.4-1.fc32.x86_64                  29/37 
  Verifying        : php-pgsql-7.4.5-1.fc32.remi.x86_64                   30/37 
  Verifying        : php-pgsql-7.4.5-1.fc32.x86_64                        31/37 
  Verifying        : php-process-7.4.5-1.fc32.remi.x86_64                 32/37 
  Verifying        : php-process-7.4.5-1.fc32.x86_64                      33/37 
  Verifying        : php-soap-7.4.5-1.fc32.remi.x86_64                    34/37 
  Verifying        : php-soap-7.4.5-1.fc32.x86_64                         35/37 
  Verifying        : php-xml-7.4.5-1.fc32.remi.x86_64                     36/37 
  Verifying        : php-xml-7.4.5-1.fc32.x86_64                          37/37 

Upgraded:
  php-bcmath-7.4.5-1.fc32.remi.x86_64                                           
  php-cli-7.4.5-1.fc32.remi.x86_64                                              
  php-common-7.4.5-1.fc32.remi.x86_64                                           
  php-devel-7.4.5-1.fc32.remi.x86_64                                            
  php-gd-7.4.5-1.fc32.remi.x86_64                                               
  php-imap-7.4.5-1.fc32.remi.x86_64                                             
  php-json-7.4.5-1.fc32.remi.x86_64                                             
  php-mbstring-7.4.5-1.fc32.remi.x86_64                                         
  php-mysqlnd-7.4.5-1.fc32.remi.x86_64                                          
  php-pdo-7.4.5-1.fc32.remi.x86_64                                              
  php-pecl-krb5-1.1.3-1.fc32.remi.7.4.x86_64                                    
  php-pecl-mcrypt-1.0.3-1.fc32.remi.7.4.x86_64                                  
  php-pecl-xdebug-2.9.5-1.fc32.remi.7.4.x86_64                                  
  php-pgsql-7.4.5-1.fc32.remi.x86_64                                            
  php-process-7.4.5-1.fc32.remi.x86_64                                          
  php-soap-7.4.5-1.fc32.remi.x86_64                                             
  php-xml-7.4.5-1.fc32.remi.x86_64                                              

Installed:
  php-channel-horde-1.0-14.fc32.noarch                                          
  php-horde-horde-lz4-1.0.10-7.fc32.remi.7.4.x86_64                             

Complete!

Re: Fedora 32 remi repo (and GPG key)

> php-horde-horde-lz4   x86_64   1.0.10-7.fc32.remi.7.4     remi-modular    18 k
>     replacing  php73.x86_64 1.0-2.fc31.remi

This shouldn't happen, going to fix this.

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test