1 (edited by naugui 2020-09-10 12:36:16)

Topic: Update php 5.3.3 to 7.3 - Centos 6.7

Bonjour,

J'ai un problème lorsque je met à jour php :

/usr/bin/yum update php-*

<Modules complémentaires chargés : fastestmirror, priorities>
Configuration du processus de mise à jour
Loading mirror speeds from cached hostfile
* base: ftp.fau.de
* centos-sclo-rh: ftp.fau.de
* centos-sclo-sclo: mirror.eu.oneandone.net
* epel: epel.mirror.nucleus.be
* extras: mirror.plustech.de
* remi-php73: remi.mirror.ate.info
* remi-safe: remi.mirror.ate.info
* rpmforge: mirror.de.leaseweb.net
* updates: ftp.fau.de
1645 packages excluded due to repository priority protections
Résolution des dépendances
--> Lancement de la transaction de test
---> Package php.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php.x86_64 0:7.3.22-1.el6.remi will be an update
--> Traitement de la dépendance : libargon2.so.0()(64bit) pour le paquet : php-7.3.22-1.el6.remi.x86_64
---> Package php-cli.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-cli.x86_64 0:7.3.22-1.el6.remi will be an update
---> Package php-common.x86_64 0:5.3.3-27.el6.3 will be mis à jour
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-suhosin-0.9.29-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-suhosin-0.9.29-2.el6.x86_64
---> Package php-common.x86_64 0:7.3.22-1.el6.remi will be an update
--> Traitement de la dépendance : php-json(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-common-7.3.22-1.el6.remi.x86_64
---> Package php-gd.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-gd.x86_64 0:7.3.22-1.el6.remi will be an update
--> Traitement de la dépendance : gd-last(x86-64) >= 2.1.1 pour le paquet : php-gd-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : libgd.so.3()(64bit) pour le paquet : php-gd-7.3.22-1.el6.remi.x86_64
---> Package php-imap.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-imap.x86_64 0:7.3.22-1.el6.remi will be an update
---> Package php-intl.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-intl.x86_64 0:7.3.22-1.el6.remi will be an update
--> Traitement de la dépendance : libicudata.so.50()(64bit) pour le paquet : php-intl-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : libicui18n.so.50()(64bit) pour le paquet : php-intl-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : libicuio.so.50()(64bit) pour le paquet : php-intl-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : libicuuc.so.50()(64bit) pour le paquet : php-intl-7.3.22-1.el6.remi.x86_64
---> Package php-mbstring.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-mbstring.x86_64 0:7.3.22-1.el6.remi will be an update
--> Traitement de la dépendance : libonig.so.105()(64bit) pour le paquet : php-mbstring-7.3.22-1.el6.remi.x86_64
---> Package php-mcrypt.x86_64 0:5.3.3-1.el6 will be obsolète
---> Package php-mysql.x86_64 0:5.3.3-27.el6.3 will be obsolète
--> Traitement de la dépendance : php-mysql pour le paquet : php-pear-MDB2-Driver-mysql-1.5.0-0.8.b4.el6.noarch
--> Traitement de la dépendance : php-mysql >= 5.2.0 pour le paquet : postfixadmin-ovh-2.3.7-2.el6.noarch
--> Traitement de la dépendance : php-mysql >= 5.2.0 pour le paquet : phpMyAdmin-ovh-4.1.14.8-6.el6.noarch
---> Package php-mysqlnd.x86_64 0:7.3.22-1.el6.remi will be obsoleting
---> Package php-pdo.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-pdo.x86_64 0:7.3.22-1.el6.remi will be an update
---> Package php-pear.noarch 1:1.9.4-4.el6 will be mis à jour
---> Package php-pear.noarch 1:1.9.4-5.el6 will be an update
---> Package php-pecl-apc.x86_64 0:3.1.9-2.el6 will be obsolète
---> Package php-pecl-apcu-bc.x86_64 0:1.0.5-1.el6.remi.7.3 will be obsoleting
--> Traitement de la dépendance : php-pecl-apcu(x86-64) >= 5.1.2 pour le paquet : php-pecl-apcu-bc-1.0.5-1.el6.remi.7.3.x86_64
---> Package php-pecl-mcrypt.x86_64 0:1.0.3-1.el6.remi.7.3 will be obsoleting
---> Package php-soap.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-soap.x86_64 0:7.3.22-1.el6.remi will be an update
---> Package php-xml.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-xml.x86_64 0:7.3.22-1.el6.remi will be an update
--> Lancement de la transaction de test
---> Package gd-last.x86_64 0:2.3.0-2.el6.remi will be installé
--> Traitement de la dépendance : libwebp.so.5()(64bit) pour le paquet : gd-last-2.3.0-2.el6.remi.x86_64
---> Package libargon2.x86_64 0:20161029-7.el6.remi will be installé
---> Package libicu-last.x86_64 0:50.1.2-17.el6.remi will be installé
---> Package oniguruma5php.x86_64 0:6.9.5+rev1-2.el6.remi will be installé
---> Package php-common.x86_64 0:5.3.3-27.el6.3 will be mis à jour
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-suhosin-0.9.29-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-suhosin-0.9.29-2.el6.x86_64
---> Package php-json.x86_64 0:7.3.22-1.el6.remi will be installé
---> Package php-pecl-apcu-bc.x86_64 0:1.0.5-1.el6.remi.7.3 will be obsoleting
--> Traitement de la dépendance : php-pecl-apcu(x86-64) >= 5.1.2 pour le paquet : php-pecl-apcu-bc-1.0.5-1.el6.remi.7.3.x86_64
---> Package php-pecl-mysql.x86_64 0:1.0.0-0.20.20180226.647c933.el6.remi.7.3 will be installé
--> Lancement de la transaction de test
---> Package libwebp.x86_64 0:0.4.3-3.el6 will be installé
---> Package php-common.x86_64 0:5.3.3-27.el6.3 will be mis à jour
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-suhosin-0.9.29-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-suhosin-0.9.29-2.el6.x86_64
---> Package php-pecl-apcu-bc.x86_64 0:1.0.5-1.el6.remi.7.3 will be obsoleting
--> Traitement de la dépendance : php-pecl-apcu(x86-64) >= 5.1.2 pour le paquet : php-pecl-apcu-bc-1.0.5-1.el6.remi.7.3.x86_64
--> Résolution des dépendances terminée
Erreur : Paquet : php-pecl-apcu-bc-1.0.5-1.el6.remi.7.3.x86_64 (remi-php73)
             Requiert : php-pecl-apcu(x86-64) >= 5.1.2
             Disponible : php-pecl-apcu-4.0.11-2.el6.x86_64 (epel)
                 php-pecl-apcu(x86-64) = 4.0.11-2.el6
Erreur : Paquet : php-suhosin-0.9.29-2.el6.x86_64 (@epel)
             Requiert : php(zend-abi) = 20090626
             Suppression : php-common-5.3.3-27.el6.3.x86_64 (@LocalRepo)
                 php(zend-abi) = 20090626
             Mis à jour par : php-common-7.3.22-1.el6.remi.x86_64 (remi-php73)
                 php(zend-abi) = 20180731-64
             Disponible : php-common-7.3.21-1.el6.remi.x86_64 (remi-php73)
                 php(zend-abi) = 20180731-64
Erreur : Paquet : php-suhosin-0.9.29-2.el6.x86_64 (@epel)
             Requiert : php(api) = 20090626
             Suppression : php-common-5.3.3-27.el6.3.x86_64 (@LocalRepo)
                 php(api) = 20090626
             Mis à jour par : php-common-7.3.22-1.el6.remi.x86_64 (remi-php73)
                 php(api) = 20180731-64
             Disponible : php-common-7.3.21-1.el6.remi.x86_64 (remi-php73)
                 php(api) = 20180731-64
Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
Vous pouvez essayer d'exécuter : rpm -Va --nofiles --nodigest
>

Si j'ajoute --skip-broken :
Modules complémentaires chargés : fastestmirror, priorities
Configuration du processus de mise à jour
Loading mirror speeds from cached hostfile
* base: ftp.fau.de
* centos-sclo-rh: ftp.fau.de
* centos-sclo-sclo: mirror.checkdomain.de
* epel: epel.mirror.nucleus.be
* extras: mirror.plustech.de
* remi-php73: remi.mirror.ate.info
* remi-safe: remi.mirror.ate.info
* rpmforge: mirror.de.leaseweb.net
* updates: ftp.fau.de
1645 packages excluded due to repository priority protections
Résolution des dépendances
--> Lancement de la transaction de test
---> Package php.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php.x86_64 0:7.3.22-1.el6.remi will be an update
--> Traitement de la dépendance : libargon2.so.0()(64bit) pour le paquet : php-7.3.22-1.el6.remi.x86_64
---> Package php-cli.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-cli.x86_64 0:7.3.22-1.el6.remi will be an update
---> Package php-common.x86_64 0:5.3.3-27.el6.3 will be mis à jour
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-suhosin-0.9.29-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-suhosin-0.9.29-2.el6.x86_64
---> Package php-common.x86_64 0:7.3.22-1.el6.remi will be an update
--> Traitement de la dépendance : php-json(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-common-7.3.22-1.el6.remi.x86_64
---> Package php-gd.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-gd.x86_64 0:7.3.22-1.el6.remi will be an update
--> Traitement de la dépendance : gd-last(x86-64) >= 2.1.1 pour le paquet : php-gd-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : libgd.so.3()(64bit) pour le paquet : php-gd-7.3.22-1.el6.remi.x86_64
---> Package php-imap.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-imap.x86_64 0:7.3.22-1.el6.remi will be an update
---> Package php-intl.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-intl.x86_64 0:7.3.22-1.el6.remi will be an update
--> Traitement de la dépendance : libicudata.so.50()(64bit) pour le paquet : php-intl-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : libicui18n.so.50()(64bit) pour le paquet : php-intl-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : libicuio.so.50()(64bit) pour le paquet : php-intl-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : libicuuc.so.50()(64bit) pour le paquet : php-intl-7.3.22-1.el6.remi.x86_64
---> Package php-mbstring.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-mbstring.x86_64 0:7.3.22-1.el6.remi will be an update
--> Traitement de la dépendance : libonig.so.105()(64bit) pour le paquet : php-mbstring-7.3.22-1.el6.remi.x86_64
---> Package php-mcrypt.x86_64 0:5.3.3-1.el6 will be obsolète
---> Package php-mysql.x86_64 0:5.3.3-27.el6.3 will be obsolète
--> Traitement de la dépendance : php-mysql pour le paquet : php-pear-MDB2-Driver-mysql-1.5.0-0.8.b4.el6.noarch
--> Traitement de la dépendance : php-mysql >= 5.2.0 pour le paquet : postfixadmin-ovh-2.3.7-2.el6.noarch
--> Traitement de la dépendance : php-mysql >= 5.2.0 pour le paquet : phpMyAdmin-ovh-4.1.14.8-6.el6.noarch
---> Package php-mysqlnd.x86_64 0:7.3.22-1.el6.remi will be obsoleting
---> Package php-pdo.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-pdo.x86_64 0:7.3.22-1.el6.remi will be an update
---> Package php-pear.noarch 1:1.9.4-4.el6 will be mis à jour
---> Package php-pear.noarch 1:1.9.4-5.el6 will be an update
---> Package php-pecl-apc.x86_64 0:3.1.9-2.el6 will be obsolète
---> Package php-pecl-apcu-bc.x86_64 0:1.0.5-1.el6.remi.7.3 will be obsoleting
--> Traitement de la dépendance : php-pecl-apcu(x86-64) >= 5.1.2 pour le paquet : php-pecl-apcu-bc-1.0.5-1.el6.remi.7.3.x86_64
---> Package php-pecl-mcrypt.x86_64 0:1.0.3-1.el6.remi.7.3 will be obsoleting
---> Package php-soap.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-soap.x86_64 0:7.3.22-1.el6.remi will be an update
---> Package php-xml.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-xml.x86_64 0:7.3.22-1.el6.remi will be an update
--> Lancement de la transaction de test
---> Package gd-last.x86_64 0:2.3.0-2.el6.remi will be installé
--> Traitement de la dépendance : libwebp.so.5()(64bit) pour le paquet : gd-last-2.3.0-2.el6.remi.x86_64
---> Package libargon2.x86_64 0:20161029-7.el6.remi will be installé
---> Package libicu-last.x86_64 0:50.1.2-17.el6.remi will be installé
---> Package oniguruma5php.x86_64 0:6.9.5+rev1-2.el6.remi will be installé
---> Package php-common.x86_64 0:5.3.3-27.el6.3 will be mis à jour
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-suhosin-0.9.29-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-suhosin-0.9.29-2.el6.x86_64
---> Package php-json.x86_64 0:7.3.22-1.el6.remi will be installé
---> Package php-pecl-apcu-bc.x86_64 0:1.0.5-1.el6.remi.7.3 will be obsoleting
--> Traitement de la dépendance : php-pecl-apcu(x86-64) >= 5.1.2 pour le paquet : php-pecl-apcu-bc-1.0.5-1.el6.remi.7.3.x86_64
---> Package php-pecl-mysql.x86_64 0:1.0.0-0.20.20180226.647c933.el6.remi.7.3 will be installé
--> Lancement de la transaction de test
---> Package libwebp.x86_64 0:0.4.3-3.el6 will be installé
---> Package php-common.x86_64 0:5.3.3-27.el6.3 will be mis à jour
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-suhosin-0.9.29-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-suhosin-0.9.29-2.el6.x86_64
---> Package php-pecl-apcu-bc.x86_64 0:1.0.5-1.el6.remi.7.3 will be obsoleting
--> Traitement de la dépendance : php-pecl-apcu(x86-64) >= 5.1.2 pour le paquet : php-pecl-apcu-bc-1.0.5-1.el6.remi.7.3.x86_64
--> Lancement de la transaction de test
---> Package php-common.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-common.x86_64 0:7.3.22-1.el6.remi will be an update
--> Traitement de la dépendance : php(api) = 20180731-64 pour le paquet : php-pecl-mysql-1.0.0-0.20.20180226.647c933.el6.remi.7.3.x86_64
--> Traitement de la dépendance : php(api) = 20180731-64 pour le paquet : php-pecl-mcrypt-1.0.3-1.el6.remi.7.3.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20180731-64 pour le paquet : php-pecl-mysql-1.0.0-0.20.20180226.647c933.el6.remi.7.3.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20180731-64 pour le paquet : php-pecl-mcrypt-1.0.3-1.el6.remi.7.3.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-xml-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-pdo-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-intl-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-imap-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-mbstring-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-cli-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-soap-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-gd-7.3.22-1.el6.remi.x86_64
---> Package php-json.x86_64 0:7.3.22-1.el6.remi will be installé
---> Package php-pecl-apc.x86_64 0:3.1.9-2.el6 will be obsolète
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
---> Package php-pecl-apcu-bc.x86_64 0:1.0.5-1.el6.remi.7.3 will be obsoleting
--> Lancement de la transaction de test
---> Package php-common.x86_64 0:5.3.3-27.el6.3 will be mis à jour
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-suhosin-0.9.29-2.el6.x86_64
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-suhosin-0.9.29-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
---> Package php-common.x86_64 0:7.3.21-1.el6.remi will be an update
--> Traitement de la dépendance : php-json(x86-64) = 7.3.21-1.el6.remi pour le paquet : php-common-7.3.21-1.el6.remi.x86_64
---> Package php-common.x86_64 0:7.3.22-1.el6.remi will be an update
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-xml-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-pdo-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-intl-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-imap-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-mbstring-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-cli-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-soap-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-gd-7.3.22-1.el6.remi.x86_64
---> Package php-pecl-apc.x86_64 0:3.1.9-2.el6 will be obsolète
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
--> Lancement de la transaction de test
---> Package php-common.x86_64 0:5.3.3-27.el6.3 will be mis à jour
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-suhosin-0.9.29-2.el6.x86_64
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-suhosin-0.9.29-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
---> Package php-common.x86_64 0:7.3.22-1.el6.remi will be an update
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-xml-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-pdo-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-intl-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-imap-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-mbstring-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-cli-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-soap-7.3.22-1.el6.remi.x86_64
--> Traitement de la dépendance : php-common(x86-64) = 7.3.22-1.el6.remi pour le paquet : php-gd-7.3.22-1.el6.remi.x86_64
---> Package php-json.x86_64 0:7.3.21-1.el6.remi will be installé
---> Package php-pecl-apc.x86_64 0:3.1.9-2.el6 will be obsolète
--> Traitement de la dépendance : php(api) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
--> Traitement de la dépendance : php(zend-abi) = 20090626 pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64
--> Lancement de la transaction de test
---> Package php-mcrypt.x86_64 0:5.3.3-1.el6 will be obsolète
---> Package php-mysql.x86_64 0:5.3.3-27.el6.3 will be obsolète
---> Package php-pear.noarch 1:1.9.4-4.el6 will be mis à jour
---> Package php-pecl-mcrypt.x86_64 0:1.0.3-1.el6.remi.7.3 will be obsoleting
--> Traitement de la dépendance : php(zend-abi) = 20180731-64 pour le paquet : php-pecl-mcrypt-1.0.3-1.el6.remi.7.3.x86_64
--> Traitement de la dépendance : php(api) = 20180731-64 pour le paquet : php-pecl-mcrypt-1.0.3-1.el6.remi.7.3.x86_64
---> Package php-pecl-mysql.x86_64 0:1.0.0-0.20.20180226.647c933.el6.remi.7.3 will be installé
--> Traitement de la dépendance : php(zend-abi) = 20180731-64 pour le paquet : php-pecl-mysql-1.0.0-0.20.20180226.647c933.el6.remi.7.3.x86_64
--> Traitement de la dépendance : php(api) = 20180731-64 pour le paquet : php-pecl-mysql-1.0.0-0.20.20180226.647c933.el6.remi.7.3.x86_64
--> Traitement de la dépendance : php-mysqlnd(x86-64) pour le paquet : php-pecl-mysql-1.0.0-0.20.20180226.647c933.el6.remi.7.3.x86_64
--> Lancement de la transaction de test
---> Package php-mysqlnd.x86_64 0:7.3.21-1.el6.remi will be obsoleting
--> Traitement de la dépendance : php-pdo(x86-64) = 7.3.21-1.el6.remi pour le paquet : php-mysqlnd-7.3.21-1.el6.remi.x86_64
---> Package php-pecl-mcrypt.x86_64 0:1.0.3-1.el6.remi.7.3 will be obsoleting
--> Traitement de la dépendance : php(zend-abi) = 20180731-64 pour le paquet : php-pecl-mcrypt-1.0.3-1.el6.remi.7.3.x86_64
--> Traitement de la dépendance : php(api) = 20180731-64 pour le paquet : php-pecl-mcrypt-1.0.3-1.el6.remi.7.3.x86_64
---> Package php-pecl-mysql.x86_64 0:1.0.0-0.20.20180226.647c933.el6.remi.7.3 will be installé
--> Traitement de la dépendance : php(zend-abi) = 20180731-64 pour le paquet : php-pecl-mysql-1.0.0-0.20.20180226.647c933.el6.remi.7.3.x86_64
--> Traitement de la dépendance : php(api) = 20180731-64 pour le paquet : php-pecl-mysql-1.0.0-0.20.20180226.647c933.el6.remi.7.3.x86_64
--> Lancement de la transaction de test
---> Package php-pdo.x86_64 0:5.3.3-27.el6.3 will be mis à jour
---> Package php-pdo.x86_64 0:7.3.21-1.el6.remi will be an update
--> Traitement de la dépendance : php-common(x86-64) = 7.3.21-1.el6.remi pour le paquet : php-pdo-7.3.21-1.el6.remi.x86_64
---> Package php-pecl-mcrypt.x86_64 0:1.0.3-1.el6.remi.7.3 will be obsoleting
--> Traitement de la dépendance : php(zend-abi) = 20180731-64 pour le paquet : php-pecl-mcrypt-1.0.3-1.el6.remi.7.3.x86_64
--> Traitement de la dépendance : php(api) = 20180731-64 pour le paquet : php-pecl-mcrypt-1.0.3-1.el6.remi.7.3.x86_64
---> Package php-pecl-mysql.x86_64 0:1.0.0-0.20.20180226.647c933.el6.remi.7.3 will be installé
--> Traitement de la dépendance : php(zend-abi) = 20180731-64 pour le paquet : php-pecl-mysql-1.0.0-0.20.20180226.647c933.el6.remi.7.3.x86_64
--> Traitement de la dépendance : php(api) = 20180731-64 pour le paquet : php-pecl-mysql-1.0.0-0.20.20180226.647c933.el6.remi.7.3.x86_64
--> Traitement de la dépendance : /usr/bin/pear pour le paquet : php-pear-DB-1.7.13-3.el6.noarch
--> Traitement de la dépendance : /usr/bin/pear pour le paquet : php-pear-Net-SMTP-1.6.1-1.el6.noarch
--> Traitement de la dépendance : /usr/bin/pear pour le paquet : php-pear-Auth-SASL-1.0.6-1.el6.noarch
--> Traitement de la dépendance : /usr/bin/pear pour le paquet : php-pear-Mail-Mime-1.8.4-1.el6.noarch
--> Traitement de la dépendance : /usr/bin/pear pour le paquet : php-pear-Net-Socket-1.0.10-1.el6.noarch
--> Traitement de la dépendance : /usr/bin/pear pour le paquet : php-pear-Mail-mimeDecode-1.5.5-1.el6.noarch
--> Traitement de la dépendance : /usr/bin/pear pour le paquet : php-pear-MDB2-Driver-mysql-1.5.0-0.8.b4.el6.noarch
--> Traitement de la dépendance : /usr/bin/pear pour le paquet : php-pear-MDB2-2.5.0-0.9.b5.el6.noarch
--> Traitement de la dépendance : /usr/bin/pecl pour le paquet : php-pecl-apc-3.1.9-2.el6.x86_64

Paquets omis en raison de problèmes de dépendances :
    gd-last-2.3.0-2.el6.remi.x86_64 depuis remi-safe
    libargon2-20161029-7.el6.remi.x86_64 depuis remi-safe
    libicu-last-50.1.2-17.el6.remi.x86_64 depuis remi-safe
    libwebp-0.4.3-3.el6.x86_64 depuis epel
    oniguruma5php-6.9.5+rev1-2.el6.remi.x86_64 depuis remi-safe
    php-7.3.22-1.el6.remi.x86_64 depuis remi-php73
    php-cli-7.3.22-1.el6.remi.x86_64 depuis remi-php73
    php-common-7.3.21-1.el6.remi.x86_64 depuis remi-php73
    php-common-7.3.22-1.el6.remi.x86_64 depuis remi-php73
    php-gd-7.3.22-1.el6.remi.x86_64 depuis remi-php73
    php-imap-7.3.22-1.el6.remi.x86_64 depuis remi-php73
    php-intl-7.3.22-1.el6.remi.x86_64 depuis remi-php73
    php-json-7.3.21-1.el6.remi.x86_64 depuis remi-php73
    php-json-7.3.22-1.el6.remi.x86_64 depuis remi-php73
    php-mbstring-7.3.22-1.el6.remi.x86_64 depuis remi-php73
    php-mysqlnd-7.3.21-1.el6.remi.x86_64 depuis remi-php73
    php-mysqlnd-7.3.22-1.el6.remi.x86_64 depuis remi-php73
    php-pdo-7.3.21-1.el6.remi.x86_64 depuis remi-php73
    php-pdo-7.3.22-1.el6.remi.x86_64 depuis remi-php73
    1:php-pear-1.9.4-5.el6.noarch depuis base
    php-pecl-apcu-bc-1.0.5-1.el6.remi.7.3.x86_64 depuis remi-php73
    php-pecl-mcrypt-1.0.3-1.el6.remi.7.3.x86_64 depuis remi-php73
    php-pecl-mysql-1.0.0-0.20.20180226.647c933.el6.remi.7.3.x86_64 depuis remi-php73
    php-soap-7.3.22-1.el6.remi.x86_64 depuis remi-php73
    php-xml-7.3.22-1.el6.remi.x86_64 depuis remi-php73

Re: Update php 5.3.3 to 7.3 - Centos 6.7

EL-6 ? seriously ?

This distribution will reach its end of life in a few weeks, really time to upgrade to 7 or 8

> Erreur : Paquet : php-suhosin-0.9.29-2.el6.x86_64 (@epel)

Expected, this extension doesn't exists for PHP 7.x, you have to remove it first

> Modules complémentaires chargés : fastestmirror, priorities>
> 1645 packages excluded due to repository priority protections

Expected, configure the "priorities" plugin or disable it
(as explained by the wizard, see link on top right corner of all pages)

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Update php 5.3.3 to 7.3 - Centos 6.7

La question étant en français je ne sais pas pourquoi j'ai répondu en anglais...

Sérieusement EL-6 sera maintenue jusqu'en novembre 2020, il est donc temps de monter sur une version 7 ou 8

> Erreur : Paquet : php-suhosin-0.9.29-2.el6.x86_64 (@epel)

C'est normal, cette extension n'existe pas pour PHP 7.0.
Il faut donc la désinstaller avant la mise à jour

> Modules complémentaires chargés : fastestmirror, priorities>
> 1645 packages excluded due to repository priority protections

C'est normal, il faut corriger la configuration de cette extension (remi-php73 devant être plus prioritaire que EPEL), ou le désactiver.

Comme l'explique l'assistant, lien dans le coing supérieur droit de chaque page.

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Update php 5.3.3 to 7.3 - Centos 6.7

Bonjour,

Merci ça fonctionne et oui la mise à jour vers la version 8 est prévue ^^.

Re: Update php 5.3.3 to 7.3 - Centos 6.7

smile

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test