Topic: Composer package update. CentOS 8

Hello

Unable to install updates. Here is already a closed thread about composer, but I did not understood what is the solution. My case's output is

[root@ispcd ~]# dnf update
Last metadata expiration check: 2:49:37 ago on Tue 10 Nov 2020 07:00:39 PM EET.
Error:
Problem: cannot install the best update candidate for package composer-1.10.15-1.el8.remi.noarch
  - nothing provides (php-composer(composer/semver) >= 3.0 with php-composer(composer/semver) < 4) needed by composer-2.0.6-1.el8.remi.noarch
  - nothing provides (php-composer(react/promise) >= 2.7 with php-composer(react/promise) < 3) needed by composer-2.0.6-1.el8.remi.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Re: Composer package update. CentOS 8

You need  to  enable  "remi" repository

Desktop: Fedora 33 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Composer package update. CentOS 8

Remi wrote:

You need  to  enable  "remi" repository

It helps. Thanks.

Re: Composer package update. CentOS 8

Previous answer (from phone) was short, explanation

Usually "noarch" packages are in EPEL, and "remi" provides more recent versions
So, as it replaces official packages it is not enabled by default

But, for 8, things are a bit different as EPEL-8 is empty for now (no PHP packages there)
or perhaps is dead....

Desktop: Fedora 33 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test