Topic: Changed opcache.enable_cli recovery from PHP7.4.0RC5

Currently, when running more than two php artisan, opcache is enabled by default, causing a problem.


https://git.remirepo.net/cgit/rpms/php/ … 1577a7a392


```
committer    Remi Collet <remi@remirepo.net>    2019-10-29 11:06:02 +0100
-;opcache.enable_cli=0
+opcache.enable_cli=1
```


In the PHP manual and source, the defaults are all 0.


php.net/manual/en/opcache.configuration.php

`opcache.enable_cli    "0"`


github.com/php/php-src/blob/master/ext/opcache/zend_accelerator_module.c#L263

`STD_PHP_INI_BOOLEAN("opcache.enable_cli"             , "0" `



Of course my server can be solved by changing the settings.

But I think there are a lot of people using the Remi's RPM repository so recovery defaults is a better solution.

Re: Changed opcache.enable_cli recovery from PHP7.4.0RC5

### Changed versions

# php70 -i|grep -i opcache.enable_cli
opcache.enable_cli => Off => Off

# php71 -i|grep -i opcache.enable_cli
opcache.enable_cli => Off => Off

# php72 -i|grep -i opcache.enable_cli
opcache.enable_cli => Off => Off

# php73 -i|grep -i opcache.enable_cli
opcache.enable_cli => Off => Off

# php74 -i|grep -i opcache.enable_cli
opcache.enable_cli => On => On

# php80 -i|grep -i opcache.enable_cli 
opcache.enable_cli => On => On

Re: Changed opcache.enable_cli recovery from PHP7.4.0RC5

Thanks fr the report

Strangely you are the first to report any issue with this configuration (since 7.4 was released, 1 year ago)

Have you more information about what happens exactly?
Is it a opcache issue, which can be fixed upstream?
Is it an artisan issue, which can be fixed upstream?
Any upstream report?

Of course, I can be convinced to revert this change, but I'd like to understand what is the exact problem, especially as the opcache optimizer can give perf improvement (~40% on Zend/benchmark)

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Changed opcache.enable_cli recovery from PHP7.4.0RC5

Sorry, I tested it again to reproduce the problem and it was identified as a different cause.

It was just a redis database number overlap.

`opcache.enable_cli=1` didn't have any problem.

Re: Changed opcache.enable_cli recovery from PHP7.4.0RC5

great  smile

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi