Topic: PHP 5.3 to 7.3 upgrade failed

Hello again.
I've posted my problem about 2 weeks ago on Stackoverflow, and you explained what needed to be done, but I wasn't able to do so.
To readdress my problem, I'm trying to update a vps for a client, running Centos 6, php 5.3. apache.
"which php" : /usr/local/bin/php and "/usr/bin/php -v" : PHP 7.3.24 (cli) (built: Oct 27 2020 12:24:50) gives  me this and you said /usr/local/bin/php had to be removed. I was wondering if " rm -rf /usr/local/bin/php /usr/local/lib/php " would work?
I deleted the "/usr/local/bin/php" but somehow php 7.3 couldn't be found or I did something wrong. so I reverted the process.
Still have php 5.3

Re: PHP 5.3 to 7.3 upgrade failed

CentOS 6 is dead, unmaintained, unsecure : you MUST upgrade to a supported released.

if you have both /usr/bin/php  (package) and  /usr/local/bin/php (build from sources), you have to remoce the second and the first will be used.

You can encounter bash cache issue to switch to new binary, a logoff/login should be enough

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: PHP 5.3 to 7.3 upgrade failed

thank you.
Yes, I will do that immediately. thank you so much.