1 (edited by BillGuarnere 2021-02-01 10:15:05)

Topic: gnupg1 conflict with epel

Hi, a few days ago I noticed some problems during my daily yum-cron update regarding gnupg1, seems like some sort of conflict between the original package from Remi and a new one from Epel.

These are the packages I have installed on my server

[bill@drakaris ~]#sudo rpm -qa | grep gnupg | sort
gnupg1-1.4.23-1.el7.remi.x86_64
gnupg2-2.0.22-5.el7_5.x86_64
php73-php-pecl-gnupg-1.4.0-6.el7.remi.x86_64
php-pecl-gnupg-1.4.0-6.el7.remi.7.3.x86_64

This is the output from a manual yum update

[bill@drakaris ~]$sudo yum update
Loaded plugins: changelog, copr, fastestmirror
Loading mirror speeds from cached hostfile
 * base: d36uatko69830t.cloudfront.net
 * centos-sclo-rh: d36uatko69830t.cloudfront.net
 * centos-sclo-sclo: d36uatko69830t.cloudfront.net
 * epel: d2lzkl7pfhq30w.cloudfront.net
 * extras: d36uatko69830t.cloudfront.net
 * remi-php73: mirror.netweaver.uk
 * remi-safe: mirror.netweaver.uk
 * updates: d36uatko69830t.cloudfront.net
Resolving Dependencies
--> Running transaction check
---> Package gnupg1.x86_64 0:1.4.23-1.el7.remi will be updated
--> Processing Dependency: gnupg < 2 for package: php73-php-pecl-gnupg-1.4.0-6.el7.remi.x86_64
--> Processing Dependency: gnupg < 2 for package: php-pecl-gnupg-1.4.0-6.el7.remi.7.3.x86_64
---> Package gnupg1.x86_64 0:1.4.23-14.el7 will be an update
--> Finished Dependency Resolution
Error: Package: php73-php-pecl-gnupg-1.4.0-6.el7.remi.x86_64 (@remi-safe)
           Requires: gnupg < 2
           Removing: gnupg1-1.4.23-1.el7.remi.x86_64 (@remi-safe)
               gnupg = 1.4.23-1.el7.remi
           Updated By: gnupg1-1.4.23-14.el7.x86_64 (epel)
               Not found
           Installed: gnupg2-2.0.22-5.el7_5.x86_64 (installed)
               gnupg = 2.0.22-5.el7_5
           Available: gnupg1-1.4.20-1.el7.remi.x86_64 (remi-safe)
               gnupg = 1.4.20-1.el7.remi
Error: Package: php-pecl-gnupg-1.4.0-6.el7.remi.7.3.x86_64 (@remi-php73)
           Requires: gnupg < 2
           Removing: gnupg1-1.4.23-1.el7.remi.x86_64 (@remi-safe)
               gnupg = 1.4.23-1.el7.remi
           Updated By: gnupg1-1.4.23-14.el7.x86_64 (epel)
               Not found
           Installed: gnupg2-2.0.22-5.el7_5.x86_64 (installed)
               gnupg = 2.0.22-5.el7_5
           Available: gnupg1-1.4.20-1.el7.remi.x86_64 (remi-safe)
               gnupg = 1.4.20-1.el7.remi
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

This is the detail of the new package you is trying to install and which causes the conflict

[bill@drakaris ~]$sudo yum info gnupg1-1.4.23-14.el7.x86_64
Loaded plugins: changelog, copr, fastestmirror
Loading mirror speeds from cached hostfile
 * base: d36uatko69830t.cloudfront.net
 * centos-sclo-rh: d36uatko69830t.cloudfront.net
 * centos-sclo-sclo: d36uatko69830t.cloudfront.net
 * epel: mirror.freethought-internet.co.uk
 * extras: d36uatko69830t.cloudfront.net
 * remi-php73: mirror.netweaver.uk
 * remi-safe: mirror.netweaver.uk
 * updates: d36uatko69830t.cloudfront.net
Available Packages
Name        : gnupg1
Arch        : x86_64
Version     : 1.4.23
Release     : 14.el7
Size        : 1.3 M
Repo        : epel/x86_64
Summary     : A GNU utility for secure communication and data storage
URL         : http://www.gnupg.org/
License     : GPLv3+ with exceptions
Description : GnuPG (GNU Privacy Guard) is a GNU utility for encrypting data and
            : creating digital signatures. GnuPG has advanced key management
            : capabilities and is compliant with the proposed OpenPGP Internet
            : standard described in RFC2440. Since GnuPG doesn't use any patented
            : algorithm, it is not compatible with any version of PGP2 (PGP2.x uses
            : only IDEA for symmetric-key encryption, which is patented worldwide).

I also tried to manually download the new rpm from Epel and update via rpm, but this is the result

[bill@drakaris ~]$sudo rpm -Uvh /tmp/gnupg1-1.4.23-14.el7.x86_64.rpm
error: Failed dependencies:
        gnupg < 2 is needed by (installed) php73-php-pecl-gnupg-1.4.0-6.el7.remi.x86_64
        gnupg < 2 is needed by (installed) php-pecl-gnupg-1.4.0-6.el7.remi.7.3.x86_64

Do you have any suggestion on how to solve this conflict, or do you know if some gnupg1 updated is also pending on remi with the same version as the epel one?

Thanks

Bill

Re: gnupg1 conflict with epel

Thanks for the notice

Indeed "gnupg1" was missing in EPEL for years, so was in my repository as a "temporary" workaround

As finally available in EPEL will provide a new build of the pecl extension as soon as possible
and remove it from my repo.

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: gnupg1 conflict with epel

Notice: Affects only EL-7 and PHP <= 7.3

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: gnupg1 conflict with epel

New builds (1.4.0-10) are now uploaded to the repository, and should fix this issue.

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: gnupg1 conflict with epel

Remi wrote:

New builds (1.4.0-10) are now uploaded to the repository, and should fix this issue.

Fantastic job, thank you very much for your time smile

Re: gnupg1 conflict with epel

smile

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi