Topic: cannot install the best update candidate for package php-gd-8.0.10-2.e

Greetings Remi's forum users,

The forum is great and thanks to you for helping and sharing your valuable  opinions, really appreciated!

I'm not sure how many of you experienced the below issue...

From a few days we are trying to update some of our RHEL 8 nodes but we face the below error:

---
Problem 2: cannot install the best update candidate for package php-gd-8.0.10-2.el8.remi.x86_64
  - nothing provides libgd.so.103()(64bit) needed by php-gd-8.1.1-1.el8.remi.x86_64
---

The package gd3php is not in the modular Remi repo which we are using.

We are syncing from here mirrorlist=http://cdn.remirepo.net/enterprise/8/modular/$basearch/mirror to our internal repo, so we are using her repo as is without any change.
This update issue appeared on 16.12.2021 when the php-gd-8.1.1-1.el8.remi.x86_64.rpm was added in the Remi's repo.
Is there a way to resolve this missing dependency issue somehow?

Regards

Re: cannot install the best update candidate for package php-gd-8.0.10-2.e

> The package gd3php is not in the modular Remi repo which we are using.

it is in the remi-safe repository which is mandatory as it provides all common dependencies
and it is enabled by default using the remi-release autoconfiguration package


P.S. explanation about this update https://github.com/remicollet/remirepo/issues/194

Desktop: Fedora 35 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 34 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi