1 (edited by wilburunion 2022-07-07 18:28:09)

Topic: php-pecl-zip won't upgrade

centOS 7 server - yum won't upgrade php-pecl-zip.  I am running php 7.4.27 - but the yum repo file still has the 7.3 repo file installed
  It reads

Error: Package: php-pecl-zip-1.21.0-3.el7.remi.7.3.x86_64 (remi-php73)
           Requires: php(zend-abi) = 20180731-64
           Installed: php-common-7.4.27-1.el7.remi.x86_64 (@remi-php74)
               php(zend-abi) = 20190902-64

I know php 7.3 is end of life, but I do have the correct php installed

even though I uninstalled php 7.3 - yum update still does this

---> Package php-pecl-zip.x86_64 0:1.20.0-1.el7.remi.7.4 will be updated
---> Package php-pecl-zip.x86_64 0:1.21.0-3.el7.remi.7.3 will be an update
--> Processing Dependency: php(api) = 20180731-64 for package: php-pecl-zip-1.21.0-3.el7.remi.7.3.x86_64
--> Processing Dependency: php(zend-abi) = 20180731-64 for package: php-pecl-zip-1.21.0-3.el7.remi.7.3.x86_64


I installed the php 74 verssion wwith rpm -ivh https://rpms.remirepo.net/enterprise/7/ … x86_64.rpm

But the yum update will not clear

Re: php-pecl-zip won't upgrade

Looks like you have 7.4 installed but 7.3 repository enabled.

Bad repository configuration

"yum repolist" output may helps to check
also "full" yum output may helps (instead of partial content)

For a proper configuration, follow the wizard instructions
(link on the top / right of all pages)


P.S. you are also running an outdated 7.4.27 (latest is 7.4.30), obvious result of bad repo config

Desktop: Fedora 35 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 36 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: php-pecl-zip won't upgrade

THANKS . . . That was my first thought and and I commented as thus with an underscore as below which of course is WRONG and useless

remi-php73_repo

But thank you - you are right  - I used

    yum-config-manager --disable 'remi-php*'
    yum-config-manager --enable   remi-php74

and the yum update fixed it all . . .

Updated:
  php.x86_64 0:7.4.30-1.el7.remi                    php-bcmath.x86_64 0:7.4.30-1.el7.remi              php-cli.x86_64 0:7.4.30-1.el7.remi
  php-common.x86_64 0:7.4.30-1.el7.remi             php-fpm.x86_64 0:7.4.30-1.el7.remi                 php-gd.x86_64 0:7.4.30-1.el7.remi
  php-gmp.x86_64 0:7.4.30-1.el7.remi                php-intl.x86_64 0:7.4.30-1.el7.remi                php-json.x86_64 0:7.4.30-1.el7.remi
  php-ldap.x86_64 0:7.4.30-1.el7.remi               php-mbstring.x86_64 0:7.4.30-1.el7.remi            php-mysqlnd.x86_64 0:7.4.30-1.el7.remi
  php-opcache.x86_64 0:7.4.30-1.el7.remi            php-pdo.x86_64 0:7.4.30-1.el7.remi                 php-pecl-zip.x86_64 0:1.21.0-3.el7.remi.7.4
  php-process.x86_64 0:7.4.30-1.el7.remi            php-soap.x86_64 0:7.4.30-1.el7.remi                php-sodium.x86_64 0:7.4.30-1.el7.remi
  php-tidy.x86_64 0:7.4.30-1.el7.remi               php-xml.x86_64 0:7.4.30-1.el7.remi

Re: php-pecl-zip won't upgrade

smile

Desktop: Fedora 35 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 36 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi