1 (edited by monkey3d 2022-11-20 08:44:20)

Topic: Fedora 37 - installation Dolibarr nécessite php-imap

Bonjour,
Pour installer Dolibarr, il est nécessaire d'avoir php-imap et php-ldap d'installés.
php-ldap est dans les dépôts de Fedora 37 mais pas php-imap.
J'installe donc la pile php81 - multiple versions simultaneously -puis php-imap. L'installation est réalisée sans problème.
A noter que la pile remi est la même me semble t-il que l'actuelle version php de Fedora 37 soit la 8.1.12.
Puis je lance l'installation de Dolibarr mais échec car ne trouve pas php-imap.
Effectivement ce n'est pas php-imap qui est connu mais php81-php-imap
J'ai lu pas mal de post mais je ne vois pas comment faire.
==> une solution ?
D'avance merci.

Re: Fedora 37 - installation Dolibarr nécessite php-imap

Si il y a 2 versions installées, il faut s'assurer de celle utilisée pour les pages PHP
Donc quel est le service FPM qui tourne (php-fpm ou php81-php-fpm)

Sinon, le plus simple est évidement de n'utiliser qu'une seule version

Pour une installation simple et propre, suivre les instructions de l'assistant
https://rpms.remirepo.net/wizard/

Desktop: Fedora 35 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 36 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

3 (edited by monkey3d 2022-11-21 12:15:06)

Re: Fedora 37 - installation Dolibarr nécessite php-imap

Merci pour la réponse.
J'ai bien-sûr appliqué les instructions du lien wizard dans la formule - multiple versions simultaneously - comme je l'indique dans mon post d'origine.
J'ai donc 2 piles php qui à priori sont identiques puisque Fedora 37 de base à la version php 8.1.12.
J'ai 3 applicatifs sous Symfony 5.4 qui fonctionnent sans problème en utilisant la pile php de Fedora 37.
Je voudrai maintenant installer Dolibarr dont l'installeur me demande php-imap qui n'existe pas dans les dépôts Fedora. Voilà la raison d'installation de la nouvelle pile qui permet d'installer php-imap. Sauf que l'installeur de Dolibarr ne trouve pas php-imap puisqu'il se nomme php81-php-imap.
Et je ne vois pas comment faire pour que l'installeur Dolibarr pointe sur le php-imap installé ou (et c'est peut-être la solution) faire pointer mes 3 applicatifs sur la nouvelle pile qui est normalement identique à celle de Fedora 37 de base.
Une idée ?

Re: Fedora 37 - installation Dolibarr nécessite php-imap

Encore une fois il serait beaucoup plus simple d'installer 1 seule version
(au lieu d'installer 2 fois la 8.1, celle de fedora et la mienne)

Pour utiliser la version php81-* il faut s'assure que php81-php-fpm est installé et fonctionne
et ensuite pour chaque vhost / app / dossier, positionner le bon SetHander pour utiliser le bon FPM.

Comme décrit dans https://blog.remirepo.net/post/2022/02/ … ravail-PHP

Desktop: Fedora 35 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 36 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Fedora 37 - installation Dolibarr nécessite php-imap

Merci pour vos réponses.
Je comprends bien tout l'intérêt en terme de simplicité de n'avoir qu'une seule pile et si c'est possible je m'engouffrerai dans la solution.
Je vais donc étudier le lien indiqué et évaluer si je peux migrer mes 3 applis web actuels de la pile Fedora vers votre pile qui me semble pour l'instant la seule solution.
Je ne peux me permettre d'avoir un non-fonctionnement sur ces 3 applis.
Je ne peux agir aussi à priori sur l'installeur Dolibarr qui s'arrête dès qu'il teste la non présence du package php-imap. Et je suppose qu'il n'y a aucun moyen de renommer le php81-php-imap en php-imap en sachant que la pile php Fedora est identique actuellement à votre pile ?
Dolibarr étant un progiciel open-source assez répandu, il me semble aussi curieux d'avoir ce problème sur la distribution Linux Fedora. Je crois que php-imap a été retiré des dépôts Fedora à partir de la version 34.

Re: Fedora 37 - installation Dolibarr nécessite php-imap

> Et je suppose qu'il n'y a aucun moyen de renommer le php81-php-imap en php-imap en sachant que la pile php Fedora est identique actuellement à votre pile ?

Non

> Dolibarr étant un progiciel open-source assez répandu, il me semble aussi curieux d'avoir ce problème sur la distribution Linux Fedora.

imap s'appuie sur libc-client qui est un projert mort depuis 15ans, sans maintenance
donc aucun projet sérieux ne devrait d'appuyé dessus.

Desktop: Fedora 35 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 36 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Fedora 37 - installation Dolibarr nécessite php-imap

Je vais essayer de le re-signaler au projet Dolibarr sans trop d'illusion sur la portée de mon intervention.
Des posts existent sur le sujet et retourne tous en réponse vers l'utilisation de votre pile.
Merci pour vos infos. Cordialement.

Re: Fedora 37 - installation Dolibarr nécessite php-imap

Pour info contenu du post transmis à Dolibarr :
Bonjour,
L’installeur rpm de Dolibarr pour Fedora vérifie que php-imap est bien installé.
Or depuis la version 34 de Fedora php-imap a été retiré car php-imap s’appuie sur la librairie libc-client qui est un projet ‹ mort › sans maintenance depuis plus de 10 ans.
Il y a bien-sûr une solution de contournement en installant sur la plateforme une pile php du dépôt Remi qui comprend php-imap mais qui oblige à faire ‹ quelques acrobaties › si le serveur a d’autres applicatifs et donc nécessite d’adresser la bonne pile php par applicatif.
Ne serait-il pas opportun de changer de solution pour adresser les mails ? et dans un premier temps de ne plus obliger l’installation de php-imap quitte à geler la fonction mail ?
Merci.

Re: Fedora 37 - installation Dolibarr nécessite php-imap

> Ne serait-il pas opportun de changer de solution pour adresser les mails ? et dans un premier temps de ne plus obliger l’installation de php-imap quitte à geler la fonction mail ?

imap ce n'est pas pour "envoyer" des mails, mais pour "lire" le contenu d'une boite mail.

Desktop: Fedora 35 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 36 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

10 (edited by monkey3d 2022-11-21 14:54:59)

Re: Fedora 37 - installation Dolibarr nécessite php-imap

J'ai écris "adresser" ... peut-être un manque de précision de ma part. J'ai utilisé ce package il y a quelques années dans un projet, je connais sa portée.