Topic: Struggling with rebuilding any PHP SCL package

Hi there. I am running Rocky Linux 8 on a Raspberry Pi4. I am trying to rebuild a couple of your PHP SCL src packages for my required aarch64 architecture.

Using php82 as an example:

I have installed the php82-8.2-4.remi.src.rpm and the php-8.2.4-1.remi.src.rpm RPMs and then I run rpmbuild --define "scl php82" -ba php.spec from my SPECS directory.
This appears to work as after some time a number of rpm files beginning with php82 are generated in my RPMS directory.

I then attempt to install these RPMs by running sudo dnf install php82*.rpm from the RPMS directory.
However this fails and complains about php82-runtime being missing.

I am still fairly new to rebuilding RPMs, especially SCLs, and have gotten this far by learning from posts here on the forum :-)

Please help, what am I doing wrong?


Re: Struggling with rebuilding any PHP SCL package

I think I may have solved the problem.

I decided to try running the rpmbuild command again but in a slightly different way: rpmbuild --define "scl php82" -ba php82.spec

This generated an additional couple of rpm files in addition to the ones I had managed to generate earlier, one of which happened to be the php82 runtime rpm.

Running the sudo dnf install php82*.rpm command from the RPMS directory now successfully installs the rpms

Re: Struggling with rebuilding any PHP SCL package

Do you really need Software Collection ? do you need various versions running simultaneously?

Single version are now the default way (modules) and containers

The aarch64 PHP modules are available for EL-9  (not for EL-8 because lack of time / resources)

Else if you really want to build SCL on EL-8
never use rpmbuild directly, but use mock instead

You can read the (very) long thread about this

Desktop: Fedora 37 + rpmfusion + remi-test
Laptop:  Fedora 38 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi