Topic: phpMyAdmin 4.8.1 depency issue

Hi Remi,
first of all a big thanks for your wonderful SCL repos for PHP on centos 7.
I use the SCL version 5.6.x and 7.0.x on my server and left the centos default untouched.
But now there seems to be a problem with that centos default version as i cant update phpMyAdmin.
Updating worked without problems until version 4.7.8 but now i am stuck and couldnt resolve it yet.
Maybe you have another idea to get it to work?

Thanks in advance, sascha

following the output of yum (sorry for the german parts ; ) )

Fehler: Paket: php-twig-1.35.3-1.el7.remi.5.4.x86_64 (remi)
            Benötigt: php(api) = 20100412-64
            Installiert: php-common-5.6.26-1.el7.remi.x86_64 (@remi-php56)
                php(api) = 20131106-64
            Verfügbar: php-common-5.4.16-45.el7.x86_64 (base)
                php(api) = 20100412-64
            Verfügbar: php-common-5.4.45-13.el7.remi.x86_64 (remi)
                php(api) = 20100412-64
            Verfügbar: php-common-5.4.45-14.el7.remi.x86_64 (remi)
                php(api) = 20100412-64
Fehler: Paket: php-intl-5.4.45-14.el7.remi.x86_64 (remi)
            Benötigt: php-common(x86-64) = 5.4.45-14.el7.remi
            Installiert: php-common-5.6.26-1.el7.remi.x86_64 (@remi-php56)
                php-common(x86-64) = 5.6.26-1.el7.remi
            Verfügbar: php-common-5.4.16-45.el7.x86_64 (base)
                php-common(x86-64) = 5.4.16-45.el7
            Verfügbar: php-common-5.4.45-13.el7.remi.x86_64 (remi)
                php-common(x86-64) = 5.4.45-13.el7.remi
            Verfügbar: php-common-5.4.45-14.el7.remi.x86_64 (remi)
                php-common(x86-64) = 5.4.45-14.el7.remi
Fehler: Paket: php-twig-1.35.3-1.el7.remi.5.4.x86_64 (remi)
            Benötigt: php(zend-abi) = 20100525-64
            Installiert: php-common-5.6.26-1.el7.remi.x86_64 (@remi-php56)
                php(zend-abi) = 20131226-64
            Verfügbar: php-common-5.4.16-45.el7.x86_64 (base)
                php(zend-abi) = 20100525-64
            Verfügbar: php-common-5.4.45-13.el7.remi.x86_64 (remi)
                php(zend-abi) = 20100525-64
            Verfügbar: php-common-5.4.45-14.el7.remi.x86_64 (remi)
                php(zend-abi) = 20100525-64
 Sie können versuchen, mit --skip-broken das Problem zu umgehen.
 Sie könnten Folgendes versuchen: rpm -Va --nofiles --nodigest

BTW: The buttons in compose window are not working for me.

Re: phpMyAdmin 4.8.1 depency issue

> I use the SCL version 5.6.x and 7.0.x on my server and left the centos default untouched.

Be aware that packaged webapp (e.g.phpMyAdmin) are not aware of SCL, and only use dependencies from "base" packages.

>Fehler: Paket: php-intl-5.4.45-14.el7.remi.x86_64 (remi)
>            Benötigt: php-common(x86-64) = 5.4.45-14.el7.remi
>            Installiert: php-common-5.6.26-1.el7.remi.x86_64 (@remi-php56)

You have php-common from remi-php56, so you need php-twig from remi-php56

And thus also probably php56-php-twig and php70-php-twig

BTW, phpMyAdmin will alway use the twig library from base repo, but the package also provide the twig extension (php 5.x) which is only a accelerator (not available for 7.x)

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: phpMyAdmin 4.8.1 depency issue

Thanks for the input.

I installed php-twig for 5.6 and 7.0 with

yum --enablerepo=remi install php56-php-twig php70-php-twig

but unfortunately this doesn't change a thing, the error is still the same.

Is that php-twig something new in phpMyAdmin 4.8.1?
I am asking because i haven't changed my server config since last phpMyAdmin update and i am wondering why this failure happens now.

regarding

Be aware that packaged webapp (e.g.phpMyAdmin) are not aware of SCL, and only use dependencies from "base" packages.

if it is not aware of the SCL versions why does it show the (@remi-php56)-SCL-versions in the dependencies check?
Or did i missunderstand?

Re: phpMyAdmin 4.8.1 depency issue

Try:

yum --enablerepo=remi-php56 install php-twig

> Is that php-twig something new in phpMyAdmin 4.8.1?

Yes.

> if it is not aware of the SCL versions why does it show the (@remi-php56)-SCL-versions in the dependencies check?

@remi-php56 means the "remi-php56" repository with base packages (php-*)
the SCL packages (php56-*) are in remi or remi-safe

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: phpMyAdmin 4.8.1 depency issue

yum --enablerepo=remi-php56 install php-twig

did half the trick.
After doing so the error

Fehler: Paket: php-intl-5.4.45-14.el7.remi.x86_64 (remi)
            Benötigt: php-common(x86-64) = 5.4.45-14.el7.remi
            Installiert: php-common-5.6.26-1.el7.remi.x86_64 (@remi-php56)
                php-common(x86-64) = 5.6.26-1.el7.remi
            Verfügbar: php-common-5.4.16-45.el7.x86_64 (base)
                php-common(x86-64) = 5.4.16-45.el7
            Verfügbar: php-common-5.4.45-13.el7.remi.x86_64 (remi)
                php-common(x86-64) = 5.4.45-13.el7.remi
            Verfügbar: php-common-5.4.45-14.el7.remi.x86_64 (remi)
                php-common(x86-64) = 5.4.45-14.el7.remi

was left and so i did

yum --enablerepo=remi-php56 install php-intl

After that i was able to install the new phpMyAdmin.

If i understand it correctly by doing so i upgraded the centos 7 stock version to version 5.6.36 from your repo.
Therefore if there are problems in the future i have to write about errors here in this forum.

Re: phpMyAdmin 4.8.1 depency issue

> If i understand it correctly by doing so i upgraded the centos 7 stock version to version 5.6.36 from your repo.

It was already updated (in you first post => Installiert: php-common-5.6.26-1.el7.remi.x86_64 (@remi-php56))

To be clear,

* If you want to keep stock version of PHP, you need to use phpMyAdmin version 4.4.15 from EPEL.
But this version won't work well with recent PHP versions installed as SCL (especially latest 7.x)

* If you want latest phpMyAdmin, from my repository (4.8.1 for now), indeed, you have to update stock PHP version.

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test