Topic: Remi php-intl - very old version

Hello,

First of all- thank you for all the repos smile

I am currently using PHP 7.2.13 from Remi on centos 7.

I wanted to install prestashop which needed php-intl. I installed it with yum, and it got "php-intl.x86_64   7.2.13-1.el7.remi    @remi-php72".

However, the prestashop installation script gives a warning that the intl/icu are too old.

Checking phpinfo shows this:

intl
Internationalization support    enabled
version     1.1.0
ICU version     50.1.2
ICU Data version     50.1
ICU TZData version     2018e
ICU Unicode version     6.2


Could you please tell me:

1-why are such old versions used? Are newer ones unstable?
2-will there be any issues if I remove the remi php-intl and manually compile another php-intl / ICU package?

Thanks a lot!

Re: Remi php-intl - very old version

> 1-why are such old versions used? Are newer ones unstable?

This is the ICU version available on official repository.

> 2-will there be any issues if I remove the remi php-intl and manually compile another php-intl / ICU package?

It could work.

BTW, I will very probably backport ICU 60 (from RHEL-8) to EL6 and EL7 repo.

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Remi php-intl - very old version

Thank you!