Topic: zip PHP Startup: Unable to load dynamic library

I've recently updated from PHP 7.1.5 to 7.1.25 and this error comes up but only for some requests:

PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/zip.so' - /usr/lib64/php/modules/zip.so: undefined symbol: zip_libzip_version

CentOS Linux release 7.3.1611 (Core)
remi-php71

Re: zip PHP Startup: Unable to load dynamic library

Check libzip5 version.

Should be 1.5.1 (from remi-safe which is by default enabled, so which should have been pull by any update)

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

3 (edited by keune 2018-12-12 13:58:35)

Re: zip PHP Startup: Unable to load dynamic library

I think it was about PHP-FPM not reloading correctly after new PHP version was installed.
The errors stopped after i restart PHP-FPM. Apparently a reload is not enough.

Thank you.