Topic: libmemcached-opt-libs libevent2 dependency error

Hi,

When I run yum update it gives libevent2 dependency error. When I try to yum search libevent2 it says No matches found. How can I solve this problem ?


yum update
Loaded plugins: priorities, update-motd, upgrade-helper
1404 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package php72-php-pecl-memcached.x86_64 0:3.0.4-1.el6.remi will be updated
---> Package php72-php-pecl-memcached.x86_64 0:3.1.3-1.el6.remi will be an update
--> Processing Dependency: libmemcached-opt-libs(x86-64) for package: php72-php-pecl-memcached-3.1.3-1.el6.remi.x86_64
---> Package php72-php-pecl-msgpack.x86_64 0:2.0.2-4.el6.remi will be updated
---> Package php72-php-pecl-msgpack.x86_64 0:2.0.3-1.el6.remi will be an update
--> Running transaction check
---> Package libmemcached-opt-libs.x86_64 0:1.0.18-1.el6.remi will be installed
--> Processing Dependency: libevent2(x86-64) for package: libmemcached-opt-libs-1.0.18-1.el6.remi.x86_64
--> Finished Dependency Resolution
Error: Package: libmemcached-opt-libs-1.0.18-1.el6.remi.x86_64 (remi)
           Requires: libevent2(x86-64)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest







yum search libevent2
Loaded plugins: priorities, update-motd, upgrade-helper
amzn-main                                                                    | 2.1 kB  00:00:00     
amzn-updates                                                                 | 2.5 kB  00:00:00     
epel/x86_64/metalink                                                         |  18 kB  00:00:00     
epel                                                                         | 3.2 kB  00:00:00     
remi                                                                         | 3.0 kB  00:00:00     
remi-php72                                                                   | 3.0 kB  00:00:00     
remi-safe                                                                    | 3.0 kB  00:00:00     
(1/11): amzn-main/latest/group_gz                                            | 4.4 kB  00:00:00     
(2/11): amzn-updates/latest/group_gz                                         | 4.4 kB  00:00:00     
(3/11): amzn-updates/latest/updateinfo                                       | 542 kB  00:00:00     
(4/11): amzn-updates/latest/primary_db                                       | 1.1 MB  00:00:00     
(5/11): amzn-main/latest/primary_db                                          | 4.0 MB  00:00:00     
(6/11): epel/x86_64/group_gz                                                 |  71 kB  00:00:00     
(7/11): epel/x86_64/updateinfo                                               | 773 kB  00:00:00     
(8/11): remi-php72/primary_db                                                | 190 kB  00:00:00     
(9/11): remi-safe/primary_db                                                 | 1.2 MB  00:00:00     
(10/11): remi/primary_db                                                     | 2.3 MB  00:00:00     
(11/11): epel/x86_64/primary                                                 | 3.2 MB  00:00:00     
epel                                                                                    12517/12517
1404 packages excluded due to repository priority protections
Warning: No matches found for: libevent2
No matches found

Re: libmemcached-opt-libs libevent2 dependency error

BTW when I check libevent version with yum info libevent. It's look like version 2.0.21 is already installed. But the package name is not libevent2 it's libevent.

yum info libevent
Loaded plugins: priorities, update-motd, upgrade-helper
1404 packages excluded due to repository priority protections
Installed Packages
Name        : libevent
Arch        : x86_64
Version     : 2.0.21
Release     : 4.19.amzn1
Size        : 697 k
Repo        : installed
Summary     : Abstract asynchronous event notification library
URL         : http://sourceforge.net/projects/levent/
License     : BSD
Description : The libevent API provides a mechanism to execute a callback function
            : when a specific event occurs on a file descriptor or after a timeout
            : has been reached. libevent is meant to replace the asynchronous event
            : loop found in event driven network servers. An application just needs
            : to call event_dispatch() and can then add or remove events dynamically
            : without having to change the event loop.

Re: libmemcached-opt-libs libevent2 dependency error

You are not using CentOS but an amzn thing...

Sorry, but no idea how to fix this properly...

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: libmemcached-opt-libs libevent2 dependency error

Working on a workaround

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: libmemcached-opt-libs libevent2 dependency error

libmemcached-opt-libs-1.0.18-2 should fix this issue.

$ rpmdiff rpmdiff libmemcached-opt-libs-1.0.18-1.el6.remi.x86_64.rpm libmemcached-opt-libs-1.0.18-2.el6.remi.x86_64.rpm
removed     REQUIRES libevent2(x86-64)  
removed     REQUIRES openssl(x86-64)  
removed     REQUIRES libstdc++(x86-64)  
removed     REQUIRES cyrus-sasl-lib(x86-64)  
added       REQUIRES libc.so.6()(64bit)  
added       REQUIRES libc.so.6(GLIBC_2.2.5)(64bit)  
added       REQUIRES libc.so.6(GLIBC_2.3.4)(64bit)  
added       REQUIRES libc.so.6(GLIBC_2.3)(64bit)  
added       REQUIRES libc.so.6(GLIBC_2.4)(64bit)  
added       REQUIRES libdl.so.2()(64bit)  
added       REQUIRES libevent-2.0.so.5()(64bit)  
added       REQUIRES libgcc_s.so.1()(64bit)  
added       REQUIRES libgcc_s.so.1(GCC_3.0)(64bit)  
added       REQUIRES libm.so.6()(64bit)  
added       REQUIRES libm.so.6(GLIBC_2.2.5)(64bit)  
added       REQUIRES libpthread.so.0()(64bit)  
added       REQUIRES libpthread.so.0(GLIBC_2.2.5)(64bit)  
added       REQUIRES libpthread.so.0(GLIBC_2.3.2)(64bit)  
added       REQUIRES libsasl2.so.2()(64bit)  
added       REQUIRES libstdc++.so.6()(64bit)  
added       REQUIRES libstdc++.so.6(CXXABI_1.3)(64bit)  
added       REQUIRES libstdc++.so.6(GLIBCXX_3.4)(64bit)  
added       REQUIRES rtld(GNU_HASH)  
...

Please confirm.

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: libmemcached-opt-libs libevent2 dependency error

It does fix the issue on my side ! smile I had the same issue yesterday

Thanks a lot

Re: libmemcached-opt-libs libevent2 dependency error

Hi,

Thank you so much for the quick fix. Now yum update worked without any problem.

Thanks,
Ozgur.