Topic: oci8 breaks after 7.1.26 update

Hello,
I read the previous issue with oci8 breaking after update, but updating has not fixed the issue for me.

After the last update to php 7.1.26 and updating oracle client to 18.3 ( also updated ldconfig), I'm getting this error:

[21-Jan-2019 18:45:08 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/oci8.so' - /usr/lib/oracle/18.3/client64/lib/libclntsh.so.18.1: undefined symbol: mql_setopt in Unknown on line 0
[21-Jan-2019 18:45:08 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/pdo_oci.so' - /usr/lib/oracle/18.3/client64/lib/libclntsh.so.18.1: undefined symbol: mql_setopt in Unknown on line 0

Are there any other steps I can take to fix this? I'm happy to provide any other system info you need.

Thank you!

Re: oci8 breaks after 7.1.26 update

I updated to php 7.3, but am still getting the mql_setopt error when restarting apache

Re: oci8 breaks after 7.1.26 update

I finally got it working.

I ended up having to change etc sysconfig htt pd and php-fpm to change the LD_LIBRARY_PATH and then reinstall htt pd after I had upgraded php.

Re: oci8 breaks after 7.1.26 update

Yes LD_LIBRARY_PATH need to link to oracle 18.3 installation directory.
This may also happen when both version 12.x and 18.3 aare in the library path.

BTW, solved.

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test