Topic: ImageMagick6-libs dependency resolution problem

Good morning!

I know how we all love ImageMagick packaging problems, I seem to have run into another one on my Centos 7 system:

--> Finished Dependency Resolution
--> Running transaction check
---> Package ImageMagick6-libs.x86_64 0:6.9.10.16-1.el7.remi will be updated
--> Processing Dependency: ImageMagick6-libs(x86-64) = 6.9.10.16-1.el7.remi for package: ImageMagick6-6.9.10.16-1.el7.remi.x86_64
---> Package kernel-devel.x86_64 0:3.10.0-862.9.1.el7 will be erased
--> Finished Dependency Resolution
Error: Package: ImageMagick6-6.9.10.16-1.el7.remi.x86_64 (@remi)
           Requires: ImageMagick6-libs(x86-64) = 6.9.10.16-1.el7.remi
           Removing: ImageMagick6-libs-6.9.10.16-1.el7.remi.x86_64 (@remi)
               ImageMagick6-libs(x86-64) = 6.9.10.16-1.el7.remi
           Updated By: ImageMagick6-libs-6.9.10.49-1.el7.remi.x86_64 (remi-safe)
               ImageMagick6-libs(x86-64) = 6.9.10.49-1.el7.remi
           Available: ImageMagick6-libs-6.9.10.48-1.el7.remi.x86_64 (remi-safe)
               ImageMagick6-libs(x86-64) = 6.9.10.48-1.el7.remi
 You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
cpanel-analytics-1.3.3-1.1.noarch has missing requires of cpanel-version >= ('0', '73.0.0', None)

I've run 'yum clean'.  Not sure what to do at this point, if using '--skip-broken' is a safe thing to do.  I don't know what the difference between '@remi' and 'remi-safe' is.  It seems to be holding back over 300 packages needing update on my production system.  The cpanel package problem looks like a separate issue.

I currently have:

# uname -r
3.10.0-693.2.2.el7.x86_64

# rpm -qa | grep remi
remi-release-7.5-2.el7.remi.noarch
# rpm -qa | grep -i imagemagick
ImageMagick6-6.9.10.16-1.el7.remi.x86_64
ImageMagick6-devel-6.9.10.16-1.el7.remi.x86_64
ImageMagick6-libs-6.9.10.16-1.el7.remi.x86_64

Thank you!
Nick

Re: ImageMagick6-libs dependency resolution problem

Check enabled repository

ImageMagick6-libs is in "remi-safe" as can be installed beside default version in base repo.

ImageMagick6 is on "remi" as it replaces default system version.

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: ImageMagick6-libs dependency resolution problem

Remi wrote:

Check enabled repository

Thank you.  I found that remi.repo had enabled=0 for the main 'remi' entry.. Strange!

With your description of remi and remi-safe, do you mean that they should both be enabled, because one contains ImageMagick6 and the other contains ImageMagick6-lib and so both are required?

I changed remi to enabled=1 and dependency resolution for the ImageMagick6* packages does now succeed.  Great!  However:

Loaded plugins: fastestmirror, universal-hooks
Loading mirror speeds from cached hostfile
 * EA4: 109.203.100.185
 * cpanel-addons-production-feed: 109.203.100.185
 * cpanel-plugins: 109.203.100.185
 * base: mirrors.clouvider.net
 * epel: mirrors.ukfast.co.uk
 * extras: mirror.sov.uk.goscomb.net
 * remi: mirrors.ukfast.co.uk
 * remi-safe: mirrors.ukfast.co.uk
 * updates: mirrors.coreix.net
Resolving Dependencies
--> Running transaction check
---> Package ImageMagick6.x86_64 0:6.9.10.16-1.el7.remi will be updated
---> Package ImageMagick6.x86_64 0:6.9.10.49-1.el7.remi will be an update
---> Package ImageMagick6-devel.x86_64 0:6.9.10.16-1.el7.remi will be updated
---> Package ImageMagick6-devel.x86_64 0:6.9.10.49-1.el7.remi will be an update
--> Processing Dependency: libwebp7-devel(x86-64) for package: ImageMagick6-devel-6.9.10.49-1.el7.remi.x86_64
---> Package ImageMagick6-libs.x86_64 0:6.9.10.16-1.el7.remi will be updated
---> Package ImageMagick6-libs.x86_64 0:6.9.10.49-1.el7.remi will be an update
--> Processing Dependency: libwebpmux.so.3()(64bit) for package: ImageMagick6-libs-6.9.10.49-1.el7.remi.x86_64
--> Processing Dependency: libwebp.so.7()(64bit) for package: ImageMagick6-libs-6.9.10.49-1.el7.remi.x86_64
---> Package MariaDB-client.x86_64 0:10.2.19-1.el7.centos will be updated
---> Package MariaDB-client.x86_64 0:10.2.25-1.el7.centos will be an update
---> Package MariaDB-common.x86_64 0:10.2.19-1.el7.centos will be updated
---> Package MariaDB-common.x86_64 0:10.2.25-1.el7.centos will be an update
---> Package MariaDB-compat.x86_64 0:10.2.19-1.el7.centos will be updated
---> Package MariaDB-compat.x86_64 0:10.2.25-1.el7.centos will be an update
---> Package MariaDB-devel.x86_64 0:10.2.19-1.el7.centos will be updated
---> Package MariaDB-devel.x86_64 0:10.2.25-1.el7.centos will be an update
---> Package MariaDB-server.x86_64 0:10.2.19-1.el7.centos will be updated
---> Package MariaDB-server.x86_64 0:10.2.25-1.el7.centos will be an update
---> Package MariaDB-shared.x86_64 0:10.2.19-1.el7.centos will be updated
---> Package MariaDB-shared.x86_64 0:10.2.25-1.el7.centos will be an update
---> Package NetworkManager.x86_64 1:1.12.0-8.el7_6 will be updated
---> Package NetworkManager.x86_64 1:1.12.0-10.el7_6 will be an update
---> Package NetworkManager-libnm.x86_64 1:1.12.0-8.el7_6 will be updated
---> Package NetworkManager-libnm.x86_64 1:1.12.0-10.el7_6 will be an update
---> Package NetworkManager-ppp.x86_64 1:1.12.0-8.el7_6 will be updated
---> Package NetworkManager-ppp.x86_64 1:1.12.0-10.el7_6 will be an update
---> Package NetworkManager-team.x86_64 1:1.12.0-8.el7_6 will be updated
---> Package NetworkManager-team.x86_64 1:1.12.0-10.el7_6 will be an update
---> Package NetworkManager-tui.x86_64 1:1.12.0-8.el7_6 will be updated
---> Package NetworkManager-tui.x86_64 1:1.12.0-10.el7_6 will be an update
---> Package NetworkManager-wifi.x86_64 1:1.12.0-8.el7_6 will be updated
---> Package NetworkManager-wifi.x86_64 1:1.12.0-10.el7_6 will be an update
---> Package bind.x86_64 32:9.9.4-72.el7 will be updated
---> Package bind.x86_64 32:9.9.4-74.el7_6.1 will be an update
---> Package bind-devel.x86_64 32:9.9.4-72.el7 will be updated
---> Package bind-devel.x86_64 32:9.9.4-74.el7_6.1 will be an update
---> Package bind-libs.x86_64 32:9.9.4-72.el7 will be updated
---> Package bind-libs.x86_64 32:9.9.4-74.el7_6.1 will be an update
---> Package bind-libs-lite.x86_64 32:9.9.4-72.el7 will be updated
---> Package bind-libs-lite.x86_64 32:9.9.4-74.el7_6.1 will be an update
---> Package bind-license.noarch 32:9.9.4-72.el7 will be updated
---> Package bind-license.noarch 32:9.9.4-74.el7_6.1 will be an update
---> Package bind-utils.x86_64 32:9.9.4-72.el7 will be updated
---> Package bind-utils.x86_64 32:9.9.4-74.el7_6.1 will be an update
---> Package cargo.x86_64 0:1.30.0-7.el7 will be updated
---> Package cargo.x86_64 0:1.35.0-1.el7 will be an update
---> Package cpanel-analytics.noarch 0:1.3.3-1.1 will be updated
---> Package cpanel-analytics.noarch 0:1.3.3-4.1 will be an update
---> Package cpanel-dovecot-solr.noarch 0:6.6.2-8.1 will be updated
---> Package cpanel-dovecot-solr.noarch 0:6.6.2-9.1 will be an update
---> Package cpanel-dovecot-solr-contrib.noarch 0:6.6.2-8.1 will be updated
---> Package cpanel-dovecot-solr-contrib.noarch 0:6.6.2-9.1 will be an update
---> Package cpanel-dovecot-solr-contrib-extraction.noarch 0:6.6.2-8.1 will be updated
---> Package cpanel-dovecot-solr-contrib-extraction.noarch 0:6.6.2-9.1 will be an update
---> Package cpanel-dovecot-solr-docs.noarch 0:6.6.2-8.1 will be updated
---> Package cpanel-dovecot-solr-docs.noarch 0:6.6.2-9.1 will be an update
---> Package cpanel-dovecot-solr-server.noarch 0:6.6.2-8.1 will be updated
---> Package cpanel-dovecot-solr-server.noarch 0:6.6.2-9.1 will be an update
---> Package cpanel-wordpress-instance-manager-plugin.noarch 0:3.0.1-1.1 will be updated
---> Package cpanel-wordpress-instance-manager-plugin.noarch 0:3.0.5-1.1 will be an update
---> Package cpanel-wp-cli.noarch 0:2.1.0-2.1 will be obsoleting
---> Package cpp.x86_64 0:4.8.5-36.el7 will be updated
---> Package cpp.x86_64 0:4.8.5-36.el7_6.2 will be an update
---> Package dbus.x86_64 1:1.10.24-12.el7 will be updated
---> Package dbus.x86_64 1:1.10.24-13.el7_6 will be an update
---> Package dbus-devel.x86_64 1:1.10.24-12.el7 will be updated
---> Package dbus-devel.x86_64 1:1.10.24-13.el7_6 will be an update
---> Package dbus-libs.x86_64 1:1.10.24-12.el7 will be updated
---> Package dbus-libs.x86_64 1:1.10.24-13.el7_6 will be an update
---> Package device-mapper.x86_64 7:1.02.149-10.el7_6.2 will be updated
---> Package device-mapper.x86_64 7:1.02.149-10.el7_6.7 will be an update
---> Package device-mapper-libs.x86_64 7:1.02.149-10.el7_6.2 will be updated
---> Package device-mapper-libs.x86_64 7:1.02.149-10.el7_6.7 will be an update
---> Package elinks.x86_64 0:0.12-0.37.pre6.el7 will be updated
---> Package elinks.x86_64 0:0.12-0.37.pre6.el7.0.1 will be an update
---> Package firefox.x86_64 0:60.3.0-1.el7.centos will be updated
---> Package firefox.x86_64 0:60.7.0-1.el7.centos will be an update
---> Package freetype.x86_64 0:2.8-12.el7 will be updated
---> Package freetype.x86_64 0:2.8-12.el7_6.1 will be an update
---> Package freetype-devel.x86_64 0:2.8-12.el7 will be updated
---> Package freetype-devel.x86_64 0:2.8-12.el7_6.1 will be an update
---> Package galera.x86_64 0:25.3.24-1.rhel7.el7.centos will be updated
---> Package galera.x86_64 0:25.3.26-1.rhel7.el7.centos will be an update
---> Package gcc.x86_64 0:4.8.5-36.el7 will be updated
---> Package gcc.x86_64 0:4.8.5-36.el7_6.2 will be an update
---> Package gcc-c++.x86_64 0:4.8.5-36.el7 will be updated
---> Package gcc-c++.x86_64 0:4.8.5-36.el7_6.2 will be an update
---> Package ghostscript.x86_64 0:9.07-31.el7_6.3 will be updated
---> Package ghostscript.x86_64 0:9.07-31.el7_6.11 will be an update
---> Package ghostscript-devel.x86_64 0:9.07-31.el7_6.3 will be updated
---> Package ghostscript-devel.x86_64 0:9.07-31.el7_6.11 will be an update
---> Package glib2.x86_64 0:2.56.1-2.el7 will be updated
---> Package glib2.x86_64 0:2.56.1-4.el7_6 will be an update
---> Package glib2-devel.x86_64 0:2.56.1-2.el7 will be updated
---> Package glib2-devel.x86_64 0:2.56.1-4.el7_6 will be an update
---> Package glibc.i686 0:2.17-260.el7 will be updated
---> Package glibc.x86_64 0:2.17-260.el7 will be updated
---> Package glibc.i686 0:2.17-260.el7_6.5 will be an update
---> Package glibc.x86_64 0:2.17-260.el7_6.5 will be an update
---> Package glibc-common.x86_64 0:2.17-260.el7 will be updated
---> Package glibc-common.x86_64 0:2.17-260.el7_6.5 will be an update
---> Package glibc-devel.x86_64 0:2.17-260.el7 will be updated
---> Package glibc-devel.x86_64 0:2.17-260.el7_6.5 will be an update
---> Package glibc-headers.x86_64 0:2.17-260.el7 will be updated
---> Package glibc-headers.x86_64 0:2.17-260.el7_6.5 will be an update
---> Package glibc-static.x86_64 0:2.17-260.el7 will be updated
---> Package glibc-static.x86_64 0:2.17-260.el7_6.5 will be an update
---> Package gnutls.x86_64 0:3.3.29-8.el7 will be updated
---> Package gnutls.x86_64 0:3.3.29-9.el7_6 will be an update
---> Package gnutls-c++.x86_64 0:3.3.29-8.el7 will be updated
---> Package gnutls-c++.x86_64 0:3.3.29-9.el7_6 will be an update
---> Package gnutls-dane.x86_64 0:3.3.29-8.el7 will be updated
---> Package gnutls-dane.x86_64 0:3.3.29-9.el7_6 will be an update
---> Package gnutls-devel.x86_64 0:3.3.29-8.el7 will be updated
---> Package gnutls-devel.x86_64 0:3.3.29-9.el7_6 will be an update
---> Package google-chrome-stable.x86_64 0:71.0.3578.98-1 will be updated
---> Package google-chrome-stable.x86_64 0:75.0.3770.100-1 will be an update
---> Package grub2.x86_64 1:2.02-0.76.el7.centos will be updated
---> Package grub2.x86_64 1:2.02-0.76.el7.centos.1 will be an update
---> Package grub2-common.noarch 1:2.02-0.76.el7.centos will be updated
---> Package grub2-common.noarch 1:2.02-0.76.el7.centos.1 will be an update
---> Package grub2-pc.x86_64 1:2.02-0.76.el7.centos will be updated
---> Package grub2-pc.x86_64 1:2.02-0.76.el7.centos.1 will be an update
---> Package grub2-pc-modules.noarch 1:2.02-0.76.el7.centos will be updated
---> Package grub2-pc-modules.noarch 1:2.02-0.76.el7.centos.1 will be an update
---> Package grub2-tools.x86_64 1:2.02-0.76.el7.centos will be updated
---> Package grub2-tools.x86_64 1:2.02-0.76.el7.centos.1 will be an update
---> Package grub2-tools-extra.x86_64 1:2.02-0.76.el7.centos will be updated
---> Package grub2-tools-extra.x86_64 1:2.02-0.76.el7.centos.1 will be an update
---> Package grub2-tools-minimal.x86_64 1:2.02-0.76.el7.centos will be updated
---> Package grub2-tools-minimal.x86_64 1:2.02-0.76.el7.centos.1 will be an update
---> Package htop.x86_64 0:2.2.0-1.el7 will be updated
---> Package htop.x86_64 0:2.2.0-3.el7 will be an update
---> Package iproute.x86_64 0:4.11.0-14.el7 will be updated
---> Package iproute.x86_64 0:4.11.0-14.el7_6.2 will be an update
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.191.b12-1.el7_6 will be updated
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.212.b04-0.el7_6 will be an update
--> Processing Dependency: pcsc-lite-libs(x86-64) for package: 1:java-1.8.0-openjdk-headless-1.8.0.212.b04-0.el7_6.x86_64
---> Package kernel.x86_64 0:3.10.0-957.21.3.el7 will be installed
---> Package kernel-devel.x86_64 0:3.10.0-957.21.3.el7 will be installed
---> Package kernel-headers.x86_64 0:3.10.0-957.1.3.el7 will be updated
---> Package kernel-headers.x86_64 0:3.10.0-957.21.3.el7 will be an update
---> Package kernel-tools.x86_64 0:3.10.0-957.1.3.el7 will be updated
---> Package kernel-tools.x86_64 0:3.10.0-957.21.3.el7 will be an update
---> Package kernel-tools-libs.x86_64 0:3.10.0-957.1.3.el7 will be updated
---> Package kernel-tools-libs.x86_64 0:3.10.0-957.21.3.el7 will be an update
---> Package kexec-tools.x86_64 0:2.0.15-21.el7 will be updated
---> Package kexec-tools.x86_64 0:2.0.15-21.el7_6.3 will be an update
---> Package kmod-libs.x86_64 0:20-21.el7 will be updated
---> Package kmod-libs.x86_64 0:20-23.el7 will be an update
---> Package krb5-devel.x86_64 0:1.15.1-34.el7 will be updated
---> Package krb5-devel.x86_64 0:1.15.1-37.el7_6 will be an update
---> Package krb5-libs.x86_64 0:1.15.1-34.el7 will be updated
---> Package krb5-libs.x86_64 0:1.15.1-37.el7_6 will be an update
---> Package libblkid.x86_64 0:2.23.2-59.el7 will be updated
---> Package libblkid.x86_64 0:2.23.2-59.el7_6.1 will be an update
---> Package libblkid-devel.x86_64 0:2.23.2-59.el7 will be updated
---> Package libblkid-devel.x86_64 0:2.23.2-59.el7_6.1 will be an update
---> Package libgcc.i686 0:4.8.5-36.el7 will be updated
---> Package libgcc.x86_64 0:4.8.5-36.el7 will be updated
---> Package libgcc.i686 0:4.8.5-36.el7_6.2 will be an update
---> Package libgcc.x86_64 0:4.8.5-36.el7_6.2 will be an update
---> Package libgfortran.x86_64 0:4.8.5-36.el7 will be updated
---> Package libgfortran.x86_64 0:4.8.5-36.el7_6.2 will be an update
---> Package libgomp.x86_64 0:4.8.5-36.el7 will be updated
---> Package libgomp.x86_64 0:4.8.5-36.el7_6.2 will be an update
---> Package libgudev1.x86_64 0:219-62.el7 will be updated
---> Package libgudev1.x86_64 0:219-62.el7_6.6 will be an update
---> Package libkadm5.x86_64 0:1.15.1-34.el7 will be updated
---> Package libkadm5.x86_64 0:1.15.1-37.el7_6 will be an update
---> Package libmount.x86_64 0:2.23.2-59.el7 will be updated
---> Package libmount.x86_64 0:2.23.2-59.el7_6.1 will be an update
---> Package libmount-devel.x86_64 0:2.23.2-59.el7 will be updated
---> Package libmount-devel.x86_64 0:2.23.2-59.el7_6.1 will be an update
---> Package libquadmath.x86_64 0:4.8.5-36.el7 will be updated
---> Package libquadmath.x86_64 0:4.8.5-36.el7_6.2 will be an update
---> Package libsmartcols.x86_64 0:2.23.2-59.el7 will be updated
---> Package libsmartcols.x86_64 0:2.23.2-59.el7_6.1 will be an update
---> Package libssh2.x86_64 0:1.4.3-12.el7 will be updated
---> Package libssh2.x86_64 0:1.4.3-12.el7_6.2 will be an update
---> Package libssh2-devel.x86_64 0:1.4.3-12.el7 will be updated
---> Package libssh2-devel.x86_64 0:1.4.3-12.el7_6.2 will be an update
---> Package libstdc++.i686 0:4.8.5-36.el7 will be updated
---> Package libstdc++.x86_64 0:4.8.5-36.el7 will be updated
---> Package libstdc++.i686 0:4.8.5-36.el7_6.2 will be an update
---> Package libstdc++.x86_64 0:4.8.5-36.el7_6.2 will be an update
---> Package libstdc++-devel.x86_64 0:4.8.5-36.el7 will be updated
---> Package libstdc++-devel.x86_64 0:4.8.5-36.el7_6.2 will be an update
---> Package libuuid.x86_64 0:2.23.2-59.el7 will be updated
---> Package libuuid.x86_64 0:2.23.2-59.el7_6.1 will be an update
---> Package libuuid-devel.x86_64 0:2.23.2-59.el7 will be updated
---> Package libuuid-devel.x86_64 0:2.23.2-59.el7_6.1 will be an update
---> Package libuv.x86_64 1:1.10.2-1.el7 will be updated
---> Package libuv.x86_64 1:1.29.1-1.el7 will be an update
---> Package mesa-libEGL.x86_64 0:18.0.5-3.el7 will be updated
---> Package mesa-libEGL.x86_64 0:18.0.5-4.el7_6 will be an update
---> Package mesa-libEGL-devel.x86_64 0:18.0.5-3.el7 will be updated
---> Package mesa-libEGL-devel.x86_64 0:18.0.5-4.el7_6 will be an update
---> Package mesa-libGL.x86_64 0:18.0.5-3.el7 will be updated
---> Package mesa-libGL.x86_64 0:18.0.5-4.el7_6 will be an update
---> Package mesa-libGL-devel.x86_64 0:18.0.5-3.el7 will be updated
---> Package mesa-libGL-devel.x86_64 0:18.0.5-4.el7_6 will be an update
---> Package mesa-libgbm.x86_64 0:18.0.5-3.el7 will be updated
---> Package mesa-libgbm.x86_64 0:18.0.5-4.el7_6 will be an update
---> Package mesa-libglapi.x86_64 0:18.0.5-3.el7 will be updated
---> Package mesa-libglapi.x86_64 0:18.0.5-4.el7_6 will be an update
---> Package microcode_ctl.x86_64 2:2.1-47.el7 will be updated
---> Package microcode_ctl.x86_64 2:2.1-47.4.el7_6 will be an update
---> Package newrelic-daemon.x86_64 0:8.4.0.231-1 will be updated
---> Package newrelic-daemon.x86_64 0:8.7.0.242-1 will be an update
---> Package newrelic-php5.x86_64 0:8.4.0.231-1 will be updated
---> Package newrelic-php5.x86_64 0:8.7.0.242-1 will be an update
---> Package newrelic-php5-common.noarch 0:8.4.0.231-1 will be updated
---> Package newrelic-php5-common.noarch 0:8.7.0.242-1 will be an update
---> Package nscd.x86_64 0:2.17-260.el7 will be updated
---> Package nscd.x86_64 0:2.17-260.el7_6.5 will be an update
---> Package nss.x86_64 0:3.36.0-7.el7_5 will be updated
---> Package nss.x86_64 0:3.36.0-7.1.el7_6 will be an update
---> Package nss-pem.x86_64 0:1.0.3-5.el7 will be updated
---> Package nss-pem.x86_64 0:1.0.3-5.el7_6.1 will be an update
---> Package nss-sysinit.x86_64 0:3.36.0-7.el7_5 will be updated
---> Package nss-sysinit.x86_64 0:3.36.0-7.1.el7_6 will be an update
---> Package nss-tools.x86_64 0:3.36.0-7.el7_5 will be updated
---> Package nss-tools.x86_64 0:3.36.0-7.1.el7_6 will be an update
---> Package nss-util.x86_64 0:3.36.0-1.el7_5 will be updated
---> Package nss-util.x86_64 0:3.36.0-1.1.el7_6 will be an update
---> Package openjpeg2.x86_64 0:2.3.0-6.el7 will be updated
---> Package openjpeg2.x86_64 0:2.3.1-1.el7 will be an update
---> Package openjpeg2-devel.x86_64 0:2.3.0-6.el7 will be updated
---> Package openjpeg2-devel.x86_64 0:2.3.1-1.el7 will be an update
---> Package openjpeg2-tools.x86_64 0:2.3.0-6.el7 will be updated
---> Package openjpeg2-tools.x86_64 0:2.3.1-1.el7 will be an update
---> Package openldap.x86_64 0:2.4.44-20.el7 will be updated
---> Package openldap.x86_64 0:2.4.44-21.el7_6 will be an update
---> Package openssl.x86_64 1:1.0.2k-16.el7 will be updated
---> Package openssl.x86_64 1:1.0.2k-16.el7_6.1 will be an update
---> Package openssl-devel.x86_64 1:1.0.2k-16.el7 will be updated
---> Package openssl-devel.x86_64 1:1.0.2k-16.el7_6.1 will be an update
---> Package openssl-libs.x86_64 1:1.0.2k-16.el7 will be updated
---> Package openssl-libs.x86_64 1:1.0.2k-16.el7_6.1 will be an update
---> Package pango.x86_64 0:1.42.4-1.el7 will be updated
---> Package pango.x86_64 0:1.42.4-2.el7_6 will be an update
---> Package pango-devel.x86_64 0:1.42.4-1.el7 will be updated
---> Package pango-devel.x86_64 0:1.42.4-2.el7_6 will be an update
---> Package perl-ExtUtils-CBuilder.noarch 1:0.28.2.6-293.el7 will be updated
---> Package perl-ExtUtils-CBuilder.noarch 1:0.28.2.6-294.el7_6 will be an update
---> Package perl-ExtUtils-Embed.noarch 0:1.30-293.el7 will be updated
---> Package perl-ExtUtils-Embed.noarch 0:1.30-294.el7_6 will be an update
---> Package perl-ExtUtils-Install.noarch 0:1.58-293.el7 will be updated
---> Package perl-ExtUtils-Install.noarch 0:1.58-294.el7_6 will be an update
---> Package perl-IO-Zlib.noarch 1:1.10-293.el7 will be updated
---> Package perl-IO-Zlib.noarch 1:1.10-294.el7_6 will be an update
---> Package perl-Locale-Maketext-Simple.noarch 1:0.21-293.el7 will be updated
---> Package perl-Locale-Maketext-Simple.noarch 1:0.21-294.el7_6 will be an update
---> Package perl-Module-CoreList.noarch 1:2.76.02-293.el7 will be updated
---> Package perl-Module-CoreList.noarch 1:2.76.02-294.el7_6 will be an update
---> Package perl-Module-Loaded.noarch 1:0.08-293.el7 will be updated
---> Package perl-Module-Loaded.noarch 1:0.08-294.el7_6 will be an update
---> Package perl-Object-Accessor.noarch 1:0.42-293.el7 will be updated
---> Package perl-Object-Accessor.noarch 1:0.42-294.el7_6 will be an update
---> Package perl-Package-Constants.noarch 1:0.02-293.el7 will be updated
---> Package perl-Package-Constants.noarch 1:0.02-294.el7_6 will be an update
---> Package perl-Pod-Escapes.noarch 1:1.04-293.el7 will be updated
---> Package perl-Pod-Escapes.noarch 1:1.04-294.el7_6 will be an update
---> Package perl-Time-Piece.x86_64 0:1.20.1-293.el7 will be updated
---> Package perl-Time-Piece.x86_64 0:1.20.1-294.el7_6 will be an update
---> Package perl-macros.x86_64 4:5.16.3-293.el7 will be updated
---> Package perl-macros.x86_64 4:5.16.3-294.el7_6 will be an update
---> Package policycoreutils.x86_64 0:2.5-29.el7 will be updated
---> Package policycoreutils.x86_64 0:2.5-29.el7_6.1 will be an update
---> Package policycoreutils-python.x86_64 0:2.5-29.el7 will be updated
---> Package policycoreutils-python.x86_64 0:2.5-29.el7_6.1 will be an update
---> Package polkit.x86_64 0:0.112-18.el7 will be updated
---> Package polkit.x86_64 0:0.112-18.el7_6.1 will be an update
---> Package python.x86_64 0:2.7.5-76.el7 will be updated
---> Package python.x86_64 0:2.7.5-77.el7_6 will be an update
---> Package python-devel.x86_64 0:2.7.5-76.el7 will be updated
---> Package python-devel.x86_64 0:2.7.5-77.el7_6 will be an update
---> Package python-libs.x86_64 0:2.7.5-76.el7 will be updated
---> Package python-libs.x86_64 0:2.7.5-77.el7_6 will be an update
---> Package python-perf.x86_64 0:3.10.0-957.1.3.el7 will be updated
---> Package python-perf.x86_64 0:3.10.0-957.21.3.el7 will be an update
---> Package python-tools.x86_64 0:2.7.5-76.el7 will be updated
---> Package python-tools.x86_64 0:2.7.5-77.el7_6 will be an update
---> Package r1soft-getmodule.x86_64 0:1.0.0-67 will be updated
---> Package r1soft-getmodule.x86_64 0:1.0.0-73 will be an update
---> Package remi-release.noarch 0:7.5-2.el7.remi will be updated
---> Package remi-release.noarch 0:7.6-2.el7.remi will be an update
---> Package rsync.x86_64 0:3.1.2-4.el7 will be updated
---> Package rsync.x86_64 0:3.1.2-6.el7_6.1 will be an update
---> Package rust.x86_64 0:1.30.1-7.el7 will be updated
---> Package rust.x86_64 0:1.35.0-1.el7 will be an update
--> Processing Dependency: libLLVM-7.so(LLVM_7)(64bit) for package: rust-1.35.0-1.el7.x86_64
--> Processing Dependency: libLLVM-7.so()(64bit) for package: rust-1.35.0-1.el7.x86_64
---> Package rust-std-static.x86_64 0:1.30.1-7.el7 will be updated
---> Package rust-std-static.x86_64 0:1.35.0-1.el7 will be an update
---> Package selinux-policy.noarch 0:3.13.1-229.el7_6.6 will be updated
---> Package selinux-policy.noarch 0:3.13.1-229.el7_6.12 will be an update
---> Package selinux-policy-targeted.noarch 0:3.13.1-229.el7_6.6 will be updated
---> Package selinux-policy-targeted.noarch 0:3.13.1-229.el7_6.12 will be an update
---> Package serverbackup-agent.x86_64 0:6.8.2-55 will be updated
---> Package serverbackup-agent.x86_64 0:6.10.1-29 will be an update
---> Package serverbackup-async-agent-2-6.x86_64 0:6.8.2-55 will be updated
---> Package serverbackup-async-agent-2-6.x86_64 0:6.10.1-29 will be an update
---> Package serverbackup-enterprise-agent.x86_64 0:6.8.2-55 will be updated
---> Package serverbackup-enterprise-agent.x86_64 0:6.10.1-29 will be an update
---> Package serverbackup-setup.x86_64 0:6.8.2-55 will be updated
---> Package serverbackup-setup.x86_64 0:6.10.1-29 will be an update
---> Package shadow-utils.x86_64 2:4.1.5.1-25.el7 will be updated
---> Package shadow-utils.x86_64 2:4.1.5.1-25.el7_6.1 will be an update
---> Package systemd.x86_64 0:219-62.el7 will be updated
---> Package systemd.x86_64 0:219-62.el7_6.6 will be an update
---> Package systemd-libs.i686 0:219-62.el7 will be updated
---> Package systemd-libs.x86_64 0:219-62.el7 will be updated
---> Package systemd-libs.i686 0:219-62.el7_6.6 will be an update
---> Package systemd-libs.x86_64 0:219-62.el7_6.6 will be an update
---> Package systemd-sysv.x86_64 0:219-62.el7 will be updated
---> Package systemd-sysv.x86_64 0:219-62.el7_6.6 will be an update
---> Package tkinter.x86_64 0:2.7.5-76.el7 will be updated
---> Package tkinter.x86_64 0:2.7.5-77.el7_6 will be an update
---> Package tuned.noarch 0:2.10.0-6.el7 will be updated
---> Package tuned.noarch 0:2.10.0-6.el7_6.3 will be an update
---> Package tzdata.noarch 0:2018g-1.el7 will be updated
---> Package tzdata.noarch 0:2019a-1.el7 will be an update
---> Package tzdata-java.noarch 0:2018g-1.el7 will be updated
---> Package tzdata-java.noarch 0:2019a-1.el7 will be an update
---> Package util-linux.x86_64 0:2.23.2-59.el7 will be updated
---> Package util-linux.x86_64 0:2.23.2-59.el7_6.1 will be an update
---> Package wget.x86_64 0:1.14-18.el7 will be updated
---> Package wget.x86_64 0:1.14-18.el7_6.1 will be an update
---> Package wp-cli.noarch 0:1.5.1-2.2.2.cpanel will be obsoleted
---> Package xfsprogs.x86_64 0:4.5.0-18.el7 will be updated
---> Package xfsprogs.x86_64 0:4.5.0-19.el7_6 will be an update
---> Package xorg-x11-server-Xvfb.x86_64 0:1.20.1-5.1.el7 will be updated
---> Package xorg-x11-server-Xvfb.x86_64 0:1.20.1-5.3.el7_6 will be an update
---> Package xorg-x11-server-common.x86_64 0:1.20.1-5.1.el7 will be updated
---> Package xorg-x11-server-common.x86_64 0:1.20.1-5.3.el7_6 will be an update
--> Running transaction check
---> Package libwebp7.x86_64 0:1.0.2-1.el7.remi will be installed
---> Package libwebp7-devel.x86_64 0:1.0.2-1.el7.remi will be installed
---> Package llvm7.0-libs.x86_64 0:7.0.1-4.el7 will be installed
---> Package pcsc-lite-libs.x86_64 0:1.8.8-8.el7 will be installed
--> Processing Conflict: libwebp7-devel-1.0.2-1.el7.remi.x86_64 conflicts libwebp-devel < 1.0.2
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel-devel.x86_64 0:3.10.0-862.9.1.el7 will be erased
--> Processing Conflict: libwebp7-devel-1.0.2-1.el7.remi.x86_64 conflicts libwebp-devel < 1.0.2
--> Finished Dependency Resolution
Error: libwebp7-devel conflicts with libwebp-devel-0.3.0-7.el7.x86_64
 You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
cpanel-analytics-1.3.3-1.1.noarch has missing requires of cpanel-version >= ('0', '73.0.0', None)

I do not currently have libwebp7-devel installed:

# rpm -qa | grep libwebp7

So now, apparently libwebp7-devel from remi conflicts with the base repo version? Perhaps? I'm not experienced at parsing these messages.

Re: ImageMagick6-libs dependency resolution problem

> With your description of remi and remi-safe, do you mean that they should both be enabled, because one contains ImageMagick6 and the other contains ImageMagick6-lib and so both are required?

"remi" is not safe as it replaces base package.

The libwebp7-devel package being a example.

You should enable it only if you need some package from it.

BTW, do you really need the "devel" stuff ?

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

5 (edited by neekfenwick 2019-06-20 07:44:05)

Re: ImageMagick6-libs dependency resolution problem

You make a good point, I don't need ImageMagick6-devel and removing that allows the transaction to complete since the dependent devel package is no longer considered.  My system is up to date now.

I have read https://blog.remirepo.net/pages/English-FAQ#enable where you describe 'remi' being disabled.  I seem to be in that 'administrator choice' position of wanting to enable it permanently.

This production server running cPanel runs 'dnf update' automatically to keep its packages up to date, and with 'remi' disabled the transaction could not complete (as in my original post).  I am rather red faced now, checking my emails it has been failing over ImageMagick6-libs since December last year, hence the large list of packages needing update yesterday.  So, for the security of the server, I think I would need to keep 'remi' enabled.  I'm not sure why it worked before then, perhaps the remi repo was enabled back then, or they simply were not updated very often and it was a time bomb waiting to bite me (to mix my metaphors).

May this serve as a warning to others to check their update logs for this kind of error smile

I would welcome your experienced view on this smile

Edit: by the way, the link to https://iuscommunity.org/pages/TheSafeR … ative.html from the English FAQ page returns a 301 redirect that leads to https://ius.io/pages/TheSafeRepoInitiative.html that gives a 404 response.  Perhaps https://ius.io/SafeRepo/ is the correct link and their redirect is b0rked.