Topic: nothing provides libonig.so.5 needed by php-mbstring (ubi8-minimal)

Hello,

Creating a PHP 7.3 Docker image on top of ubi8-minimal, I get:

nothing provides libonig.so.5()(64bit) needed by php-mbstring-7.3.7-3.el8.remi.x86_64

While there is an oniguruma package for RHEL 7: https://rpms.remirepo.net/enterprise/7/ … x86_64.rpm I can't find anything for RHEL 8.

Am I missing something?

Re: nothing provides libonig.so.5 needed by php-mbstring (ubi8-minimal)

I see oniguruma-6.8.2-1.el8.x86_64.rpm on the RHEL-8 DVD...

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: nothing provides libonig.so.5 needed by php-mbstring (ubi8-minimal)

# LANG=C dnf install php-mbstring
Updating Subscription Management repositories.
Last metadata expiration check: 0:01:14 ago on Tue Jul 16 11:53:11 2019.
Dependencies resolved.
===============================================================================================================
 Package              Arch           Version                    Repository                                Size
===============================================================================================================
Installing:
 php-mbstring         x86_64         7.3.7-3.el8.remi           remi-modular                             520 k
Installing dependencies:
 oniguruma            x86_64         6.8.2-1.el8                rhel-8-for-x86_64-appstream-rpms         188 k

Transaction Summary
===============================================================================================================
Install  2 Packages

Total download size: 707 k
Installed size: 2.8 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): php-mbstring-7.3.7-3.el8.remi.x86_64.rpm                                 53 MB/s | 520 kB     00:00    
(2/2): oniguruma-6.8.2-1.el8.x86_64.rpm                                        331 kB/s | 188 kB     00:00    
---------------------------------------------------------------------------------------------------------------
Total                                                                          1.2 MB/s | 707 kB     00:00     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                       1/1 
  Installing       : oniguruma-6.8.2-1.el8.x86_64                                                          1/2 
  Running scriptlet: oniguruma-6.8.2-1.el8.x86_64                                                          1/2 
  Installing       : php-mbstring-7.3.7-3.el8.remi.x86_64                                                  2/2 
  Running scriptlet: php-mbstring-7.3.7-3.el8.remi.x86_64                                                  2/2 
  Verifying        : oniguruma-6.8.2-1.el8.x86_64                                                          1/2 
  Verifying        : php-mbstring-7.3.7-3.el8.remi.x86_64                                                  2/2 
Installed products updated.

Installed:
  php-mbstring-7.3.7-3.el8.remi.x86_64                       oniguruma-6.8.2-1.el8.x86_64                      

Complete!
Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: nothing provides libonig.so.5 needed by php-mbstring (ubi8-minimal)

I can see that oniguruma is provided by repository: rhel-8-for-x86_64-appstream-rpms.

There is no such repository from a ubi8-minimal image, probably "ubi-8-appstream: Red Hat Universal Base Image 8 (RPMs)" would be the equivalent?

Here is the output of

dfn list all

https://gist.github.com/patrickallaert/ … 87fc57a201

Re: nothing provides libonig.so.5 needed by php-mbstring (ubi8-minimal)

The available repositories from an ubi8-minimal images are the following ones:

output of

dnf repolist --all

, remi* repositories stripped out:

ubi-8-appstream           Red Hat Universal Base Image 8 (RPMs) -  enabled:  692
ubi-8-appstream-debug     Red Hat Universal Base Image 8 (Debug RP disabled
ubi-8-appstream-source    Red Hat Universal Base Image 8 (Source R disabled
ubi-8-baseos              Red Hat Universal Base Image 8 (RPMs) -  enabled:  644
ubi-8-baseos-debug        Red Hat Universal Base Image 8 (Debug RP disabled
ubi-8-baseos-source       Red Hat Universal Base Image 8 (Source R disabled

Re: nothing provides libonig.so.5 needed by php-mbstring (ubi8-minimal)

I will search for more information about ubi8...

BTW, not easily fixable, as onigurama is part of RHEL-8, I cannot add it to my repo (as latest version use same soname)

And switching to bundled lib is not a solution, as it have been now removed from php-src.


...

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: nothing provides libonig.so.5 needed by php-mbstring (ubi8-minimal)

As a temporary solution, I just add to the repository (remi-safe)

oniguruma-6.8.2-0.1.el8.remi

This should fix the issue for UBI8 users

NVER is lower than official package in RHEL-8 / AppStream
so official will be used when available.

Content is the same.

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: nothing provides libonig.so.5 needed by php-mbstring (ubi8-minimal)

Building the image now works... SPLENDID :-D

YOU ROCK!!!

Thank you for your support. Any idea why oniguruma isn't "visible" from an ubi8-minimal install? Would it be different from ubi8? I guess the repository are supposed to be the same, just that the set of installed packages should be different, right?

Re: nothing provides libonig.so.5 needed by php-mbstring (ubi8-minimal)

smile

> Thank you for your support. Any idea why oniguruma isn't "visible" from an ubi8-minimal install? Would it be different from ubi8?

Don't know, need to be tried.

BTW, as far as I understand properly, UBI8 is a subset of RHEL-8, and no idea how packages are selected.

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test