1 (edited by magsu 2019-12-23 06:21:16)

Topic: roundcubemail with php72-php?

Currently, it seems that installing roundcubemail-1.4.1-1.el7.remi.noarch will require PHP 5.4 to be installed. Could it be fixed so that it would work with php72-php?

For example, for the requirement of Mastermind:

--> Running transaction check
---> Package php-masterminds-html5.noarch 0:2.7.0-1.el7.remi will be installed
--> Processing Dependency: php(language) >= 5.3.0 for package: php-masterminds-html5-2.7.0-1.el7.remi.noarch
--> Processing Dependency: php-ctype for package: php-masterminds-html5-2.7.0-1.el7.remi.noarch
--> Processing Dependency: php-dom for package: php-masterminds-html5-2.7.0-1.el7.remi.noarch
--> Processing Dependency: php-iconv for package: php-masterminds-html5-2.7.0-1.el7.remi.noarch
--> Processing Dependency: php-mbstring for package: php-masterminds-html5-2.7.0-1.el7.remi.noarch
--> Processing Dependency: php-pcre for package: php-masterminds-html5-2.7.0-1.el7.remi.noarch
--> Processing Dependency: php-spl for package: php-masterminds-html5-2.7.0-1.el7.remi.noarch
--> Running transaction check
---> Package php-common.x86_64 0:5.4.45-18.el7.remi will be installed
---> Package php-mbstring.x86_64 0:5.4.45-18.el7.remi will be installed
---> Package php-xml.x86_64 0:5.4.45-18.el7.remi will be installed

Re: roundcubemail with php72-php?

No.

Packaged applications (such as roundcubemail) are design to work with the single / default PHP version

So you need to use the php-* packages, not the php72-php-* packages

See the Wizard and the FAQ.

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: roundcubemail with php72-php?

Thanks.

But what about the EOL of 5.4?

I think I actually have this working with the 7.2 packages, at least the mod_php config that is active is from php72/php.d but it was not pretty. (rpm -e --nodeps and the resulting warnings....)

Re: roundcubemail with php72-php?

Again, install php 7.2 as single / default version (so php-* packages) and you will be able to install roundcubemail.

As explained by the wizard with detailed info in the FAQ.

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: roundcubemail with php72-php?

Please excuse me, it seems this server was installed in some non-standard way. The remi.repo file does not even have the separate stanzas for the different PHP versions.

Sorry to have wasted your time. I'll just reinstall the whole thing myself.