1

Topic: Error in phpMyAdmin - can not update.

HI,

I have this error when browsing on phpMyAdmin:
PHP 7.1.3+ is required.
Currently installed version is: 5.6.25

yum list installed php
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
Installed Packages
php.x86_64                                                   7.2.27-1.el7.remi                                            @remi-php72

yum list installed phpMyAdmin
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
Installed Packages
phpMyAdmin.noarch                                            5.0.1-2.el7.remi                                             @remi


yum repolist
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
repo id                                                                                  repo name                                                                                                              status
epel/x86_64                                                                              Extra Packages for Enterprise Linux 7 - x86_64                                                                         13,513
remi-php72                                                                               Remi's PHP 7.2 RPM repository for Enterprise Linux 7 - x86_64                                                             397
remi-safe                                                                                Safe Remi's RPM repository for Enterprise Linux 7 - x86_64                                                              3,669
rhel-7-server-optional-rpms/7Server/x86_64                                               Red Hat Enterprise Linux 7 Server - Optional (RPMs)                                                                    19,519
rhel-7-server-rpms/7Server/x86_64                                                        Red Hat Enterprise Linux 7 Server (RPMs)                                                                               26,775
rhel-server-rhscl-7-rpms/7Server/x86_64                                                  Red Hat Software Collections RPMs for Red Hat Enterprise Linux 7 Server                                                12,193


How can I fix this?

Thak you,

dg

2

Re: Error in phpMyAdmin - can not update.

After downgrading from:

phpMyAdmin-5.0.1-2.el7.remi.noarch                                                                                        2/2

to

phpMyAdmin-4.4.15.10-4.el7.noarch

My phpMyAdmin started working again.

Re: Error in phpMyAdmin - can not update.

please: rpm -qa php\* | sort

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

4

Re: Error in phpMyAdmin - can not update.

rpm -qa php\* | sort

php-7.2.27-1.el7.remi.x86_64
php-bacon-qr-code-1.0.3-1.el7.remi.noarch
php-bcmath-7.2.27-1.el7.remi.x86_64
php-cli-7.2.27-1.el7.remi.x86_64
php-common-7.2.27-1.el7.remi.x86_64
php-composer-ca-bundle-1.2.6-1.el7.remi.noarch
php-composer-semver-1.5.1-1.el7.remi.noarch
php-composer-spdx-licenses-1.5.2-1.el7.remi.noarch
php-composer-xdebug-handler-1.4.0-1.el7.remi.noarch
php-fedora-autoloader-1.0.0-1.el7.remi.noarch
php-gd-7.2.27-1.el7.remi.x86_64
php-gmp-7.2.27-1.el7.remi.x86_64
php-google-recaptcha-1.2.3-1.el7.remi.noarch
php-intl-7.2.27-1.el7.remi.x86_64
php-json-7.2.27-1.el7.remi.x86_64
php-jsonlint-1.7.2-1.el7.remi.noarch
php-justinrainbow-json-schema5-5.2.9-1.el7.remi.noarch
php-mbstring-7.2.27-1.el7.remi.x86_64
phpMyAdmin-4.4.15.10-4.el7.noarch
php-mysqlnd-7.2.27-1.el7.remi.x86_64
php-paragonie-constant-time-encoding-1.0.4-2.el7.noarch
php-paragonie-random-compat-2.0.18-1.el7.remi.noarch
php-password-compat-1.0.4-1.el7.remi.noarch
php-pdo-7.2.27-1.el7.remi.x86_64
php-pecl-zip-1.15.5-1.el7.remi.7.2.x86_64
php-php-gettext-1.0.12-1.el7.remi.noarch
php-phpmyadmin-motranslator-4.0-1.el7.remi.noarch
php-phpmyadmin-shapefile-2.1-1.el7.remi.noarch
php-phpmyadmin-sql-parser-4.5.0-1.el7.remi.noarch
php-phpmyadmin-sql-parser5-5.2.0-1.el7.remi.noarch
php-phpseclib-2.0.23-1.el7.remi.noarch
php-pragmarx-google2fa-3.0.3-1.el7.remi.noarch
php-pragmarx-google2fa5-5.0.0-1.el7.remi.noarch
php-pragmarx-google2fa-qrcode-1.0.3-1.el7.remi.noarch
php-process-7.2.27-1.el7.remi.x86_64
php-psr-cache-1.0.1-3.el7.remi.noarch
php-psr-container-1.0.0-1.el7.remi.noarch
php-PsrLog-1.1.2-1.el7.remi.noarch
php-psr-simple-cache-1.0.1-1.el7.remi.noarch
php-samyoul-u2f-php-server-1.1.4-1.el7.remi.noarch
php-seld-phar-utils-1.0.2-1.el7.remi.noarch
php-symfony3-common-3.4.30-1.el7.remi.noarch
php-symfony3-translation-3.4.30-1.el7.remi.noarch
php-symfony4-cache-4.1.13-1.el7.remi.noarch
php-symfony4-common-4.1.13-1.el7.remi.noarch
php-symfony4-config-4.1.13-1.el7.remi.noarch
php-symfony4-dependency-injection-4.1.13-1.el7.remi.noarch
php-symfony4-expression-language-4.1.13-1.el7.remi.noarch
php-symfony4-filesystem-4.1.13-1.el7.remi.noarch
php-symfony4-yaml-4.1.13-1.el7.remi.noarch
php-symfony-browser-kit-2.8.52-2.el7.remi.noarch
php-symfony-class-loader-2.8.52-2.el7.remi.noarch
php-symfony-common-2.8.52-2.el7.remi.noarch
php-symfony-config-2.8.52-2.el7.remi.noarch
php-symfony-console-2.8.52-2.el7.remi.noarch
php-symfony-css-selector-2.8.52-2.el7.remi.noarch
php-symfony-debug-2.8.52-2.el7.remi.noarch
php-symfony-dependency-injection-2.8.52-2.el7.remi.noarch
php-symfony-dom-crawler-2.8.52-2.el7.remi.noarch
php-symfony-event-dispatcher-2.8.52-2.el7.remi.noarch
php-symfony-expression-language-2.8.52-2.el7.remi.noarch
php-symfony-filesystem-2.8.52-2.el7.remi.noarch
php-symfony-finder-2.8.52-2.el7.remi.noarch
php-symfony-http-foundation-2.8.52-2.el7.remi.noarch

5

Re: Error in phpMyAdmin - can not update.

And the second part.

php-symfony-http-kernel-2.8.52-2.el7.remi.noarch
php-symfony-polyfill-1.13.1-1.el7.remi.noarch
php-symfony-process-2.8.52-2.el7.remi.noarch
php-symfony-var-dumper-2.8.52-2.el7.remi.noarch
php-symfony-yaml-2.8.52-2.el7.remi.noarch
php-tcpdf-6.3.2-1.el7.remi.noarch
php-tcpdf-dejavu-sans-fonts-6.3.2-1.el7.remi.noarch
php-tidy-7.2.27-1.el7.remi.x86_64
php-twig-1.42.4-1.el7.remi.noarch
php-twig2-2.12.3-1.el7.remi.noarch
php-twig-extensions-1.5.4-1.el7.remi.noarch
php-williamdes-mariadb-mysql-kbs-1.2.8-1.el7.remi.noarch
php-xml-7.2.27-1.el7.remi.x86_64

Re: Error in phpMyAdmin - can not update.

List looks OK.

I don't really understand the problem...

Try a phpinfo page to see what version is displayed
Also:

php -v
which php
rpm -qf $(which php)
rpm -Va php\*

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

7

Re: Error in phpMyAdmin - can not update.

when doing the phpinfo() I get:
Configuration File (php.ini) Path     /etc/opt/rh/rh-php56

and it is PHP Version 5.6.25.

php -v
PHP 7.2.27 (cli) (built: Jan 22 2020 09:31:55) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies

which php
/usr/bin/php

rpm -qf $(which php)
php-cli-7.2.27-1.el7.remi.x86_64

rpm -Va php\*
S.5....T.  c /etc/php.ini
S.5....T.  c /etc/httpd/conf.d/phpMyAdmin.conf
S.5....T.  c /etc/phpMyAdmin/config.inc.php

Also in /etc/opt/rh

I found two version:

drwxr-xr-x. 12 root root 162 Jun 28  2019 rh-php56
drwxr-xr-x. 12 root root 162 Dec 28 15:53 rh-php70

I have the feeling that the person that installed Wordpress did it in some sort of chrooted environment for Apache and that is why PHP doesn't upgrade.

Re: Error in phpMyAdmin - can not update.

Looks like you have a "multiple versions" installation

as described in https://developers.redhat.com/blog/2017 … tion-tips/

So you need to ensure that latest version 7.2 is used by phpMyAdmin


P.S. notice rh-php56 and rh-php70 have reached their end of life, and are no more supported, only rh-php72 and rh-php73 are.

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Error in phpMyAdmin - can not update.

Just had same problem and found this. Thanks