Topic: phpMyAdmin-5.0.1-2.el7.remi.noarch broken with nginx and php-fpm

After upgrading from phpMyAdmin-4.9.4-1.el7.remi.noarch to phpMyAdmin-5.0.1-2.el7.remi.noarch the interface became unusable. Reported upstream, see https://github.com/phpmyadmin/phpmyadmin/issues/15838
Downgrading fixed all the rendering problems.

Re: phpMyAdmin-5.0.1-2.el7.remi.noarch broken with nginx and php-fpm

Hmm... cannot reproduce

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: phpMyAdmin-5.0.1-2.el7.remi.noarch broken with nginx and php-fpm

Tested with both apache + php-fpm (my usual testing config) and ngix + php-fpm

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: phpMyAdmin-5.0.1-2.el7.remi.noarch broken with nginx and php-fpm

Odd, I can reproduce it on two different nginx machines using both the rpm package and the tarball.

Re: phpMyAdmin-5.0.1-2.el7.remi.noarch broken with nginx and php-fpm

Strange,
Perhaps a cache issue ?
Or a bad configuration

On Fedora and EL-8 we use a very simple configuration (everything works out of the bow there)
=> https://git.remirepo.net/cgit/rpms/php/ … dmin.nginx

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: phpMyAdmin-5.0.1-2.el7.remi.noarch broken with nginx and php-fpm

Thanks, that clearly helped. This is the non-working configuration, which works fine, however, with 4.9.4:

location ~* /(dbadmin|logs|pma(494|501))/ {
        root          /var/www/vhosts;
        fastcgi_pass  127.0.0.1:9000;
        fastcgi_index index.php;
        fastcgi_param SCRIPT_FILENAME  $document_root$fastcgi_script_name;
        fastcgi_read_timeout 300;
        include       fastcgi_params;
}

Re: phpMyAdmin-5.0.1-2.el7.remi.noarch broken with nginx and php-fpm

And this is the config that now works with 5.0.1 and 5.1 snapshot (sorry for the double post, the forum software picks up links in the nginx configuration):

location ~* /(dbadmin|logs|pma(494|501))/ {
        root          /var/www/vhosts;
        index index.php;
        location ~ ^/(dbadmin|logs|pma(494|501))/(.+\.php)$ {
                fastcgi_pass  127.0.0.1:9000;
                fastcgi_index index.php;
                fastcgi_param SCRIPT_FILENAME  $document_root$fastcgi_script_name;
                fastcgi_read_timeout 300;
                include       fastcgi_params;
        }
}